You Experience Performance and Logon Problems When You Use Terminal Services

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Article ID: 829485 - View products that this article applies to.
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SYMPTOMS

When you try to start programs by using Terminal Services, you may experience some of or all the following behavior:
  • Your Terminal server sessions may become slow to respond, or sessions may stop responding completely.
  • When you try to log on to the Terminal server by using domain credentials, you receive an error message that is similar to the following:
    No logon server found
  • You may not be able to log on to the Terminal server unless you use credentials for a local user account.
  • The logon dialog box may not appear when you try to log on to the Terminal server.
Note These symptoms may appear gradually over the course of a day.

CAUSE

This problem occurs because the Naifltr.sys filter driver returns an incorrect status code that leads to a resource leak.

RESOLUTION

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows 2000 Server Service Pack 3 (SP3) or a later version installed.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows 2000
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   21-Sep-2003  01:36  5.0.2195.6824      29,712  Mountmgr.sys
   24-Sep-2003  01:19  5.0.2195.6825   1,698,432  Ntkrnlmp.exe     
   24-Sep-2003  01:19  5.0.2195.6825   1,697,792  Ntkrnlpa.exe     
   24-Sep-2003  01:20  5.0.2195.6825   1,718,464  Ntkrpamp.exe     
   24-Sep-2003  01:19  5.0.2195.6825   1,676,096  Ntoskrnl.exe     
Windows NT4 Workstation
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Sep-2003  16:46  4.0.1381.7236     957,568  Ntkrnlmp.exe     
   24-Sep-2003  16:46  4.0.1381.7236     937,216  Ntoskrnl.exe 
Windows NT4 Server
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   24-Sep-2003  16:46  4.0.1381.7236     957,568  Ntkrnlmp.exe     
   24-Sep-2003  16:46  4.0.1381.7236     937,216  Ntoskrnl.exe  
Windows NT4 Terminal Server
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Aug-2003  14:58  4.0.1381.33552    170,256  Gdi32.dll        
   24-Sep-2003  17:14  4.0.1381.33552  1,004,544  Ntkrnlmp.exe     
   24-Sep-2003  17:14  4.0.1381.33552    983,424  Ntoskrnl.exe     
   19-Aug-2003  14:58  4.0.1381.33552    332,048  User32.dll       
   26-Aug-2003  18:31  4.0.1381.33552  1,280,752  Win32k.sys
   19-Aug-2003  14:58  4.0.1381.33552    196,368  Winsrv.dll      

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New Naming Schema for Microsoft Windows Hotfix Packages
For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the Standard Terminology That Is Used to Describe Microsoft Software Updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Properties

Article ID: 829485 - Last Review: February 27, 2014 - Revision: 3.4
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows NT 4.0 Service Pack 6
Keywords: 
kbnosurvey kbarchive kbhotfixserver kbqfe kberrmsg kbwin2000presp5fix kbqfe kbfix kbbug KB829485

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