Windows XP stops responding when you connect to a shared folder

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Article ID: 829909 - View products that this article applies to.
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SYMPTOMS

When you try to use Microsoft Internet Explorer on a Microsoft Windows XP-based computer to connect over your LAN to a shared folder, you may not connect to the network share, and your computer may appear to have stopped responding. However, if you wait for a long time (more than five minutes), the request may time out, and then your computer respond again or you receive a "Page not available" error message.

CAUSE

This issue may occur if Internet Explorer is configured to forward local Intranet requests to a proxy server.

RESOLUTION

To resolve this problem, configure Internet Explorer's proxy server settings to bypass the proxy server for local addresses, and then type your local intranet Fully Qualified Domain Names (FQDNs) in the exclusion list. To do so, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Double-click Internet Options, click the Connections tab, and then click LAN Settings.
  3. In the Local Area Network (LAN) Settings dialog box, under Proxy server, click to select the Bypass proxy server for local address check box.
  4. Click Advanced.
  5. In the Exceptions area, in the Do not use proxy server for addresses beginning with box, type the FQDNs that are used on your Intranet.
  6. Click OK three times, and then close Control Panel.

MORE INFORMATION

Windows XP includes the Web Client service. With the Web Client service, you can seamlessly access WebDav resources over HTTP. When you type a standard UNC path, for example \\server\share, the location is first passed to the Web Client service. The Web Client service tries to connect to http://server/share. If the destination server returns an error, the Web Client service passes the request to the Microsoft Client service, and the computer tries to make a Common Internet File System (CIFS) connection.

If the Web Client service connects to a server that does not host a Web site, the Web Client service receives a Transport Control Protocol (TCP) reset, and the request is passed to the Microsoft Client service. If the server hosts a Web site that does not support WebDav, the Web Client service receives a "Option Not Supported" error message, and the request is passed to the Microsoft Client service.

However, if Internet Explorer is configured to forward local Intranet requests to a proxy server, Internet Explorer forwards Web Client HTTP requests to the proxy server. The proxy server tries to contact the destination server. If the destination server reports an error, the proxy server may not send the expected HTTP error code back to the Web Client. As a result, the Web Client waits for a response from the proxy server until the Web Client times out.

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Article ID: 829909 - Last Review: December 10, 2003 - Revision: 1.1
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbprb KB829909

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