Algunos procedimientos de Windows no funcionan si el servicio de llamada a procedimiento remoto está deshabilitado

En este artículo se proporciona una solución a un problema en el que algunos procedimientos de Windows no funcionan cuando el servicio llamada a procedimiento remoto (RPC) está deshabilitado.

Se aplica a: Windows 10 (todas las ediciones), Windows Server 2012 R2
Número de KB original: 830071

Importante

Este artículo contiene información sobre cómo modificar el Registro. Antes de modificarlo, asegúrese de hacer una copia de seguridad de este y de comprender cómo restaurarlo si hay un problema. Para obtener más información sobre cómo realizar una copia de seguridad, restaurar y editar el Registro, consulte Información del Registro de Windows para usuarios avanzados.

Síntomas

Al reiniciar el equipo que ejecuta Microsoft Windows NT 4.0, Microsoft Windows 2000, Microsoft Windows Server 2003 o Microsoft Windows XP, pueden producirse las condiciones siguientes:

  • No se pueden mover iconos en el escritorio.
  • No se pueden ver las entradas del registro de eventos.
  • Puede abrir la Consola de administración de Microsoft Services (MMC), pero no puede ver ningún servicio en la lista.

Causa

Este problema puede producirse si deshabilita el servicio RPC. Muchos procedimientos del sistema operativo Windows dependen del servicio RPC.

Microsoft recomienda que no deshabilite el servicio RPC.

Solución

Advertencia

Si utiliza incorrectamente el Editor del Registro, puede causar serios problemas que tal vez requieran volver a instalar el sistema operativo. Microsoft no le garantiza que pueda solucionar los problemas que sean consecuencia del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.

Para resolver este problema, siga estos pasos:

  1. Haga clic en Inicio, en Ejecutar, escriba regedt32 y, a continuación, haga clic en Aceptar.
  2. Expanda la clave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RpcSs\del Registro .
  3. Haga doble clic en Inicio, escriba 2 en el cuadro de diálogo Editar valor DWORD y, a continuación, haga clic en Aceptar.
  4. Cierre Editor del Registro y reinicie el equipo.

Si el equipo no se inicia correctamente, puede usar la consola de recuperación para volver a habilitar el servicio RPC. Para usar la consola de recuperación, siga estos pasos:

  1. Inicie el equipo en la consola de recuperación.
  2. En el símbolo del sistema de la consola de recuperación, escriba el Enable RPCSS Service_Auto_Start comando y presione ENTRAR.
  3. En el símbolo del sistema de la consola de recuperación, escriba EXITy, a continuación, presione ENTRAR.
  4. Restart your computer.

Más información

Los siguientes servicios dependen del servicio RPC:

  • Servicio de transferencia inteligente en segundo plano
  • Sistema de sucesos COM+
  • Distributed Link Tacking Client
  • Coordinador de transacciones distribuidas
  • Servicio de fax
  • Servicio de Index Server
  • Agente de directiva IPSec
  • Mensajero
  • Conexiones de red
  • Administrador de trabajos de impresión
  • Almacenamiento protegido
  • Almacenamiento extraíble
  • Agente de escucha del Protocolo de información de enrutamiento (RIP)
  • Enrutamiento y acceso remoto
  • Programador de tareas
  • Telefonía
  • Telnet
  • Windows Installer
  • Instrumental de administración de Windows

Referencias

Para obtener más información sobre cómo usar la consola de recuperación en Windows XP, en Windows 2000 o en Windows Server 2003, consulta ¿Cuáles son las opciones de recuperación del sistema en Windows? y Cómo usar la consola de recuperación en un equipo basado en Windows Server 2003 que no se inicia.