Alguns procedimentos do Windows não funcionarão se o serviço de Chamada de Procedimento Remoto estiver desabilitado

Este artigo fornece uma solução para um problema em que alguns procedimentos do Windows não funcionam quando o serviço RPC (Chamada de Procedimento Remoto) é desabilitado.

Aplica-se a: Windows 10 — todas as edições, Windows Server 2012 R2
Número de KB original: 830071

Importante

Este artigo contém informações sobre como modificar o Registro. Antes de modificar o Registro, certifique-se de fazer o backup e de que saiba restaurá-lo caso ocorra algum problema. Para obter mais informações sobre como fazer backup do Registro, restaurá-lo e modificá-lo, consulte Informações do Registro do Windows para usuários avançados.

Sintomas

Quando você reinicia o computador que executa o Microsoft Windows NT 4.0, Microsoft Windows 2000, Microsoft Windows Server 2003 ou Microsoft Windows XP, as seguintes condições podem ocorrer:

  • Você não pode mover ícones na área de trabalho.
  • Você não pode exibir entradas de log de eventos.
  • Você pode abrir o MMC (Console de Gerenciamento da Microsoft) dos Serviços, mas não pode ver nenhum serviço listado.

Motivo

Esse problema poderá ocorrer se você desabilitar o serviço RPC. Muitos procedimentos do sistema operacional Windows dependem do serviço RPC.

A Microsoft recomenda que você não desabilite o serviço RPC.

Resolução

Aviso

O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. Use o Editor do Registro por sua própria conta e risco.

Para resolver este problema, execute as seguintes etapas:

  1. Clique em Iniciar, clique em Executar, digite regedt32 e clique em OK.
  2. Expanda a chave HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RpcSs\do registro .
  3. Clique duas vezes em Iniciar, digite 2 na caixa de diálogo Editar Valor DWORD e clique em OK.
  4. Feche Editor do Registro e reinicie o computador.

Se o computador não iniciar corretamente, você poderá usar o Console de Recuperação para habilitar novamente o serviço RPC. Para usar o Console de Recuperação, siga estas etapas:

  1. Inicie seu computador no Console de Recuperação.
  2. No prompt de comando do Console de Recuperação, digite o Enable RPCSS Service_Auto_Start comando e pressione ENTER.
  3. No prompt de comando do Console de Recuperação, digite EXITe pressione ENTER.
  4. Restart your computer.

Mais informações

Os serviços a seguir dependem do serviço RPC:

  • Serviço de Transferência Inteligente em Segundo Plano
  • Sistema de Eventos COM+
  • Cliente de aderência de link distribuído
  • Coordenador de transação distribuída
  • Serviços de fax
  • Serviço de indexação
  • Agente de Política IPSec
  • Mensageiro
  • Conexões de Rede
  • Spooler de impressão
  • Armazenamento Protegido
  • Armazenamento Removível
  • Ouvinte do RIP (Protocolo de Informações de Roteamento)
  • Roteamento e acesso remoto
  • Agendador de tarefas
  • Telefonia
  • Telnet
  • Windows Installer
  • Instrumentação de gerenciamento do Windows

Referências

Para obter mais informações sobre como usar o Console de Recuperação no Windows XP, no Windows 2000 ou no Windows Server 2003, confira Quais são as opções de recuperação do sistema no Windows? e Como usar o Console de Recuperação em um computador baseado no Windows Server 2003 que não é iniciado.