Help and Support

Identificativo articolo: 830265 - Ultima modifica: lunedì 24 aprile 2006 - Revisione: 7.1

Visualizzazione di un messaggio di errore "Memoria insufficiente" quando si tenta di salvare un file

Importante In questo articolo vengono fornite le informazioni per ridurre il livello delle impostazioni di protezione o per disattivare le funzionalità di protezione in un computer. È possibile apportare queste modifiche per risolvere un problema specifico. Prima di apportare tali modifiche, si consiglia di valutare i rischi derivanti dall'implementazione di questa soluzione in un ambiente particolare. Se si sceglie di implementare questa soluzione, adottare ogni ulteriore procedura che faciliti la protezione del sistema.

Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

Sintomi

È possibile che si verifichi uno o più dei seguenti sintomi:
  • In Microsoft Outlook non è possibile aprire il file delle cartelle personali (pst) in una condivisione di rete.
  • In Microsoft Office non è possibile salvare documenti in una condivisione del file system distribuito (DFS).
  • Quando si modificano file su un file server di rete, non è possibile effettuare il salvataggio e viene visualizzato un messaggio di errore analogo al seguente, anche se sull'unità di rete lo spazio disponibile su disco è sufficiente:
    Disco pieno. Risorse insufficienti.
  • Vengono visualizzati uno o più messaggi di errore del programma analoghi ai seguenti:
    • Quando si tenta di salvare un file in Microsoft Excel:

      Messaggio 1
      Documento non salvato.
      Messaggio 2
      Disco pieno.
    • Quando si tenta di salvare un file nello stesso percorso in Microsoft Word:

      Messaggio 1
      Impossibile salvare: memoria o spazio su disco esauriti unità:\percorso\nomefile
      Messaggio 2
      Lo spazio su disco è esaurito oppure ci sono troppi file aperti.
      Nota È possibile salvare file RTF (Rich Text Format) da Word sull'unità mappata, ma non è possibile salvare file doc.
    • Quando si tenta di accedere a un file in Microsoft PowerPoint:

      Messaggio 1
      File di sola lettura.
      Messaggio 2
      Si è verificato un errore durante l'accesso al file nomefile.
    • In Outlook:
      Impossibile avviare il servizio promemoria. I promemoria non verranno visualizzati. Impossibile salvare il file <Lettera unità>:\Outlook\Nomefile.pst a causa di un errore. Chiudere e riavviare tutte le applicazioni di posta elettronica.
    • Quando si tenta di accedere a un file personale in Outlook:
      Impossibile espandere la cartella. Impossibile salvare il file (Nomefile.pst) a causa di un errore. Chiudere e riavviare tutte le applicazioni di posta elettronica.
    • Quando si tenta di salvare un file in Microsoft Paint:
      Errore sconosciuto durante l'accesso a Unità:\cartella\nomefile.bmp
      Nota È possibile salvare questo file nel formato JPEG (Joint Photographic Experts Group), TIFF (Tagged Image File Format) o GIF (Graphics Interchange Format). Solo i file BMP (Bitmap) causano problemi di salvataggio in Paint.
    • Quando si tenta di salvare un file in Adobe PageMaker 7.0:

      Messaggio 1
      Disco pieno.
      Messaggio 2
      Parametro non valido.
    • Quando si tenta di salvare un file, è possibile che da altri programmi venga visualizzato un messaggio di errore analogo a uno dei seguenti:

      Messaggio 1
      Disco pieno o memoria esaurita.
      Messaggio 2
      Accesso negato.
      Messaggio 3
      Documento non salvato.
      Messaggio 4
      Disco pieno o memoria insufficiente.
      È inoltre possibile che venga restituito un messaggio per indicare che il file è già in uso. Questo messaggio può essere visualizzato anche se in realtà il file non è attualmente utilizzato.
  • A volte un file non viene salvato. Sebbene non vengano visualizzati errori, il file sembra essere stato salvato correttamente.
  • Possono inoltre verificarsi i seguenti sintomi:
    1. Viene visualizzato il messaggio:

      ID evento 2020 INVALID_PARAMETER

    2. L'operazione di arresto o riavvio del computer non viene completata correttamente. Viene invece visualizzata una schermata nera con un puntatore intermittente o nessun puntatore e il sistema rimane in questa condizione.
I sintomi descritti in questo articolo si applicano ai seguenti sistemi operativi client:
  • Microsoft Windows XP
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT 4.0 Workstation
  • Microsoft Windows 98
  • Microsoft Windows 95

Cause

Questi problemi possono verificarsi per i seguenti motivi:
  • Nel computer è installata un'applicazione non Microsoft per la quale viene utilizzato un driver filtro in modalità kernel obsoleto.
  • Un driver filtro del file system di terze parti interferisce con altri driver filtro.
  • Il driver filtro VERITAS Backup Exec Advanced Open File Option (Vsp.sys) viene caricato insieme a un driver filtro antivirus, ad esempio uno dei driver filtro di Symantec AntiVirus Corporate Edition 8.0 elencati di seguito:
    • Symevent.sys (Symantec Event Library)
    • Navap.sys (Symantec AutoProtect)
    La causa di questo problema è il file SystemRoot\system32\drivers\Vsp.sys.

Risoluzione

Per risolvere questo problema, rivolgersi al produttore del driver filtro per verificare se è disponibile un driver filtro aggiornato.

Per ulteriori informazioni, visitare i seguenti siti Web VERITAS:
http://www.veritas.com/it/IT/services/support/ (http://www.veritas.com/it/IT/services/support/)
http://seer.support.veritas.com/docs/264490.htm? (http://seer.support.veritas.com/docs/264490.htm?) (informazioni in lingua inglese)
Per scaricare l'aggiornamento di VERITAS, visitare il seguente sito Web VERITAS:
http://ftp.support.veritas.com/pub/support/products/ (http://ftp.support.veritas.com/pub/support/products/)
Microsoft fornisce informazioni su come contattare altri produttori allo scopo di facilitare l'individuazione del supporto tecnico. Queste informazioni sono soggette a modifica senza preavviso. Microsoft non si assume alcuna responsabilità sull'accuratezza delle informazioni relative al contatto con altri produttori.

Workaround

Per risolvere il problema relativo al driver Vsp.sys, attenersi alla procedura appropriata:

Avviso L'esecuzione di questa procedura potrebbe rendere il computer o la rete più vulnerabile agli attacchi di utenti malintenzionati o di programmi software dannosi, quali i virus. Non è consigliabile utilizzare questa soluzione, tuttavia queste informazioni vengono fornite per consentire all'utente di implementarla a propria discrezione. L'utilizzo di questa soluzione avviene pertanto a rischio esclusivo dell'utente.
  • Rimuovere il driver Vsp.sys o VERITAS Remote Agent che consente la rimozione automatica del driver Vsp.sys.
  • Rimuovere il client VERITAS NetBackup 4.5, quindi installare la versione 3.4.1 del client NetBackup che non contiene il driver Vsp.sys.
  • Rimuovere il software VERITAS Remote Agent e reinstallarlo senza Advanced Open File Option.
  • Installare la versione con patch più recente di VERITAS Advanced Open File Option.

    Nota VERITAS Advanced Open File Option è un componente facoltativo del software di backup di VERITAS non obbligatorio per l'esecuzione di backup regolari.
  • Modificare il Registro di sistema in modo da disattivare temporaneamente il driver filtro Vps.sys, quindi riavviare il computer. Se si utilizza Windows 2000, utilizzare l'editor del Registro di sistema per modificare la sottochiave.

    Avviso L'errato utilizzo dell'editor del Registro di sistema può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. I rischi correlati all'utilizzo dell'editor del Registro di sistema sono di esclusiva responsabilità dell'utente.

    Per disattivare manualmente il servizio Advanced Open File Option, attenersi alla seguente procedura:
    1. Individuare la seguente sottochiave del Registro di sistema:
      \HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VSP\Start
    2. Impostare il valore Start su 0x4.

      Questa impostazione impedirà il caricamento del driver al riavvio del computer.

      Importante Se viene disattivato solo il driver, è possibile che il computer si arresti al riavvio successivo e che venga visualizzato l'errore "STOP 0x7B INACCESSIBLE_BOOT_DEVICE". Questo errore si verifica poiché è possibile che al driver Vsp.sys, o al driver precedente Otman5.sys, venga fatto riferimento in una o entrambe le seguenti sottochiavi del Registro di sistema:
      \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E967-E325-11CE-BFC1-08002BE10318}\UpperFilters
      \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{71A27CDD-812A-11D0-BEC7-08002BE2092F}\UpperFilters
      Se si utilizza Windows 2000, utilizzare l'editor del Registro di sistema per modificare la sottochiave. Eliminare le righe che fanno riferimento al driver Vsp.sys.
Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
816071  (http://support.microsoft.com/kb/816071/ ) Informazioni sulla disattivazione temporanea del driver filtro in modalità kernel

Informazioni

Il driver Vsp.sys consente la sospensione del processo di backup e la memorizzazione nella cache delle scritture file in maniera automatica nel corso del processo. Il driver Vsp.sys si trova nel percorso %systemroot%\SYSTEM32\DRIVERS. Il problema interessa le versioni di file 1.2:0.0 e 1.0:0.0.

Il driver è incluso in VERITAS NetBackup o in VERITAS BackupExec per Windows 9.0 (Backup Exec Advanced Open File Option). Questo file viene installato nel sistema anche da VERITAS Remote Agent.

Note
  • È possibile che con l'aggiornamento all'ultima versione di VERITAS NetBackup o di VERITAS BackupExec il driver Vsp.sys non venga aggiornato.
  • È possibile che la rimozione del software VERITAS non comporti la rimozione del driver Vsp.sys.
  • Per verificare che il driver Vsp.sys venga rimosso, visualizzare l'output dell'utilità Drivers.exe o dell'utilità Pstat.exe. Il driver Vsp.sys non dovrà essere incluso nell'output di queste utilità.

VERITAS NetBackup

La versione del client VERITAS NetBackup 3.4.1ga non causa questo problema poiché il driver Vsp.sys non viene installato. È possibile, invece, che il problema venga introdotto con l'aggiornamento al client VERITAS 4.5 Feature Pack 4.

Network Monitor

In un'acquisizione di Network Monitor è possibile visualizzare errori quando si svuota la cache. Dopo la scrittura di un file, viene inviata una richiesta SMB C_Flush_File dal client al server. Il server risponde con l'errore STATUS_INVALID_PARAMETER seguente:
Richiesta del client:
SMB: C Flush File
Risposta del server:
SMB: R flush file - NT error, System, Error, Code = (13) STATUS_INVALID_PARAMETER
SMB: NT status code = 0xC000000D, Facility = System, Severity = Error, Code = (13) STATUS_INVALID_PARAMETER
SMB: NT Status Severity Code = Error
SMB: NT Status Customer Code = 0 (0x0)
SMB: NT Status Reserved Bit = 0 (0x0)
SMB: NT Status Facility = System
SMB: NT Status Code System Error = STATUS_INVALID_PARAMETER
Il comando SMB_COM_FLUSH consente di assicurarsi che tutti i dati e tutte le informazioni di allocazione per il file corrispondente siano stati scritti in un'area di archiviazione stabile. La risposta non viene inviata finché non vengono completate le operazioni di scrittura.

Note
  • I problemi descritti nella sezione "Sintomi" si verificano in genere dopo molte ore o molti giorni di attività del file server.
  • I documenti di WordPad o del Blocco note possono essere salvati nella stessa condivisione di rete senza problemi.
  • Il problema si verifica quando nelle applicazioni vengono utilizzati file temporanei durante il processo di salvataggio.
    Quando si salva un file, in quasi tutte le applicazioni di Office vengono effettuate le seguenti operazioni:
    1. Apertura del file di origine.
    2. Apertura di una copia temporanea del file.
    3. Modifica della copia temporanea.
    4. Scaricamento di tutte le modifiche nel file temporaneo e successiva sostituzione del file di origine originale utilizzando il file temporaneo.
Importante Un programma antivirus è progettato per consentire la protezione del computer dai virus. È sconsigliabile scaricare o aprire file da origini non attendibili, visitare siti Web non attendibili oppure aprire allegati di posta elettronica quando il programma antivirus è disattivato. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
129972  (http://support.microsoft.com/kb/129972/ ) Virus informatici: descrizione, prevenzione, ripristino

Riferimenti

Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
822219  (http://support.microsoft.com/kb/822219/ ) Degrado delle prestazioni del server e ritardi quando si utilizzano file memorizzati su un file server
816071  (http://support.microsoft.com/kb/816071/ ) Informazioni sulla disattivazione temporanea del driver filtro in modalità kernel
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti. Microsoft non rilascia alcuna garanzia implicita o esplicita relativa alle prestazioni o all'affidabilità di tali prodotti.

Le informazioni in questo articolo si applicano a
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2000 Standard Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office 2000 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft Outlook 2000 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft PowerPoint 2000 Standard Edition
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2000 Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Server 4.0 Standard Edition
Chiavi: 
kbtshoot kbprb KB830265
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Traduzione articoli