A caixa de diálogo Confirmar substituição de ficheiro é apresentada quando o ficheiro de destino não existe

Traduções de Artigos Traduções de Artigos
Artigo: 830380 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando tenta utilizar o Explorador do Windows para copiar um ficheiro encriptado a partir de um servidor baseado no Microsoft Windows Server 2003, poderá detectar um dos seguintes sintomas:
  • Quando copia o ficheiro encriptado para um ficheiro de destino local, o ficheiro não copia. Não lhe for pedido com uma caixa de diálogo Confirmar substituição de ficheiro quando já existe um ficheiro local que tem o mesmo nome do ficheiro que pretende copiar.
  • Quando copia o ficheiro encriptado para um ficheiro de destino que está localizado no mesmo servidor baseado no Windows Server 2003, a operação de cópia de ficheiro não tiver êxito. Incorrectamente apresentada uma caixa de diálogo Confirmar substituição de ficheiro quando não existe nenhum ficheiro local que tem o mesmo nome do ficheiro que pretende copiar.
  • Quando copia ou arraste o ficheiro encriptado para um ficheiro de destino que está localizado num do WebDAV a partilha num servidor baseado no Microsoft Windows 2000 Server ou num servidor baseado no Windows Server 2003, incorrectamente receberá uma caixa de diálogo Confirmar substituição de ficheiro . Este comportamento ocorre quando não existe nenhum ficheiro de destino tem o mesmo nome do ficheiro que pretende copiar.
Estes problemas também poderão afectar todos os programas que utilizam a função CopyFileEX com a opção COPY_FILE_FAIL_IF_EXISTS seleccionada.

Causa

Este problema, primeiro que é descrito em "Sintomas" secção ocorre porque a função de Win32 CopyFileEx que tem a opção COPY_FILE_FAIL_IF_EXISTS seleccionada incorrectamente com êxito se o ficheiro de destino local já existe.

O segundo problema descrito na secção "Sintomas" ocorre porque a função de Win32 CopyFileEx que tem a opção COPY_FILE_FAIL_IF_EXISTS seleccionada incorrectamente não funciona se o ficheiro de destino remoto não existe.

O terceiro problema descrito na secção ? Sintomas ? ocorre porque a função de API do Win32 DuplicateEncryptionInfoFile() cria um ficheiro temporário. Quando a função DuplicateEncryptionInfoFile() falha, deixa atrás de um ficheiro de 0-kilobytes (kb). Quando copiar o ficheiro encriptado, poderá detectar o erro descrito na secção "Sintomas".

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Windows XP. Para obter informações adicionais, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322389Como obter o Windows XP service pack mais recente

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version        Size    File name      Platform
   ------------------------------------------------------------------
   18-Nov-2003  03:15  5.1.2600.1321  55,296  Feclient.dll   IA-64
   18-Nov-2003  17:20  5.1.2600.1321  18,944  Wfeclient.dll  x86

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a" deste artigo. Este problema foi corrigido pela primeira vez no Microsoft Windows XP Service Pack 2.

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 830380 - Última revisão: 29 de agosto de 2007 - Revisão: 5.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB830380 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 830380

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com