Article ID: 830407 - Last Review: October 26, 2006 - Revision: 3.5

Offline caching of network files and folders may take longer than expected in Windows 2000

Hotfix download is availableHotfix Download Available
View and request hotfix downloads
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows Registry

On This Page

Expand all | Collapse all

SYMPTOMS

When you use the Administratively assigned offline files Group Policy setting to assign files or folders for offline caching, Microsoft Windows 2000 enumerates these files and folders for caching, and the process may take longer than you expect.

CAUSE

This problem occurs because when Windows 2000 processes the policy, Windows tries to locate and cache every new file inside the network folders that are set for offline caching. This action involves a lengthy enumeration of the remote file system namespace.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   27-Jan-2004  08:14  5.0.2195.6888     101,136  Cscdll.dll       
   27-Jan-2004  08:14  5.0.2195.6894     242,448  Cscui.dll        
   23-Dec-2003  20:00  5.0.2195.6888     408,752  Mrxsmb.sys
   23-Dec-2003  20:00  5.0.2195.6888     169,776  Rdbss.sys
Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
To activate the hotfix after installation, you must add the following registry key value to the registry:

Registry subkey: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache\
Entry: EconomicalAdminPinning
Type: DWORD
Value: 1 or 0

If you set the EconomicalAdminPinning value to 1, you turn on the hotfix. A value of 0 (zero) turns off the hotfix. When you set the EconomicalAdminPinning value to 1, the policy uses more conservative processes to update administratively-pinned folders. If the cache already contains an entry for the folder that is specified in the policy, the policy does not try to process that folder. If the cache does not contain an entry for the folder that is specified in the policy, the policy pins the folder and its contents.

Important With this conservative behavior, client computers must now rely on a full synchronization at some other time to pick up new files inside previously pinned folders. Typically, this full synchronization occurs when you manually synchronize through the user interface or when you synchronize at logon or logoff with the "sync all files" options enabled.

Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache\
  3. On the Edit menu, point to New, and then click DWORD value.
  4. Type EconomicalAdminPinning, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 1, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915  (http://support.microsoft.com/kb/816915/ ) New file naming schema for Microsoft Windows software update packages
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB830407
 

Article Translations