Article ID: 830470 - Last Review: October 26, 2005 - Revision: 1.5

Delays May Occur During MCMS Authentication When You Use Site Server SQL-based Membership Authentication

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SYMPTOMS

If you use Site Server SQL-based Membership authentication through Microsoft Content Management Server (MCMS) 2001, delays may occur during authentication for each request to MCMS pages.

CAUSE

If you are using Site Server SQL-based Membership authentication through MCMS 2001, and the user name is a membership user account that does not exist as a Microsoft Windows NT account, a call from the ReAuthFilt ISAPI filter to the LookupAccountName function returns no results for a long time. This delay has a non-negligible effect on performance for each request. The LookupAccountName function sometimes takes up to 60 seconds to complete in customer environments. When Site Server is enabled for SQL-based Membership authentication, the code for the domain account lookup is not necessary.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ------------------------------------------------------------------
   14-Oct-2003  00:23  4.10.1141.0     1,150,464  Aeserverobject.dll 
Note Because of file dependencies, this update requires Microsoft Content Management Server 2001 Security Release Package 2 (SRP2).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

APPLIES TO
  • Microsoft Content Management Server 2001 Enterprise Edition
  • Microsoft Content Management Server 2001 Developer Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbfix kbcontentmgtserv2001presp2fix kbbug KB830470
 

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