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A file in a network folder opens as read-only or returns an error message that the file type cannot be recognized

Article ID:830903
Last Review:May 17, 2007
Revision:2.7
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SYMPTOMS

If you open a network folder in Microsoft Windows Explorer, and then try to open a file in that folder, the document may open as read-only or may return an error message that the file type cannot be recognized. For example, if you open a network folder over a slow link, click a file such as a Microsoft Office PowerPoint 2003 presentation, and then quickly double-click to open the file, the file may open as read-only.

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CAUSE

This problem occurs because Windows Explorer locks and reads the file to extract the thumbnail that represents the document to populate the Details window of the Show Common Tasks folder view.

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RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 (http://support.microsoft.com/kb/322389/EN-US/) How to obtain the latest Windows XP service pack

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Hotfix information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows


A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   08-Dec-2003  13:40  6.0.2800.1325  8,241,664  Shell32.dll
After install this hotfix, to enable this feature, you must add the following registry key:
1.Locate, and then click the following key in the registry:
For a per-machine policy:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

For a per-user policy:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
2.On the Edit menu, point to New, and then click DWORD Value.
3.Type NoDetailsThumbnailOnNetwork, and then press ENTER.
4.On the Edit menu, click Modify.
5.Type 1, and then click OK.

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WORKAROUND

To work around this problem without installing the hotfix that is described in the "Resolution" section in this article, follow these steps:
1.In Windows Explorer, open the network folder that contains the file that you are trying to open or save.
2.On the Tools menu, click Folder Options.
3.Click Use Windows classic folders, and then click OK.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

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MORE INFORMATION

This problem can occur to any program that uses the StgOpenStorage function to open the file over a slow link. For example, if you use the Sysinternals Filmon utility when the problem is occurring in Power Point, Powerpnt.exe does not lock the file:
206278  3:16:21 PM       POWERPNT.EXE:3304  LOCK   NOT GRANTED Offset: 2147483539 Length: 20
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition

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Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB830903

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