ネットワーク フォルダ内のファイルを開くと、ファイルが読み取り専用で開かれるか、ファイルの種類を認識できないというエラー メッセージが表示される

文書翻訳 文書翻訳
文書番号: 830903 - 対象製品
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

目次

現象

エクスプローラで、ネットワーク フォルダを開き、そのフォルダに格納されているファイルを開こうとすると、ファイルが読み取り専用で開かれるか、ファイルの種類を認識できないというエラー メッセージが表示されることがあります。たとえば、低速リンクで接続している環境でネットワーク フォルダを開き、Microsoft Office PowerPoint 2003 で作成したプレゼンテーションなどのファイルをクリックして選択してからダブルクリックして開くと、ファイルが読み取り専用で開かれることがあります。

原因

この問題は、エクスプローラが、共通のタスクを表示するフォルダ ビューの詳細ウィンドウに表示される、ドキュメントを表す縮小表示を展開するために、ファイルをロックして読み込むことが原因で発生します。

解決方法

Service Pack の情報

この問題を解決するには、Microsoft Windows XP の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322389 最新の Windows XP Service Pack を入手する方法

修正プログラムの情報

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows XP Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/?ws=support
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付            時刻    バージョン        サイズ       ファイル名
   ---------------------------------------------------------
   08-Dec-2003  13:40  6.0.2800.1325  8,241,664  Shell32.dll
この修正プログラムのインストール後、機能を有効にするには、次のレジストリ キーを追加する必要があります。
  1. レジストリで次のキーを見つけてクリックします。
    コンピュータごとにポリシーを設定する場合

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


    ユーザーごとにポリシーを設定する場合

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
  2. [編集] メニューの [新規] をポイントし、[DWORD 値] をクリックします。
  3. NoDetailsThumbnailOnNetwork と入力し、Enter キーを押します。
  4. [編集] メニューの [修正] をクリックします。
  5. 1 と入力し、[OK] をクリックします。

回避策

この資料の「解決方法」に記載されている修正プログラムをインストールせずにこの問題を回避するには、次の手順を実行します。
  1. エクスプローラで、開く (または保存する) ファイルが含まれているネットワーク フォルダを開きます。
  2. [ツール] メニューの [フォルダ オプション] をクリックします。
  3. [従来の Windows フォルダを使う] をクリックし、[OK] をクリックします。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。 この問題は、Microsoft Windows XP Service Pack 2 で最初に修正されました。

詳細

この問題は、低速リンクで接続している環境でファイルを開くのに StgOpenStorage 関数を使用するプログラムで発生する可能性があります。このため、この問題が Power Point で発生している場合、Sysinternals Filmon ユーティリティを使用すれば Powerpnt.exe でファイルがロックされることはありません。
206278  3:16:21 PM       POWERPNT.EXE:3304  LOCK   NOT GRANTED Offset: 2147483539 Length: 20
関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

プロパティ

文書番号: 830903 - 最終更新日: 2006年3月24日 - リビジョン: 2.4
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
キーワード:?
kbhotfixserver kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB830903
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com