แฟ้มในโฟลเดอร์เครือข่ายเปิดเป็นแบบอ่านอย่างเดียว หรือส่งกลับข้อผิดพลาดที่ไม่มีรู้จักชนิดของแฟ้ม

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 830903 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

ถ้าคุณเปิดโฟลเดอร์เครือข่ายใน Microsoft Windows Explorer และพยายามเปิดแฟ้มในโฟลเดอร์นั้น เอกสารอาจเปิดเป็นแบบอ่านอย่างเดียว หรืออาจส่งคืนข้อความแสดงข้อผิดพลาดที่ไม่มีรู้จักชนิดของแฟ้ม ตัวอย่างเช่น ถ้าคุณเปิดโฟลเดอร์เครือข่ายผ่านการเชื่อมโยงที่ล่าช้า คลิกแฟ้มเช่นการนำเสนอ Microsoft Office PowerPoint 2003 แล้ว คลิกสองอย่างรวดเร็วครั้งเพื่อเปิดแฟ้ม แฟ้มอาจเปิดเป็นแบบอ่านอย่างเดียว

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจาก Windows Explorer ถูกล็อก และอ่านไฟล์สำหรับการขยายรูปขนาดย่อที่แสดงเอกสารไปยังการเติมข้อมูลในหน้าต่างรายละเอียดของมุมมองโฟลเดอร์ทั่วไปของงานที่แสดง

การแก้ไข

ข้อมูล Service Pack

เมื่อต้องการแก้ปัญหานี้ ให้ขอรับ Service Pack ใหม่ล่าสุดสำหรับ Microsoft Windows XP สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
322389วิธีการขอรับ Service Pack ล่าสุดของ Windows XP

ข้อมูลโปรแกรมแก้ไขด่วน

สิ่งสำคัญนี้ส่วน วิธี หรืองานประกอบด้วยขั้นตอนที่บอกวิธีการแก้ไขรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีไม่ถูกต้อง ดังนั้น โปรดตรวจสอบให้แน่ใจว่าคุณได้ทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองรีจิสทรีก่อนทำการปรับเปลี่ยน เพื่อที่คุณจะสามารถคืนค่ารีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูลและคืนค่ารีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
322756วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows


โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานแล้ว อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มีเป้าหมายเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น นำโปรแกรมแก้ไขด่วนนี้ไปใช้กับระบบที่พบปัญหานี้เท่านั้น โปรแกรมแก้ไขด่วนนี้อาจได้รับการทดสอบเพิ่มเติม ดังนั้น หากคุณไม่ได้รับความเสียหายรุนแรงจากปัญหานี้ เราขอแนะนำให้คุณรอการปรับปรุงซอฟต์แวร์ถัดไปที่มีโปรแกรมแก้ไขด่วนนี้

หากมีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" อยู่ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น โปรดติดต่อฝ่ายบริการสนับสนุนลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ:หากเกิดปัญหาอื่น ๆ หรือ ถ้ามีการแก้ไขปัญหาเป็นสิ่งจำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะเกิดขึ้นเมื่อมีคำถามและประเด็นการสนับสนุนอื่นๆ ซึ่งไม่จัดอยู่ในโปรแกรมแก้ไขด่วนเฉพาะที่กล่าวถึงนี้ สำหรับรายการของหมายเลขโทรศัพท์ของฝ่ายบริการและการสนับสนุนลูกค้าของ Microsoft ทั้งหมด หรือถ้าต้องการสร้างคำขอรับการสนับสนุนแยกต่างหาก โปรดเข้าสู่เว็บไซต์ของ Microsoft ต่อไปนี้::
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ:แบบฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" แสดงภาษาในโปรแกรมแก้ไขด่วนมีอยู่ หากคุณไม่เห็นภาษาของคุณ เป็นเพราะไม่มีโปรแกรมแก้ไขด่วนสำหรับภาษานั้น

โปรแกรมแก้ไขด่วนรุ่นภาษาอังกฤษนี้มีแอตทริบิวต์ของแฟ้ม (หรือแอตทริบิวต์ของแฟ้มหลังจากนั้น) ซึ่งแสดงอยู่ในตารางต่อไปนี้ วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้ม ข้อมูลจะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้โซนเวลาแท็บในเครื่องมือ'วันและเวลา'ใน'แผงควบคุม'
   Date         Time   Version        Size       File name
   ---------------------------------------------------------
   08-Dec-2003  13:40  6.0.2800.1325  8,241,664  Shell32.dll
หลังจากติดตั้งโปรแกรมแก้ไขด่วนนี้ การเปิดใช้งานลักษณะการทำงานนี้ คุณต้องเพิ่มคีย์รีจิสทรีต่อไปนี้:
  1. ค้นหา และคลิกที่คีย์ต่อไปนี้ในรีจิสตรี::
    สำหรับกรมธรรม์สำหรับแต่ละเครื่องจักร:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer


    โยบายที่ผู้ใช้:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
  2. ในการแก้ไขเมนู ให้ชี้ไปที่ใหม่แล้ว คลิกค่า DWORD.
  3. ประเภท:NoDetailsThumbnailOnNetworkแล้ว กด ENTER
  4. ในการแก้ไขเมนู คลิกปรับเปลี่ยน.
  5. ประเภท:1แล้ว คลิกตกลง.

การหลีกเลี่ยงปัญหา

เมื่อต้องการแก้ไขปัญหานี้ โดยไม่มีการติดตั้งโปรแกรมแก้ไขด่วนที่อธิบายไว้ในส่วน "การแก้ปัญหา" ในบทความนี้ ดำเนินการดังต่อไปนี้:
  1. ใน Windows Explorer เปิดโฟลเดอร์เครือข่ายที่ประกอบด้วยแฟ้มที่คุณกำลังพยายามเปิด หรือบันทึก
  2. บนเมนูเครื่องมือ คลิกตัวเลือกโฟลเดอร์
  3. คลิกที่โฟลเดอร์แบบคลาสสิที่ใช้ Windows และจากนั้น คลิกตกลง

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "นำไปใช้กับ" ของบทความนี้ปัญหานี้ได้รับการแก้ไขครั้งแรกใน Microsoft Windows XP Service Pack 2

ข้อมูลเพิ่มเติม

ปัญหานี้อาจเกิดขึ้นกับโปรแกรมที่ใช้ในStgOpenStorageฟังก์ชันเพื่อเปิดแฟ้มบนการเชื่อมโยงที่ล่าช้า ตัวอย่างเช่น ถ้าคุณใช้โปรแกรมอรรถประโยชน์ Sysinternals Filmon เมื่อเกิดปัญหาในการใช้พลังงานจุด Powerpnt.exe ไม่ล็อกแฟ้ม:
206278  3:16:21 PM       POWERPNT.EXE:3304  LOCK   NOT GRANTED Offset: 2147483539 Length: 20
สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
824684คำอธิบายของคำศัพท์มาตรฐานที่ใช้เพื่ออธิบายปรับปรุงซอฟต์แวร์ของ Microsoft

คุณสมบัติ

หมายเลขบทความ (Article ID): 830903 - รีวิวครั้งสุดท้าย: 14 มกราคม 2554 - Revision: 2.0
ใช้กับ
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbmt KB830903 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:830903

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com