Einige Geräte werden nicht erkannt, wenn Sie mehrere Medien IEEE 1394 (FireWire) verwendete(n)

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 830987 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Wenn Sie über mehrere Geräte auf demselben Computer verfügen, die den seriellen Institute of Electrical- und den seriellen Electronic Engineers (IEEE)-1394-Hochgeschwindigkeitsbus verwenden (der alternativ als FireWire bezeichnet wird) (der alternativ als FireWire bezeichnet wird) werden einige Geräte korrekt nicht erkannt.

Wenn Sie nur eines dieser Geräte verwenden lädt Plug & Play den richtigen Treiber und das Gerät funktioniert ordnungsgemäß. Wenn Sie zwei IEEE 1394-Geräte auf Ihrem Computer verwenden, wird der Treiber einem zweit Mal jedoch nicht aufgerufen. Nur das erste Gerät wird als daher erkannt.

Ursache

Wenn die Geräteide für die IEEE 1394-Geräte vergleichbar sind, kann dieses Problem auftreten. Wenn das erste Gerät ein eindeutiges ID (UID) von 200000002A30B00 hat und wenn das zweite Gerät über ein UID von 210000001A30B00 verfügt, kann dieses Problem beispielsweise auftreten.

Das Gerät-1394-Enumerator (1394bus.sys) verfügt über eine Gerätetabelle, die als eine Hash-Tabelle implementiert wird, die in einem Array gespeichert ist. Die Hash-Funktion berechnet ein Hash, das auf dem UID des Geräts basiert. Wenn sich ein Konflikt (falls die Hash-Werte identische sind, die für jedes Gerät berechnet werden) befindet, wird eine größere Tabelle reserviert.

Wenn zwei Geräteide vergleichbar sind, erzeugt die Berechnung von Hash denselben Wert für beide Geräte. Eine Kollision tritt daher auf, und der Code ordnet größere Array bis zu der Tabellengrößenbeschränkung neu ständig zu. Das zweite Gerät wird nicht erkannt, da der Hashtabelle seinen Grenzwert für Größe erreicht, bevor der neue Eintrag für das zweite Gerät an der Tabelle hinzugefügt wird.

Lösung

Windows XP

Hotfix-Informatione

Installieren Sie das neueste Service Pack für Windows XP, um dieses Problem zu beheben Klicken Sie auf die folgende Artikelanzahl, um weitere Informationen zu erhalten, um den Artikel der Microsoft Knowledge Base zu lesen:
322389 Wie Installieren des neusten Service Pack für Windows XP

Voraussetzungen

Sie, um dieses Hotfix anzuwenden, muss Windows XP Service Pack 1 ( 1) sein, dass installiert wird von Ihnen.

Starten Sie neu Anforderung

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten

Hotfix-Ersatzinformation

Dieser Hotfix ersetzt keine anderen Hotfixes

Dateiinformation

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf Die Datumangaben und die Uhrzeit-Angaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert Verwenden Sie in der Systemsteuerung Datum und Uhrzeit in Programm die Registerkarte Zeitzone, um den Unterschied zwischen UTC und lokaler Zeit zu suchen.
Windows XP Itanium-Basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinamDateiversionDateigrößeDatuUhrzeiPlattform
1394bus.sys5.1.2600.1317190,97606-Nov-200302 : 42IA-64

Windows XP mal 86-basierten Versionen
Tabelle minimierenTabelle vergrößern
DateinamDateiversionDateigrößeDatuUhrzeiPlattform
1394bus.sys5.1.2600.131751,07206-Nov-200302 : 42X

Windows Server 2003

Hotfix-Informatione

Ein unterstütztes Hotfix ist von Microsoft verfügbar. Dieses Hotfix nur das Problem zu beheben, das in diesem Artikel beschrieben wird ist jedoch vorgesehen. Wenden Sie dieses Hotfix nur auf Systemen an, bei denen dieses spezielle Problem auftritt. Dieses Hotfix empfängt möglicherweise zusaetzlich Test. Wenn Sie von diesem schwerwiegenden Problem betroffen sind nicht empfehlen wir, dass Sie auf das nächste Softwareupdate warten, das dieses Hotfix enthält.

Wenn das Hotfix verfügbar zu Download ist, ist ein "verfügbar Download" Hotfix-Abschnitt an dem Anfang dieses Artikels der Microsoft Knowledge Base. Wenden Sie sich an Microsoft Customer Service und Support, um das Hotfix zu erhalten, wenn dieser Abschnitt nicht angezeigt wird.

Hinweis: Sie müssen eine separate Dienstanfrage eventuell erstellen, wenn zusätzliche Probleme auftreten oder wenn alle Problembehandlung erforderlich ist. Die üblichen Supportkosten werden für zusätzliche Supportfragen und Probleme, die dieses bestimmte Hotfix nicht kennzeichnen, gelten. Besuchen Sie das folgende Website von Microsoft eine vollständige Support- oder von Telefonnummern und eine vollständige Microsoft Customer Service-Liste oder von Telefonnummern eine separate Dienstanfrage zu erstellen:
http://support.microsoft.com/contactus/?ws=support
Hinweis: die Sprachen, für die das Hotfix verfügbar ist, werden in dem Formular angezeigt "ob Hotfix den Download verfügbar durchführt". Wenn Sie Ihre Sprache nicht anzeigen, befindet sich es, da ein Hotfix für die Sprache nicht verfügbar ist.

Voraussetzungen

Es gelten keine Voraussetzungen

Neustar

Sie müssen den Computer nach der Installation dieses Hotfixes neu starten

Ersetzte Hotfixe

Dieser Hotfix ersetzt keine anderen Hotfixes

Dateiinformation

Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf Die Datumangaben und die Uhrzeit-Angaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert Verwenden Sie in der Systemsteuerung Datum und Uhrzeit in Programm die Registerkarte Zeitzone, um den Unterschied zwischen UTC und lokaler Zeit zu suchen.
Windows Server 2003 Itanium-Basierte Versionen
Tabelle minimierenTabelle vergrößern
DateinamDateiversionDateigrößeDatuUhrzeiPlattform
1394bus.sys5.2.3790.100168,06405-Nov-200303 : 45Nicht zutreffend

Windows Server 2003 mal 86-basierten Versionen
Tabelle minimierenTabelle vergrößern
DateinamDateiversionDateigrößeDatuUhrzeiPlattform
1394bus.sys5.2.3790.10052,60805-Nov-200319 : 46Nicht zutreffend

Status

Microsoft hat bestätigt, dass es sich dabei, um ein Problem bei den Microsoft-Produkten, die in dem Abschnitt "Betrifft" aufgeführt sind, handelt. Dieses Problem wurde erstmals in Microsoft Windows XP Service Pack 2 behoben.

Weitere Informationen

Nach Installation dieses Hotfixes wird eine Berechnung von Hash, die über höhere Entropie verfügt, für die Gerätetabelle für die DNS-Server-Konfiguration verwandt. Dieses Verhalten verhindert die Konflikte, die auftreten können, wenn die IEEE 1394-Geräteide vergleichbar sind.

Findet weitere Informationen zu IEEE 1394-Technologie auf dem folgenden Website von Microsoft:
http://www.microsoft.com/whdc/archive/1394tech.mspx

Erhalten Sie zusätzliche Informationen zu dem Verwenden von IEEE 1394-Geräten mit Windows XP, indem auf die folgende Artikelanzahl klickt, um den Artikel der Microsoft Knowledge Base zu lesen:
310433 Verwenden von IEEE (FireWire) Geräten mit Windows XP
Weitere Informationen zu Hotfix-Paketen und deren Bezeichnungen finden Sie im folgenden Artikel der Microsoft Knowledge Base
816915 Neues Namensschema für Microsoft Windows Hotfix-Paket
Klicken Sie auf die folgende Artikelanzahl, um weitere Informationen zu erhalten, um den Artikel der Microsoft Knowledge Base zu lesen:
824684 Erläuterung von Standardbegriffen bei Microsoft Softwareupdate

Eigenschaften

Artikel-ID: 830987 - Geändert am: Sonntag, 4. November 2007 - Version: 3.8
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbwinxpsp2fix kbhardware kbqfe kbwinserv2003presp1fix kbwinxppresp2fix kbfix kbbug KB830987 KbMtde kbmt
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 830987
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com