Algunos dispositivos no se reconocen cuando utiliza varios dispositivos IEEE 1394 (FireWire)

Seleccione idioma Seleccione idioma
Id. de artículo: 830987 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Si tiene varios dispositivos en el mismo equipo que utilizan el Institute of Electrical and Electronic Engineers (IEEE) 1394 serie bus de alta velocidad (también conocido como FireWire), algunos de los dispositivos que no reconozca correctamente.

Cuando se utiliza sólo uno de estos dispositivos, Plug and Play carga el controlador correcto y el dispositivo funciona correctamente. Sin embargo, si utiliza dos dispositivos IEEE 1394 del equipo, el controlador no llama a una segunda vez. Por lo tanto, se reconoce sólo el primer dispositivo.

Causa

Este problema puede producirse si los identificadores de dispositivo para los dispositivos 1394 de IEEE son similares. Por ejemplo, este problema puede producirse si el primer dispositivo tiene un identificador único (UID) de 200000002A30B00 y el segundo dispositivo tiene un UID de 210000001A30B00.

El enumerador de dispositivo 1394 (1394bus.sys) tiene una tabla de dispositivo que se implementa como una tabla hash que se almacena en una matriz. La función hash calcula un hash según el UID del dispositivo. Si hay una colisión (si los valores de hash que se calculan para cada dispositivo son el mismo), se asigna una tabla más grande.

Si dos identificadores de dispositivo son similares, el cálculo hash genera el mismo valor para ambos dispositivos. Por tanto, se produce una colisión y el código continuamente reasigna mayores matrices con límite de tamaño de tabla. Porque la tabla hash alcanza su límite de tamaño antes de que la nueva entrada para el segundo dispositivo se agrega a la tabla, no se reconoce el segundo dispositivo.

Solución

Windows XP

Información de revisiones

Para resolver este problema, obtenga el Service Pack más reciente para Windows XP. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Requisitos previos

Para aplicar este hotfix, debe tener instalado Windows XP Service Pack 1 (SP1).

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Windows XP, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
1394bus.sys5.1.2600.1317190,97606-Nov-200342: 02IA-64

Windows XP, versiones de 86 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
1394bus.sys5.1.2600.131751,07206-Nov-200342: 02x 86

Windows Server 2003

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Windows Server 2003, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
1394bus.sys5.2.3790.100168,06405-Nov-200303: 45No aplicable

Windows Server 2003, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
1394bus.sys5.2.3790.10052,60805-Nov-200319: 46No aplicable

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en el Service Pack 2 de Microsoft Windows XP.

Más información

Después de instalar esta revisión, se utiliza un cálculo de hash tiene mayor entropía para la tabla del dispositivo. Este comportamiento impide que los conflictos que pueden producirse si los identificadores de dispositivo IEEE 1394 son similares.

Para obtener más información acerca de la tecnología IEEE 1394, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/whdc/archive/1394tech.mspx

Para obtener información adicional acerca del uso de dispositivos IEEE 1394 con Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
310433Utilizar dispositivos IEEE (FireWire) con Windows XP
Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura para paquetes de revisión de Microsoft Windows
Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 830987 - Última revisión: domingo, 04 de noviembre de 2007 - Versión: 3.8
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbwinxpsp2fix kbhardware kbqfe kbwinserv2003presp1fix kbwinxppresp2fix kbfix kbbug KB830987 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 830987

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com