Software společnosti Alcatel nelze nainstalovat do počítače se systémem Windows XP (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 831014 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Některé softwarové programy Alcatel nelze nainstalovat v počítačích se systémem Windows XP. Softwarový program Alcatel nelze zaregistrovat konkrétní soubory dynamické propojení knihovny (DLL) při spuštění instalačního programu.

Příčina

K tomuto problému dochází, protože Alcatel instalační program se pokusí zaregistrovat soubory DLL použít popisovač klíče registru uzavřené.

Řešení

Informace o aktualizaci Service Pack

Problém vyřešíte instalací nejnovější aktualizace Service Pack pro systém Microsoft Windows XP. Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
322389získání nejnovější aktualizace Service Pack pro systém Windows XP

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Pokud Vás tento problém závažně nepostihuje, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Pokud tento oddíl nevidíte, obraťte se na Technickou podpora společnosti Microsoft pro získání opravy hotfix.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   16-Dec-2003  19:40  5.1.2600.1325  1,821,696  Acgenral.dll     
   16-Dec-2003  19:40  5.1.2600.1326    220,160  Acspecfc.dll     
   16-Dec-2003  19:41                    79,018  Apps.chm
   16-Dec-2003  19:40                 1,088,148  Sysmain.sdb

Informace o instalaci

Po extrahování a nainstalovány soubory opravy hotfix musíte použít nástroj Správce kompatibility (Compatadmin) správně nainstalovat opravu hotfix. Compatadmin je součástí sady Application Compatibility Toolkit. Stažení sady Application Compatibility Toolkit, naleznete na následujícím webu:
http://technet.microsoft.com/en-us/windowsvista/aa905066.aspx
Sady Application Compatibility Toolkit zahrnuje další nástroje, jako například Windows Application Compatibility Analyzer a Windows Application Verifier. Však použít konkrétní opravy hotfix, může pouze chcete nainstalovat Compatadmin.

Pomocí Compatadmin použít opravu hotfix, postupujte takto:

Poznámka: Správce kompatibility popisují kombinaci informace o kompatibilitě, která je přidána do vlastní databáze pro konkrétní program používá termín "oprava". Tato oprava může být oprava kompatibility jeden nebo kombinaci režimy kompatibility. Omezení faktor při přidání oprava vlastní databáze je, že jej platí pouze pro jeden program.
Krok 1: Použití Compatadmin vytvořit databázi kompatibility
Použít Compatadmin vytvořit databázi kompatibility, postupujte takto:
  1. Klepněte na tlačítko Start, přejděte na příkaz programy, klepněte na položku Microsoft Windows Application Compatibility Toolkit a klepněte na tlačítko kompatibilního správce Tool 3.0
  2. V nástroji Správce kompatibility klepněte na tlačítko Nový vytvoříte novou databázi kompatibility. Oprava kompatibility používá použít opravu AlcatelLayer Alcanex.exe bude obsahovat nové databáze kompatibility.
Krok 2: Přidání opravy hotfix vlastní databáze
Chcete-li přidat vlastní databázi v Compatadmin opravu hotfix, postupujte takto:
  1. V podokně databáze klepněte v části uzel Vlastní databáze nové databáze.
  2. Klepnutím na tlačítko opravit otevřete dialogové okno vytvořit nové aplikace opravit.
  3. Zadejte požadované informace pro název programu a název dodavatele, vyhledejte cestu Umístění souboru programu (Alcanex.exe) pro program a potom klepněte na tlačítko Další.
  4. Na stránce Režimy kompatibility klepněte operační systém a potom klepněte na tlačítko režim kompatibility použít program. Při instalaci opravy hotfix, zobrazí se v seznamu režimy kompatibility AlcatelLayer.

    Poznámka: Klepnutím na tlačítko Spustit Test vyzkoušejte každý režimu nebo kombinaci režimy, dokud určit režimy problém vyřešit.
  5. Klepněte na tlačítko Další.
  6. Pokud nenalezl režimu kompatibility problém vyřeší, nebo pokud chcete optimalizovat podporu kompatibility, můžete použít stránku Opravy kompatibility vyberte jednotlivé kompatibility opravuje použít. Na stránce Opravy kompatibility klepnete na tlačítko Spustit Test vyzkoušet výběry. Pokud je nutné zobrazit pouze opravy vybrané kompatibility, klepněte na tlačítko Zobrazit vybrané. Opravy kompatibility stránce se zobrazí různé ikony, podle toho, zda byla oprava kompatibility jednotlivé použita jako část režimu kompatibility. Po dokončení klepněte na tlačítko Další.
  7. Na stránce ICM informace Správce kompatibility zobrazí odpovídající informace, které zjistil pro program. Je vhodné použít omezený seznam odpovídající informace omezit velikost souboru databáze. Musí však zachovat dostatečná odpovídající informace pro systém Windows XP jednoznačně identifikovat program. Pokud chcete přidat jiný soubor seznamu odpovídající informace, klepněte na Přidat soubor a soubor vyhledejte.
  8. Klepnutím na tlačítko Dokončit uložit vlastní oprava v databázi. Můžete například uložit databázi kompatibility jako alcat .sdb.
Krok 3: Instalace databáze kompatibility
  1. V levém podokně Správce kompatibility klepněte nové vlastní databázi, kterou chcete nainstalovat.
  2. Klepněte pravým tlačítkem myši nové databáze a poté klepněte na tlačítko nainstalovat.
  3. Po instalaci opravy Alcanex.exe spustí s režimu kompatibility AlcatelLayer použita.
Krok 4: Nasazení do více počítačů vlastní oprava (*.sdb)
Chcete-li nainstalovat opravu hotfix a použít vlastní opravu zbývající počítače, postupujte takto:
  1. Nainstalovat spustitelný soubor opravy hotfix a *.sdb soubor, který jste uložili dříve v každém počítači, který chcete nainstalovat opravu.
  2. V programu Správce kompatibility otevření souboru *.sdb, klepněte na soubor a potom klepněte na tlačítko nainstalovat.
Poznámka: Sbdinst.exe můžete také použít k instalaci souboru *.sdb. Sbdinst.exe je umístěn ve složce %windir%\system32.

Další informace o nasazení naleznete soubory .sdb odkaz "Microsoft Windows Application Compatibility Toolkit". Spustit odkaz Toolkit, postupujte takto:
  1. Klepněte na tlačítko Start, přejděte na příkaz programy, klepněte na položku Microsoft Windows Application Compatibility Toolkit a klepněte na položku Microsoft Windows Compatibility správce Tool 3.0 reference.
  2. V levém podokně Microsoft Windows Compatibility správce Tool 3.0 reference rozbalte Toolkit nasazení aplikace a potom rozbalte položku zavedení a distribuce aplikací a .sdb soubory

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.Tento problém byl poprvé opraven aktualizací Microsoft Windows XP Service Pack 2.

Další informace

Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 831014 - Poslední aktualizace: 26. října 2006 - Revize: 2.6
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB831014 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:831014

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com