Windows XP ベースのコンピュータに Alcatel のソフトウェアをインストールできない

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文書番号: 831014 - 対象製品
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目次

現象

Alcatel ソフトウェア プログラムによっては、Windows XP ベースのコンピューターにインストールできません。 セットアップ プログラムを実行すると、Alcatel ソフトウェア プログラムを特定のダイナミック リンク ライブラリ (DLL) ファイル登録できません。

原因

この問題は、Alcatel セットアップ プログラムが閉じられたレジストリ キーのハンドルを使用して、DLL ファイルを登録するしようとするのでに発生します。

解決方法

Service Pack 情報

この問題を解決するには、Microsoft Windows XP 用の最新のサービス パックの入手します。 関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください:
322389How to Obtain the Latest Windows XP Service Pack JP322389 最新の Windows XP Service Pack を入手する方法

修正プログラムについて

サポートされている修正プログラムが Microsoft から提供されています。 ただし、ことを目的としたこの修正プログラムものですこの資料に記載されている問題のみを修正します。 この修正プログラムのみシステムに適用この特定の問題が発生しています。 この修正プログラム テストを受ける可能性があります。 そのため場合この問題で深刻な影響を受けていないお勧めしますこの修正プログラムを含む、次回ソフトウェアの更新されるまで待つことです。

修正プログラムをダウンロードできる場合はこの資料の先頭に「修正プログラムのダウンロード」セクションです。 このセクションが表示されていない場合、は、マイクロソフト カスタマーサービス & サポート修正プログラムを入手するを問い合わせてください。

メモ 追加問題が発生する場合は、個別のサービス要求を作成した任意のトラブルシューティングが必要な場合。 通常のサポート料金が追加の質問およびこの特定の修正プログラムの対象とならない問題について適用されます。 一覧については、完了マイクロソフト カスタマーサービス & サポートの電話番号のまたは個別のサービス要求を作成する、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
メモ 「修正プログラムのダウンロード」フォームには、修正プログラムが利用する言語が表示されます。 お使いの言語が表示されない場合、修正プログラムがその言語に対応しないのでは。

ファイル情報

この修正プログラムがファイル属性 (またはそれ以降) 次の表は、されている可能性もします。 これらのファイルの日時に協定時刻 (UTC) 記載します。 各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。 UTC および現地時間の時差を確認するには、コントロール パネル]、日付と時刻ツールの [ タイム ゾーン ] タブを使用してください。
   Date         Time   Version        Size       File name
   ----------------------------------------------------------
   16-Dec-2003  19:40  5.1.2600.1325  1,821,696  Acgenral.dll     
   16-Dec-2003  19:40  5.1.2600.1326    220,160  Acspecfc.dll     
   16-Dec-2003  19:41                    79,018  Apps.chm
   16-Dec-2003  19:40                 1,088,148  Sysmain.sdb

インストール情報

抽出して、修正プログラム ファイルをインストールした後、互換性管理ツール (Compatadmin) を正しく修正プログラムを適用する使わなければなりません。 Compatadmin は、アプリケーション互換性ツールキットに含まれています。 アプリケーション互換性ツールキットをダウンロードするには、次のマイクロソフト Web サイトを参照してください。
http://technet.microsoft.com/en-us/windowsvista/aa905066.aspx
アプリケーション互換性ツールキットには、追加のツール Windows アプリケーションの互換性の分析と Windows アプリケーション検証ツールなどが含まれています。 ただし、この特定の修正プログラムを適用するだけを Compatadmin をインストールします。

Compatadmin を使用して、修正プログラムを適用するには、次の手順を実行します。

メモ 互換性管理では、「修正」という用語を使用して特定のプログラム用のカスタム データベースに追加される互換性情報の組み合わせについて説明します。 この修正プログラムが 1 つの互換性修正プログラムまたは互換性モードの組み合わせ可能性があります。 制限係数カスタム データベースに修正プログラムを追加する場合のみ、1 つのプログラムに適用されるが。
手順 1: を使用する Compatadmin 互換性データベースを作成するには
Compatadmin を使用して、互換性データベースを作成する、次の手順を実行します。
  1. [スタート ] をクリックしてください、 プログラム をポイントし、 Microsoft Windows アプリケーション互換性ツールキット をクリックして、[ 互換性管理ツール 3. 0 ] をクリックしてください
  2. 互換性管理ツールで [新しい互換性データベースを作成するには 新規作成 ] をクリックします。 新しい互換性データベースには、Alcanex.exe を AlcatelLayer 修正プログラムの適用に使用される互換性修正プログラムが含まれて。
手順 2: カスタム データベースに修正プログラムを追加します。
Compatadmin でカスタム データベースに修正プログラムを追加するには、次の手順に従います。
  1. [ データベース ] には新しいデータベースを カスタム データベース ノードの下クリックします。
  2. 問題を修正する </a0> をクリック、[ 新しいアプリケーション修正を作成 ] ダイアログ ボックスを開きます。
  3. ベンダー名、プログラムの名前の必要な情報を入力は、 プログラム ファイルの場所 (Alcanex.exe) の、プログラムのパスして、[ 次へ] </a0> をクリックします。
  4. [ 互換モード ] ページで、[オペレーティング システム] をクリックし、互換モードのプログラムを適用します。 AlcatelLayer は、修正プログラムをインストールした場合に互換モードの一覧に表示されます。

    メモ テストの実行 の問題を解決するモードを決定するまで、各モードまたはモードの組み合わせを実行するをクリックできます。
  5. [ 次へ </a0>] をクリックします。
  6. 互換性の問題を解決するモードが見つかりませんだった場合は、 互換性の修正 ] ページを使用して個々 の互換性を選択することがでく互換性サポートを微調整する場合は、適用する修正します。 [ 互換性の修正 ] ページで、選択内容を試す テストの実行 ボタン クリックできます。 選択した互換性修正プログラムのみを表示する必要がある場合、クリックして 選択を表示 します。 互換性の修正 ページ、互換モードの一部として、個々 の修正が適用されているかどうかに応じてさまざまなアイコンが表示されます。 終わったらには、[ 次へ ] をクリックします。
  7. 一致する情報 ] ページの互換性の管理者がプログラムの検出されたすべての一致する情報表示されます。 一致する情報の制限の一覧を使用して、データベースのファイル サイズを制限することをお勧めします。 ただし、Windows XP のプログラムを識別する十分な一致する情報を保持する必要があります。 別のファイルを一致する情報の一覧に追加する場合は、[ ファイルの追加 、ファイルを検索を] します。
  8. データベースで、カスタムの修正プログラムを保存する [完了] をクリックします。 たとえば、alcat.sdb として互換性データベースを保存できます。
手順 3: 互換性データベースをインストールします。
  1. 互換性管理の左側のウィンドウで新しいカスタム データベースをインストールしてもよろしいですかをクリックします。
  2. 新しいデータベース] を右クリックし、 インストール します。
  3. 修正プログラムはインストール後 Alcanex.exe 適用 AlcatelLayer 互換モードで実行されます。
手順 4: 複数のコンピューターに、カスタムの修正プログラム (*.sdb) を展開します。
修正プログラムをインストールしているユーザー設定の修正プログラムの残りのすべてのコンピューターに適用して、次の手順に従います。
  1. 修正プログラムの実行可能ファイルと以前のバージョンに修正プログラムをインストールするコンピューターすべて保存された *.sdb ファイル インストールします。
  2. 互換性アドミニストレーターで *.sdb ファイルを開き、[ ファイル ] をクリックして [ インストール ] をクリックします。
メモ 使えます Sbdinst.exe、*.sdb ファイルをインストールします。 Sbdinst.exe は、%windir%\system32 フォルダーにあります。

.sdb ファイルを展開する方法の詳細については、「Microsoft Windows アプリケーション互換性ツールキット」の参照を確認します。 演習用ツールキットの参照を開始するには、次の手順に従います。
  1. 起動 プログラム ] をポイントし、 Microsoft Windows アプリケーション互換性ツールキット 、[ Microsoft Windows 互換性管理ツール 3. 0 リファレンス ] をクリックします。
  2. Microsoft Windows 互換性管理ツール 3. 0 参照 の左側で アプリケーションの展開のツールキット を展開して 展開するアプリケーションの配布および.sdb ファイル を展開

状況

マイクロソフトとして認識していますこの問題を記載されているいるマイクロソフト製品の問題。この問題は、Microsoft Windows XP Service Pack 2 で最初に修正されました。

詳細

関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください:
824684マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明
インストール手順

プロパティ

文書番号: 831014 - 最終更新日: 2006年10月26日 - リビジョン: 2.6
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
キーワード:?
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver kbautohotfix kbmt KB831014 KbMtja
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英語版 KB:831014
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