Artigo: 831135 - Última revisão: domingo, 8 de Fevereiro de 2009 - Revisão: 3.0

Os clientes receber uma mensagem de erro "Serviço indisponível" nos seus Web browsers quando executa vários agrupamentos de aplicações em identidades separadas no IIS

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Sintomas

Quando executa vários agrupamentos de aplicações em diferentes identidades personalizados no Microsoft (IIS), alguns processos de trabalho não podem inicializar correctamente. Quando este problema ocorre, os clientes podem receber um "Serviço indisponível" mensagem de erro quando tentarem visitar Web páginas que esses anfitrião de agrupamentos de aplicações. Além disso, a seguinte mensagem de aviso poderá ser registada no registo do sistema:

Tipo de evento: aviso
Origem do evento: W3SVC
Categoria do evento: nenhum
ID do evento: 1009
Descrição:
Um processo que serve o agrupamento de aplicações ' poolname ' terminou inesperadamente. O id de processo era ' processid '. O código de saída do processo foi '0 x 80'.

Este problema não ocorre quando utiliza as três identidades predefinidas. As identidades predefinidas são serviço de rede, serviço local e sistema local.

Nota Este problema ocorre na versão de 32 bits do IIS e a versão de 64 bits do IIS.

Causa

Juntamente com cada processo de trabalho que o IIS cria sob uma identidade diferente, o sistema cria um novo objecto do ambiente de trabalho através da atribuição de memória da pilha de ambiente de trabalho configurada. Este problema ocorre porque, quando esse pilha foi esgotada, o IIS não consegue criar mais processos de trabalho. Os clientes receber, em seguida, o "Serviço indisponível" mensagem de erro nos seus Web browsers quando tentarem visitar Web sites que esses anfitrião de agrupamentos de aplicações.

Resolução

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Para resolver este problema, adicione a chave de registo
UseSharedWPDesktop
ao computador que está a executar o IIS. Esta chave de registo permite que todos os processos de trabalho para ser executado no ambiente de um trabalho partilhado, independentemente das identidades do processo de trabalho.

Para adicionar a chave de registo
UseSharedWPDesktop
:
  1. Clique em Iniciar , clique em Executar , escreva regedit e, em seguida, clique em OK .
  2. Do IIS6, localize a seguinte chave de registo:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3SVC
    Para IIS7, localize a seguinte chave de registo:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WAS
    Para obter mais informações sobre localizações de registo do IIS 7, visite o seguinte Web site da Microsoft:
    http://support.microsoft.com/?id=930907 (http://support.microsoft.com/?id=930907)
  3. Clique com o botão direito do rato em Parameters , aponte para Novo e, em seguida, clique em Valor DWORD (DWORD Value) .
  4. Tipo UseSharedWPDesktop .
  5. Defina o valor para esta nova chave para 1.
  6. Saia do Editor de registo e, em seguida, reinicie o IIS.

Ponto Da Situação

Este comportamento ocorre por predefinição.

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Information Services 6.0
  • Microsoft Internet Information Services 7.0
Palavras-chave: 
kbmt kbprb KB831135 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 831135  (http://support.microsoft.com/kb/831135/en-us/ )