ID do artigo: 831135 - Última revisão: domingo, 8 de fevereiro de 2009 - Revisão: 3.0

Clientes exibida uma mensagem de erro "serviço indisponível" em seus navegadores da Web ao executar vários pools de aplicativos em identidades separadas no IIS

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Sintomas

Quando você executa vários pools de aplicativos em diferentes identidades personalizadas no Microsoft Internet Information Services (IIS), alguns processos de trabalho não podem inicializar corretamente. Quando esse problema ocorre, os clientes podem receber um "serviço indisponível" mensagem de erro quando eles tentam visitar site páginas que esses host de pools de aplicativo. Além disso, a seguinte mensagem de aviso pode ser registrada no log do sistema:

Tipo de evento: aviso
Origem do evento: W3SVC
Categoria do evento: nenhum
IDENTIFICAÇÃO de evento: 1009
Descrição:
Um processo que atende o pool de aplicativos ' poolname ' terminou inesperadamente. A identificação do processo era ' processid '. O código de saída do processo era '0 x 80'.

Esse problema não ocorre quando você usa as três identidades predefinidas. As identidades predefinidas são o serviço de rede, serviço local e sistema local.

Observação Esse problema ocorre tanto a versão de 32 bits do IIS como a versão de 64 bits do IIS.

Causa

Junto com cada processo do operador que o IIS cria em uma identidade separada, o sistema cria um novo objeto da área de trabalho por alocação de memória do heap da área de trabalho configurado. Esse problema ocorre porque, quando esse heap esgotou, IIS não é possível criar mais processos. Os clientes, em seguida, receber o "serviço indisponível" mensagem de erro em seus navegadores da Web ao tentar visitar site sites que os host de pools de aplicativo.

Resolução

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Para resolver esse problema, adicione a chave de registro
UseSharedWPDesktop
no seu computador que está executando o IIS. Essa chave do Registro permite que todos os processos de trabalho para ser executado em um desktop compartilhada, independentemente de suas identidades de processo do operador.

Para adicionar a chave de registro
UseSharedWPDesktop
:
  1. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  2. Para IIS6, localize a seguinte chave do Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\W3SVC
    Para IIS7, localize a seguinte chave do Registro:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\WAS
    Para obter mais informações sobre locais de registro de IIS 7, visite o seguinte site:
    http://support.microsoft.com/?id=930907 (http://support.microsoft.com/?id=930907)
  3. Clique com o botão direito do mouse em Parameters , aponte para novo e, em seguida, clique em Valor DWORD .
  4. Tipo UseSharedWPDesktop .
  5. Defina o valor para essa nova chave para 1.
  6. Feche o Editor do Registro e reinicie o IIS.

Situação

Esse comportamento é por design.

A informação contida neste artigo aplica-se a:
  • Microsoft Internet Information Services 6.0
  • Microsoft Internet Information Services 7.0
Palavras-chave: 
kbmt kbprb KB831135 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 831135  (http://support.microsoft.com/kb/831135/en-us/ )