Vous ne parvenez pas à accéder à un site Web ou à terminer une transaction Internet, ou une page Web HTTP 500 (Erreur interne du serveur) s'affiche

Traductions disponibles Traductions disponibles
Numéro d'article: 831167 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Vous pouvez être dans l'incapacité de vous connecter à un site Web ou de terminer une transaction Internet après l'installation de la mise à jour de sécurité 832894 (MS04-004). Par exemple, lorsque vous envoyez votre nom d'utilisateur et un mot de passe à un site Web sécurisé SSL à l'aide d'un formulaire sur une page Web HTTPS, une page Web HTTP 500 (Erreur interne du serveur) peut s'afficher.

Cause

Ce problème peut se produire après avoir appliqué la mise à jour de sécurité 832894 (MS04-004) ou le correctif 821814 sur un ordinateur qui exécute Microsoft Windows XP, Windows 2000, Windows NT 4.0, Windows Millennium Edition ou Windows 98.

Pour plus d'informations sur ces mises à jour logicielles, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
832894 MS04-004 : Mise à jour de sécurité cumulative pour Internet Explorer
821814 Vous recevez un message d'erreur "Impossible d'afficher la page" lorsque vous publiez des informations sur un site qui requiert une authentification
La mise à jour de sécurité 832894 (MS04-004) et le correctif 821814 modifient la façon dont les extensions Internet pour Windows (Wininet.dll) relancent les demandes POST lorsqu'un serveur Web réinitialise la connexion. Les programmes qui utilisent les fonctions d'interface de programmation d'applications (API) Windows Internet (Wininet) pour publier des données (telles qu'un nom d'utilisateur ou un mot de passe) sur un serveur Web relancent la demande POST sans inclure les données POST si le serveur Web ferme (ou réinitialise) la demande de connexion initiale.

Remarque Une demande POST n'inclut pas les données POST si la longueur de son contenu est égale à 0 ou est vide.

Parfois, ce comportement empêche une autre réinitialisation et permet l'authentification. Cependant, vous pouvez recevoir une page Web HTTP 500 (Erreur interne du serveur) si le serveur Web doit disposer des données POST lorsque Wininet relance la demande POST.

Résolution

Informations sur le téléchargement

Pour télécharger et installer cette mise à jour, reportez-vous au site Web Microsoft Windows Update à l'adresse suivante, puis installez la mise à jour 831167 :
http://support.microsoft.com/xpsp2getinstall
Les administrateurs peuvent télécharger cette mise à jour à partir du Centre de téléchargement Microsoft ou du Catalogue Windows Update pour la déployer sur plusieurs ordinateurs. Si vous souhaitez installer ultérieurement cette mise à jour sur un ou plusieurs ordinateurs, recherchez le numéro d'identification de cet article à l'aide des Options de recherche avancées dans le Catalogue Windows Update.

Pour plus d'informations sur la façon de télécharger des mises à jour à partir du Catalogue Windows Update, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
323166 Comment faire pour télécharger des mises à jour Windows et des pilotes à partir du Catalogue Windows Update
Vous pouvez télécharger les fichiers suivants à partir du Centre de téléchargement Microsoft :
Réduire cette imageAgrandir cette image
Télécharger
Téléchargez le package Q831167.exe (32 bits) maintenant.
Réduire cette imageAgrandir cette image
Télécharger
Téléchargez le package Q831167.exe (64 bits) maintenant.
Date de publication : 12 février 2004

Pour plus d'informations sur la façon de télécharger des fichiers du Support technique Microsoft, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
119591 Comment obtenir des fichiers de support technique Microsoft auprès des services en ligne
Microsoft a analysé ce fichier en vue de détecter la présence de virus. Microsoft a utilisé les logiciels de détection de virus les plus récents disponibles à la date de publication de ce fichier. Le fichier est conservé sur des serveurs sécurisés, empêchant toute modification non autorisée du fichier.

Conditions préalables

Pour installer cette mise à jour, vous devez utiliser le Service Pack 1 Internet Explorer 6 (version 6.00.2800.1106) sur l'une des versions suivantes de Windows :
  • Service Pack 1 Microsoft Windows XP
  • Service Pack 1 Microsoft Windows XP Édition 64 bits
  • Microsoft Windows XP
  • Service Pack 2/Service Pack 3/Service Pack 4 Microsoft Windows 2000
  • Service Pack 6a Microsoft Windows NT Workstation, Server et Édition Terminal Server 4.0
  • Microsoft Windows 98
  • Microsoft Windows 98 Deuxième Édition
  • Microsoft Windows Millennium Edition
Remarque Dans la mesure où la mise à jour de sécurité 832894 (MS04-004) prend en charge Windows 98, Windows 98 Deuxième Édition, Windows Millennium Edition et le Service Pack 2 Windows 2000, cette mise à jour sera également prise en charge sur ces systèmes d'exploitation.

Nécessité d'un redémarrage

Vous devez redémarrer votre ordinateur après avoir appliqué cette mise à jour.

Informations sur le remplacement de mise à jour

Cette mise à jour remplace 821814 pour Windows XP, Windows 2000, Windows NT 4.0, Windows Millennium Edition, Windows 98 Deuxième Édition et Windows 98.

Remarque Cette mise à jour ne remplace pas 821814 pour Windows Server  2003 car le problème décrit dans cet article ne se produit pas sur les ordinateurs Windows Server 2003.

Informations sur le déploiement

Les packages pour cette mise à jour prennent en charge les commutateurs suivants :
  • /q : utilise le mode silencieux ou supprime les messages lors de l'extraction des fichiers.
  • /q:u : utilise le mode silencieux utilisateur. Le mode silencieux utilisateur présente certaines boîtes de dialogue à l'utilisateur.
  • /q:a : utilise le mode silencieux administrateur. Le mode silencieux administrateur permet de ne pas afficher de boîte de dialogue à l'utilisateur.
  • /t: chemin_d'accès : indique l'emplacement du dossier temporaire utilisé par le programme d'installation ou du dossier cible lors de l'extraction des fichiers (avec le commutateur /c).
  • /c : extrait les fichiers sans les installer. Si /t: chemin_d'accès n'est pas spécifié, vous êtes invité à indiquer un dossier cible.
  • /c: chemin_d'accès : indique le chemin d'accès et le nom du fichier d'installation .inf ou .exe.
  • /r:n : ne redémarre jamais l'ordinateur après une installation.
  • /r:i : invite l'utilisateur à redémarrer l'ordinateur si un redémarrage est requis, sauf en cas d'utilisation avec le commutateur /q:a.
  • /r:a : redémarre toujours l'ordinateur après une installation.
  • /r:s : redémarre l'ordinateur après une installation sans formuler de demande auprès de l'utilisateur.
  • /n:v : ne vérifie pas la version. Utilisez ce commutateur avec précaution si vous souhaitez installer la mise à jour sur n'importe quelle version d'Internet Explorer.
Par exemple, pour installer la mise à jour sans intervention de la part de l'utilisateur et sans redémarrage de l'ordinateur, exécutez la commande suivante :
q831167.exe /q:a /r:n

Informations sur les fichiers

La version anglaise de cette mise à jour a les attributs de fichier répertoriés dans le tableau suivant ou ceux d'une version ultérieure. Les date et heure de création de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations des fichiers, les données sont converties à l'heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire de l'utilitaire Date et heure du Panneau de configuration.
   Date      Heure  Version        Taille     Nom de fichier Plate-forme
   ---------------------------------------------------------------------
   06/02/04  18:05  6.0.2800.1405    588 288  Wininet.dll
   07/02/04  01:41  6.0.2800.1405  1 796 608  Wininet.dll    IA-64

Contournement

Si vous ne pouvez pas appliquer la mise à jour indiquée dans la section Résolution, vous pouvez utiliser l'une des actions suivantes côté serveur pour contourner ce problème :
  • Augmentez l'intervalle de délai persistant HTTP sur le serveur Web ou le serveur proxy. Il n'existe pas de paramètre dans les services Internet (IIS) pour contrôler le délai persistant autre que la valeur KeepAliveTime du Registre Windows. Cependant, certains serveurs Web et serveurs proxy peuvent vous permettre d'indiquer un délai d'expiration de connexion. Si vous pouvez indiquer un délai d'expiration de connexion sur le serveur Web ou le serveur proxy, augmentez l'intervalle de délai persistant. Consultez la documentation de votre serveur Web pour obtenir le nom et la valeur corrects du paramètre. La valeur de délai persistant par défaut pour Internet Explorer est d'une minute (60 secondes). Par conséquent, vous devez utiliser un intervalle de délai persistant HTTP supérieur à une minute sur le serveur Web ou le serveur proxy.

    Pour plus d'informations sur les paramètres Windows KeepAliveInterval, Windows KeepAliveTime et Internet Explorer KeepAliveTimeout, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
    314053 Paramètres de configuration NBT et TCP/IP pour Windows XP
    120642 Paramètres de configuration NBT & TCP/IP pour Windows
    813827 Comment faire pour modifier la valeur de délai persistant par défaut dans Internet Explorer
  • Désactivez les "connexions persistantes" HTTP sur le serveur. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
    238210 En-tête persistant HTTP envoyé lorsque la mise en mémoire tampon ASP est activée

Statut

Microsoft a confirmé l'existence de ce problème dans Microsoft Internet Explorer 6.

Plus d'informations

Avertissement Toute utilisation incorrecte de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.

Après avoir appliqué la mise à jour logicielle 831167 décrite dans cet article, les programmes qui utilisent les fonctions Wininet pour publier des données sur un serveur Web renverront les demandes POST complètes lorsqu'une connexion au serveur Web sera réinitialisée.

Pour autoriser un comportement de publication d'en-tête uniquement, créez une valeur DWORD appelée SampleApp.exe, où SampleApp est le nom du fichier exécutable qui exécute le programme. Définissez les données de la valeur DWORD sur 1 de l'une des clés de Registre suivantes :
  • Pour tous les utilisateurs du programme, définissez la valeur de la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\Retry_HeaderOnlyPOST_OnConnectionReset
  • Pour l'utilisateur actuel du programme uniquement, définissez la valeur de la clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\Retry_HeaderOnlyPOST_OnConnectionReset
Par exemple, pour activer le comportement de publication d'en-tête uniquement dans Internet Explorer et dans l'Explorateur Windows, créez des valeurs DWORD pour iexplore.exe et explore.exe dans l'une de ces clés de Registre et définissez leurs données de valeur sur 1.

Remarque Pour activer le comportement de publication d'en-tête uniquement pour tous les programmes qui utilisent les fonctions Wininet pour publier des données sur un serveur Web, créez une valeur DWORD appelée * dans la même clé de Registre et définissez les données de valeur sur 1.

Propriétés

Numéro d'article: 831167 - Dernière mise à jour: vendredi 30 juin 2006 - Version: 6.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Internet Explorer 6.0
Mots-clés : 
kbqfe kbhotfixserver atdownload kbie600sp2fix kbie600presp2fix kbfix kbbug KB831167
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com