Mouse pointer movement is not smooth in Microsoft Remote Desktop Connection

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Article ID: 831172 - View products that this article applies to.
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SYMPTOMS

If you use Microsoft Remote Desktop Connection (version 5.1 or later of the Terminal Services client) to connect to a server that is running Terminal Services, you may notice that the movement of the mouse pointer is not smooth. The mouse pointer may move with a jerky motion. This problem is most noticeable when you use a painting program such as Microsoft Paint or the drawing tools in a Microsoft Office program.

CAUSE

This problem occurs because the update interval for mouse movement in Remote Desktop Connection cannot be adjusted.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Before you install this hotfix, you must first create a new registry key on the computer that is running Remote Desktop Connection. Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. Follow these steps, and then quit Registry Editor:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:
    HKEY_CURENT_USER\Software\Microsoft\Terminal Server Client
  3. On the Edit menu, point to New, and then click DWORD value.
  4. Type Min Send Interval, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 10, and then click OK.

Restart requirement

After you modify the registry and install the hotfix, you must restart the computer.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date        Time   Version           Size     File name
--------------------------------------------------------------
29-Oct-2003  00:03  5.1.2600.1313     599,040  Mstscax.dll      
23-Oct-2003  20:09  5.1.2600.1313     600,576  Msrdp.ocx

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 831172 - Last Review: August 29, 2007 - Revision: 3.1
APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbqfe kbwinxppresp2fix kbfix kbbug KB831172

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