Article ID: 831194 - Last Review: August 1, 2006 - Revision: 4.4

You receive a "Search resources changed. Please redo your search" message when you search for content in your server farm deployment of SharePoint Portal Server 2003

On This Page

Expand all | Collapse all

SYMPTOMS

When you search for content in your server farm deployment of Microsoft SharePoint Portal Server 2003 after an index is propagated from the index management server to a search server, you may receive the following message:
Search resources changed. Please redo your search. If this behavior continues, please contact your portal site's administrator.

CAUSE

This problem may occur if the sequence number of the catalogs is incorrectly updated after the index is propagated. As a result, the catalogs do not have the correct ID numbers, and the server does not respond correctly to search requests from clients. This problem may occur in situations where your server farm has more than one search server, and you restart one search server in your server farm after an index is propagated.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest SharePoint Portal Server 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Microsoft Office SharePoint Portal Server 2003 Service Pack 2.

To resolve this problem, obtain the latest service pack for SharePoint Portal Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889380  (http://support.microsoft.com/kb/889380/ ) How to obtain the latest service pack for SharePoint Portal Server 2003

Hotfix information

How to obtain the hotfix

This issue is fixed in the SharePoint Portal Server 2003 post-Service Pack 1 Hotfix Package that is dated September 17, 2004. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
883919  (http://support.microsoft.com/kb/883919/ ) Description of the SharePoint Portal Server 2003 post-Service Pack 1 hotfix package: September 17, 2004

WORKAROUND

To work around this problem, restart all the search servers on your server farm.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in SharePoint Portal Server 2003 Service Pack 2.

APPLIES TO
  • Microsoft Office SharePoint Portal Server 2003
Keywords: 
kbshareptportalsvr2003sp2fix kberrmsg kbshareptportalsvr2003presp2fix kbfix kbbug kbqfe KB831194
 

Article Translations

 

Related Support Centers