ข้อความแสดงข้อผิดพลาด "\WINNT\SYSTEM32\CONFIG\SYSTEM เสียหาย" เมื่อคุณพยายามเริ่มต้นเซิร์ฟเวอร์ Exchange 2000 ของคุณหรือ Exchange Server 2003

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 831260 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณรีสตาร์ทเครื่องคอมพิวเตอร์ที่ใช้ Microsoft Exchange 2000 Server หรือ Microsoft Exchange Server 2003 คุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้:
Windows ไม่สามารถเริ่มต้นได้เนื่องจากแฟ้มต่อไปนี้สูญหาย หรือเสียหาย: \WINNT\SYSTEM32\CONFIG\SYSTEM
Windows ไม่สามารถเริ่มต้นได้เนื่องจากแฟ้มต่อไปนี้สูญหาย หรือเสียหาย: \WINNT\SYSTEM32\CONFIG\SYSTEM.ced

สาเหตุ

ปัญหานี้เกิดขึ้นเนื่องจากเงื่อนไขใน Exchange Server ที่อาจทำให้ไฮฟ์ของระบบการขยายขนาดโดยไม่คาดคิดไว้ ไฮฟ์ของระบบถูกจำกัดการประมาณ 10.3 เมกะไบต์ นี่คือการได้เนื่องจากกลุ่ม System และเคอร์เนลของ Microsoft Windows ต้องน้อยกว่า 16 เมกะไบต์เมื่อ Windows เริ่มทำงาน

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ คุณต้องเป็นอันดับแรกแก้ไขจากสภาวะของรีจิสทรีที่เก็บคอมพิวเตอร์ของคุณเริ่มการทำงาน หลังจากที่คุณเริ่มคอมพิวเตอร์ของคุณ ติดตั้งโปรแกรมแก้ไขด่วนที่อธิบายไว้ในบทความนี้เพื่อแก้ไขปัญหาที่เกิดจากไฮฟ์ระบบของคุณเพื่อขยายเกินขีดจำกัด 10.3 MB

เรียกคืน หรือซ่อมแซมรีจิสทรี

การกู้คืนจากสภาวะของรีจิสทรีที่อธิบายไว้ในบทความนี้ ใช้รายการใดรายการหนึ่งในวิธีการต่อไปนี้:
  • คืนค่ารีจิสทรีของคุณจากการสำรองข้อมูลการทำงาน เมื่อต้องการคืนค่ารีจิสทรี คุณต้องมีการสำรองที่สร้างขึ้นก่อนหน้านี้ของรีจิสทรีสำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการคืนค่ารีจิสทรี คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
    322755ิวิธีการสำรองข้อมูล แก้ไขและคืนค่ารีจิสทรีใน Windows 2000
  • ใช้ใน Windows 2000 รีจิสทรีซ่อมแซมตี้ (Chkreg.exe) การซ่อมแซมรีจิสทรี ใช้โปรแกรมอรรถประโยชน์นี้ถ้าคุณไม่มีการสำรองข้อมูลรีจิสทรีของคุณ

    สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการขอรับ และใช้ตี้ซ่อมแซมของรีจิสทรี 2000 Windows การเยี่ยมชมเว็บไซต์ต่อไปนี้ของ Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=56D3C201-2C68-4DE8-9229-CA494362419C&displaylang=en

การแลกเปลี่ยน Server 2003

ข้อมูล Service Pack

เมื่อต้องการแก้ไขปัญหานี้ ขอรับ service pack ล่าสุดสำหรับ Microoft Exchange Server 2003 สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
836993วิธีการขอรับ Service Pack ล่าสุดสำหรับ Exchange Server 2003

Exchange 2000 Server

ข้อมูลโปรแกรมแก้ไขด่วน

โปรแกรมแก้ไขด่วนที่ได้รับการสนับสนุนจาก Microsoft พร้อมใช้งานแล้ว อย่างไรก็ตาม โปรแกรมแก้ไขด่วนนี้มีเป้าหมายเพื่อการแก้ไขปัญหาที่อธิบายไว้ในบทความนี้เท่านั้น นำโปรแกรมแก้ไขด่วนนี้ไปใช้กับระบบที่พบปัญหานี้เท่านั้น

หากมีโปรแกรมแก้ไขด่วนพร้อมสำหรับการดาวน์โหลด คุณจะเห็นส่วน "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" อยู่ที่ด้านบนของบทความฐานความรู้นี้ หากส่วนนี้ไม่ปรากฏขึ้น ให้ส่งการร้องขอไปที่ฝ่ายบริการสนับสนุนลูกค้าของ Microsoft เพื่อขอรับโปรแกรมแก้ไขด่วน

หมายเหตุ:หากเกิดปัญหาอื่น ๆ หรือ ถ้ามีการแก้ไขปัญหาเป็นสิ่งจำเป็น คุณอาจต้องสร้างการร้องขอบริการแยกต่างหาก ค่าใช้จ่ายในการสนับสนุนปกติจะเกิดขึ้นเมื่อมีคำถามและประเด็นการสนับสนุนอื่นๆ ซึ่งไม่จัดอยู่ในโปรแกรมแก้ไขด่วนเฉพาะที่กล่าวถึงนี้ สำหรับรายการของหมายเลขโทรศัพท์ของฝ่ายบริการและการสนับสนุนลูกค้าของ Microsoft ทั้งหมด หรือถ้าต้องการสร้างคำขอรับการสนับสนุนแยกต่างหาก โปรดเข้าสู่เว็บไซต์ของ Microsoft ต่อไปนี้::
http://support.microsoft.com/contactus/?ws=support
หมายเหตุ:แบบฟอร์ม "โปรแกรมแก้ไขด่วนพร้อมดาวน์โหลด" แสดงภาษาในโปรแกรมแก้ไขด่วนมีอยู่ หากคุณไม่เห็นภาษาของคุณ เป็นเพราะไม่มีโปรแกรมแก้ไขด่วนสำหรับภาษานั้น
คอมโพเนนต์: ระบบ Attendant

โปรแกรมแก้ไขด่วนรุ่นภาษาอังกฤษนี้มีแอตทริบิวต์แฟ้ม (หรือแอตทริบิวต์แฟ้มหลังจากนี้) ซึ่งแสดงในตารางต่อไปนี้ วันที่และเวลาของแฟ้มเหล่านี้จะปรากฏในรูปแบบเวลามาตรฐานสากล (UTC) เมื่อคุณดูข้อมูลแฟ้ม ข้อมูลจะถูกแปลงเป็นเวลาท้องถิ่น เมื่อต้องการค้นหาความแตกต่างระหว่างเวลา UTC กับเวลาท้องถิ่น ใช้โซนเวลาแท็บในเครื่องมือ'วันและเวลา'ใน'แผงควบคุม'
Date         Time   Version            Size    File name
--------------------------------------------------------------
23-Dec-2003  03:55  6.0.6552.0      4,370,432  Adcadmin.dll     
23-Dec-2003  03:55  6.0.6552.0         69,632  Ccmproxy.dll     
23-Dec-2003  03:55  6.0.6552.0      2,109,440  Cdoexm.dll       
23-Dec-2003  03:55  6.0.6552.0      8,470,528  Exadmin.dll      
23-Dec-2003  03:55  6.0.6552.0      3,850,240  Excluadm.dll     
23-Dec-2003  03:56  6.0.6552.0      1,867,776  Exmgmt.exe       
23-Dec-2003  03:42  6.0.6552.0        720,896  Exsp.dll         
23-Dec-2003  03:56  6.0.6552.0      1,347,584  Exwmi.dll        
23-Dec-2003  03:56  6.0.6552.0         73,728  Inproxy.dll      
23-Dec-2003  03:56  6.0.6552.0      2,973,696  Mad.exe          
23-Dec-2003  03:56  6.0.6552.0        811,008  Madmsg.dll       
23-Dec-2003  03:55  6.0.6552.0      4,698,112  Maildsmx.dll     
23-Dec-2003  03:27  6.0.6552.0         57,344  Oabgen.dll       
23-Dec-2003  03:56  6.0.6552.0         77,824  Pcproxy.dll      
23-Dec-2003  03:56  6.0.6552.0         94,208  X400prox.dll
หมายเหตุ:เนื่องจากการอ้างอิงแฟ้ม โปรแกรมแก้ไขด่วนนี้จำเป็นต้องใช้ Exchange 2000 Server Service Pack 3 (SP3)สำหรับข้อมูลเพิ่มเติม ให้คลิกหมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
301378วิธีการขอรับ Exchange 2000 Server Service Pack รุ่นล่าสุด

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"
ก่อนมีแก้ไขปัญหานี้ใน Microsoft Exchange Server 2003 Service Pack 2

ข้อมูลเพิ่มเติม

สิ่งสำคัญนี้ส่วน วิธี หรืองานประกอบด้วยขั้นตอนที่บอกวิธีการแก้ไขรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีไม่ถูกต้อง ดังนั้น โปรดตรวจสอบให้แน่ใจว่าคุณได้ทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม ให้สำรองรีจิสทรีก่อนทำการปรับเปลี่ยน เพื่อที่คุณจะสามารถคืนค่ารีจิสทรีได้หากมีปัญหาเกิดขึ้น สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูลและคืนค่ารีจิสทรี โปรดคลิกที่หมายเลขบทความต่อไปนี้ เพื่อดูบทความในฐานความรู้ของ Microsoft::
322756วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows

หลังจากที่คุณใช้โปรแกรมแก้ไขด่วนนี้ คุณต้องเพิ่มคีย์ย่อยต่อไปนี้เพื่อรีจิสทรี:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeSA\LegacyCodeExecutionLevel
เมื่อต้องการเพิ่มคีย์ย่อยนี้ ดำเนินการดังต่อไปนี้:
  1. เริ่มการทำงานของตัวแก้ไขรีจิสทรี (Regedit.exe)
  2. ค้นหา และคลิกคีย์ย่อยของรีจิสทรีต่อไปนี้:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeSA
  3. ในการแก้ไขเมนู ให้ชี้ไปที่ใหม่แล้ว คลิกค่า DWORD. เพิ่มข้อมูลค่าต่อไปนี้กับคีย์ย่อยนี้:

    ชื่อค่า::LegacyCodeExecutionLevel
    ค่าชนิด: DWORD

    คีย์ย่อยของรีจิสทรีควรจะปรากฏขึ้นเป็น:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeSA\LegacyCodeExecutionLevel
คุณสามารถกำหนดค่าของคีย์ย่อยนี้หนึ่งค่าต่อไปนี้:
  • 0: ใช้การตั้งค่านี้ถ้าคุณไม่ต้องการรวมข้อมูลใด ๆ รหัสทั้งหมดจะถูกเรียกใช้
  • 1: ใช้การตั้งค่านี้ถ้าคุณต้องการรวมรหัสดั้งเดิมที่มีความปลอดภัยเพื่อแยก แต่มีรหัสที่จะมีผลกระทบ destabilization สูง
  • 2: ใช้การตั้งค่านี้ถ้าคุณต้องการรวมรหัสดั้งเดิมทั้งหมด

    หมายเหตุ:This setting is a high risk setting. If you set this value to2, the Exchange System Attendant (MAD) does not apply any of the security policies to the registry.

คุณสมบัติ

หมายเลขบทความ (Article ID): 831260 - รีวิวครั้งสุดท้าย: 14 มกราคม 2554 - Revision: 4.0
ใช้กับ
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Keywords: 
kbautohotfix kbhotfixserver kberrmsg kbqfe kbfix kbexchange2000presp4fix kbbug kbmt KB831260 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:831260

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com