Your Windows 2000-based computer stops responding after the computer runs without interruption for more than one year

Article translations Article translations
Article ID: 831409 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

Symptoms

Your Microsoft Windows 2000-based computer stops responding after the computer runs without interruption for more than one year. If your computer uses a hardware abstraction layer (HAL) that is included with Windows 2000, your computer may stop responding after 497 days. If your computer uses a third-party custom HAL, your computer may stop responding after a longer time.

Cause

This problem occurs because the NtGetTickCount function returns a large gap when the KeTickCount function wraps from an address of 0xffffffff to an address of 0x00000001 0x00000000. The tick count produces a large gap because of 64-bit to 32-bit conversions.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows 2000 Service Pack 3 (SP3) or later.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version             Size  File name
   ----------------------------------------------------------
   21-Sep-2003  00:36  5.0.2195.6824     29,712  Mountmgr.sys
   05-Dec-2003  18:12  5.0.2195.6880  1,699,264  Ntkrnlmp.exe
   05-Dec-2003  18:13  5.0.2195.6880  1,698,560  Ntkrnlpa.exe
   05-Dec-2003  18:13  5.0.2195.6880  1,719,360  Ntkrpamp.exe
   05-Dec-2003  18:12  5.0.2195.6880  1,676,928  Ntoskrnl.exe

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about other problems on systems that run longer than 497 days, click the following article number to view the article in the Microsoft Knowledge Base:
322913 WM_TIMER messages may stop being delivered to programs in Windows 2000
For more information about how hotfix packages are named, click the following article numbers to view the articles in the Microsoft Knowledge Base:
816915 New naming schema for Microsoft Windows hotfix packages
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 831409 - Last Review: November 2, 2013 - Revision: 3.0
Applies to
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbwin2000presp5fix KB831409

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com