ID do artigo: 831429 - Última revisão: terça-feira, 14 de setembro de 2010 - Revisão: 3.0

O Windows XP pára de responder ao baixar atualizações pelo Windows Update

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao tentar baixar uma atualização pelo site do Windows Update em um computador com base no Windows 2000 ou no Windows XP, você poderá enfrentar um dos seguintes sintomas:
  • A seguinte mensagem de erro é exibida:
    Erro de inicialização 0x8007007e
    No arquivo Windows Update.log no diretório do Windows uma mensagem semelhante à seguinte poderá ser exibida:
    Erro IUENGINE determina a configuração da máquina (Erro 0x8007007E: Não foi possível localizar o módulo especificado.)
  • O computador pode parar de responder após aceitar os termos de licença.

Causa

Este problema pode ocorrer se houver arquivos do sistema corrompidos ou não registrados no computador.

Resolução

Para resolver esse problema, use os seguintes métodos conforme apropriado para o sistema e na ordem em que aparecem.

Windows XP

Para verificar os arquivos do sistema, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar e digite:Cmd.exe
  2. Clique em OK.
  3. Tipo:
    SFC.exe /scannow
  4. Pressione ENTER. O Windows verifica os arquivos protegidos do Windows e pode solicitar a inserção do CD do Windows XP para restaurar os arquivos.
  5. Quando a verificação do arquivo for concluída, digite:
    exit
  6. Pressione ENTER.

Windows 2000

Método 1: registre os arquivos do sistema

Para registrar os arquivos do sistema, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar e digite:
    regsvr32 /i Urlmon.dll
  2. Clique em OK.
  3. Ao receber a mensagem "DllRegisterServer em urlmon.dll com êxito", clique em OK e tente usar o site do Windows Update.
  4. Se o problema repetir, repita as etapas 1 a 3 para todos os seguintes comandos:
    • regsvr32 /i Shdocvw.dll
    • regsvr32 Msjava.dll
    • regsvr32 Actxprxy.dll
    • regsvr32 Oleaut32.dll
    • regsvr32 /i Mshtml.dll
    • regsvr32 /i Browseui.dll
    • regsvr32 /i Shell32.dll
Se o problema não for resolvido, alguns arquivos do sistema podem estar incorretos. Vá para o próximo método.

Método 2: executar a Ferramenta de reparo do Internet Explorer

Para executar a Ferramenta de reparo do Internet Explorer, execute as seguintes etapa:
  1. Clique em Iniciar, aponte para Configurações e clique em Painel de controle.
  2. Clique duas vezes em Adicionar ou remover programas.
  3. Na guia Alterar ou remover programas, clique em Microsoft Internet Explorer.
  4. Clique em Alterar/Remover, marque a caixa de seleção Reparar o Internet Explorer e clique em OK.
  5. Ao ser solicitado a detectar e reparar os problemas no Internet Explorer, clique em Sim.
Se o problema não for resolvido, vá para o próximo método.

Método 3: instalar o Microsoft XML Parser

Para obter a versão mais recente do Microsoft XML Parser, visite o seguinte site da Microsoft (em inglês):
http://www.microsoft.com/downloads/details.aspx? FamilyId=2CF40AE6-368C-4B6B-A185-2DFA92FB7993&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyId=2CF40AE6-368C-4B6B-A185-2DFA92FB7993&displaylang=en)
Depois de instalar o XML Parser, tente se conectar ao site do Windows Update.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Update
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Encarta Encyclopedia 2000 Deluxe Edition
Palavras-chave: 
kbenv kbprb KB831429