Показват се няколко празни диалогови прозорци

Преводи на статии Преводи на статии
ID на статията: 831430 - Преглед на продукти, за които се отнася тази статия.
Важно Тази статия съдържа информация за модифициране на системния регистър. Направете резервно копие на регистъра преди да го промените. Уверете се, че знаете как да възстановите регистъра в случай на възникване на проблем. За информация относно резервното копиране, възстановяването и модифицирането на системния регистър щракнете върху следния номер на статия в базата знания на Microsoft:
256986 Описание на системния регистър на Microsoft Windows
Разгъване на всички | Сгъване на всички

На тази страница

СИМПТОМИ

Възможно е да изпитате някой от следните симптоми:
  • При опит за разглеждане на който и да е от следните диалогови прозорци забелязвате, че съответният диалогов прозорец е изцяло или частично празен:
    • Придружител за търсене
    • Потребителски акаунти
    • Windows Update
    • Помощ и поддръжка
    • Възстановяване на системата
  • При опит за стартиране на Microsoft Windows Media Player може да се появи съобщение за грешка "An internal application error has occurred" ("Възникна вътрешна грешка в приложение") или друго подобно съобщение.
  • Функцията за печат в Internet Explorer може да не работи. Когато щракнете върху File ("Файл") и след това върху Print ("Печат"), диалоговият прозорец Print ("Печат") не се появява. Прозорецът за предварителен преглед на съдържанието за печат се извежда празен.

ПРИЧИНА

Този проблем може да възникне, ако една или няколко настройки на ключовете на системния регистър за Jscript са грешни. Това може да се случи, ако файлът Jscript.dll липсва или е увреден.

РАЗРЕШЕНИЕ

За да решите проблема, използвайте следните методи в последователността, в която са представени.

Метод 1: Регистрирайте повторно Jscript.dll и Vbscript.dll

  1. Щракнете върху Start ("Старт") и изберете Run ("Изпълни").
  2. В полето Open ("Отвори") въведете regsvr32 jscript.dll и натиснете OK.
  3. Натиснете OK.
  4. Щракнете върху Start ("Старт") и изберете Run ("Изпълни").
  5. В полето Open ("Отвори") въведете regsvr32 vbscript.dll и натиснете OK.
  6. Натиснете OK.
Ако някой от файловете не се регистрира по очаквания от вас начин или ако се появи съобщение за грешка, това означава, че системният файл липсва или е повреден. За да извлечете липсващия файл в Microsoft Windows XP, изпълнете следните стъпки:
  1. Щракнете върху Start ("Старт") и изберете Run ("Изпълни").
  2. В полето Open ("Отвори") въведете msconfig и натиснете OK.
  3. Натиснете Expand File ("Разархивирай файла").
  4. В полето File to restore ("Файл за възстановяване") въведете името на файла, който искате да възстановите.
  5. В полето Restore from ("Възстанови от") въведете пътя към .cab файла на Windows XP, от който искате да възстановите файла, или натиснете Browse From ("Преглед от"), за да намерите този .cab файл на Windows XP.

    Забележка Cab файловете на Windows XP се съхраняват в папката I386 на компактдиска на Windows XP.
  6. В диалоговия прозорец Save file in ("Запиши файла в") въведете пътя към мястото, където искате да извлечете файла, или щракнете върху Browse To ("Преглед в"), за да намерите желаната папка.
  7. Натиснете Expand ("Разшири").
  8. В диалоговия прозорец на System Configuration Utility ("Помощната програма за конфигуриране на системата") натиснете OK. Ако се появи подкана да рестартирате компютъра, натиснете Restart ("Рестартирай").
Отворете диалогов прозорец, с който е възниквал проблемът, описан в раздела "Симптоми" на тази статия. Ако проблемът се повтори, продължете към следващия метод.

Метод 2: Редактирайте системния регистър

Предупреждение При неправилна промяна на системния регистър посредством редактора на системния регистър или по друг начин е възможно да възникнат сериозни проблеми. Тези проблеми могат да наложат преинсталиране на операционната система. Microsoft не може да гарантира, че тези проблеми ще са разрешими. Променяйте регистъра на свой собствен риск.
  1. Щракнете върху Start ("Старт") и изберете Run ("Изпълни").
  2. В полето Open ("Отвори") въведете regedit и натиснете OK.
  3. Намерете следния ключ на системния регистър:
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c260-6ac0-11cf-b6d1-00aa00bbbb58}\In procServer32
    (Default) ("По подразбиране") данните за стойностите трябва да съдържат следната стойност:
    C:\WINDOWS\SYSTEM32\JSCRIPT.DLL
    Ако не е така, щракнете двукратно върху Default ("По подразбиране"), въведете C:\WINDOWS\SYSTEM32\JSCRIPT.DLL в полето Value data ("Данни за стойността") и натиснете OK.
  4. Стойностите на ThreadingModel трябва да съдържат следното:
    Both
    ("Двата") Ако не е така, щракнете двукратно върху ThreadingModel, след което въведете Both в полето Value data ("Данни за стойността").
  5. Намерете следния ключ на системния регистър:
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c261-6ac0-11cf-b6d1-00aa00bbbbb58}\In procServer32
  6. Повторете стъпките 3 и 4, за да редактирате ключа, след което преминете към стъпка 7.
  7. Намерете следния ключ на системния регистър:
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c262-6ac0-11cf-b6d1-00aa00bbbbb58}\In procServer32
  8. Повторете стъпките 3 и 4, за да редактирате ключа, след което преминете към стъпка 9.
  9. Затворете редактора на системния регистър.

Свойства

ID на статията: 831430 - Последна рецензия: 12 май 2007 г. - Редакция: 4.0
ВАЖИ ЗА
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Ключови думи: 
kbprb KB831430

Изпратете обратна информация

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com