Artikel-id: 831430 - Få vist de produkter, som denne artikel refererer til.
Vigtigt! Denne artikel indeholder oplysninger om redigering af registreringsdatabasen. Husk at tage en sikkerhedskopi af registreringsdatabasen, før du redigerer den. Kontroller, at du ved, hvordan registreringsdatabasen gendannes, hvis der opstår problemer. Du kan finde flere oplysninger om, hvordan du sikkerhedskopierer, gendanner og redigerer registreringsdatabasen, ved at klikke på nedenstående artikelnummer for at få vist artiklen i Microsoft Knowledge Base:
256986 Beskrivelse af Microsoft Windows-registreringsdatabasen
Udvid alle | Skjul alle

På denne side

Symptomer

Du kan komme ud for et af følgende symptomer:
  • Når du forsøger at få vist én af følgende dialogbokse, kan dialogboksen se ud til at være tom eller delvist tom:
    • Søgeassistent
    • Brugerkonti
    • Windows Update
    • Hjælp og support
    • Systemgendannelse
  • Når du forsøger at starte Microsoft Windows Media Player, vises fejlmeddelelsen "Der opstod en intern programfejl" muligvis.
  • Der kan muligvis ikke udskrives fra Internet Explorer. Når du klikker på Udskriv i menuen Filer, bliver dialogboksen Udskriv ikke vist. Vis udskrift er tom.

Årsag

Problemet kan opstå, hvis en eller flere af indstillingerne for registreringsdatabasenøglen Jscript er ukorrekte. Problemet kan også opstå, hvis filen Jscript.dll mangler eller er beskadiget.

Løsning

Du kan løse dette problem ved at bruge følgende metoder i nævnte rækkefølge:

Metode 1: Registrer Jscript.dll og Vbscript.dll igen

  1. Klik på Start, og klik derefter på Kør.
  2. Skriv regsvr32 jscript.dll i feltet Åbn, og klik derefter på OK.
  3. Klik på OK.
  4. Klik på Start, og klik derefter på Kør.
  5. Skriv regsvr32 vbscript.dll i feltet Åbn, og klik derefter på OK.
  6. Klik på OK.
Hvis en af filerne ikke kan registreres som forventet, eller hvis der vises en fejlmeddelelse, kan systemfilen mangle eller være beskadiget. Følg disse trin for at gendanne den manglende fil i Microsoft Windows XP:
  1. Klik på Start, og klik derefter på Kør.
  2. Skriv msconfig i feltet Åbn, og klik derefter på OK.
  3. Klik på Udpak fil.
  4. Du skal angive navnet på den fil, du vil gendanne, i feltet Fil, der skal gendannes.
  5. Angiv stien til den .cab-fil i Windows XP, hvor du vil gendanne filen, i feltet Gendan fra, eller klik på Find kilde for at finde .cab-filen i Windows XP.

    Bemærk! .cab-filer i Windows XP er gemt i mappen I286 på Windows XP-cd'en.
  6. Angiv den sti, hvor du vil udpakke den nye fil, i feltet Gem fil i, eller klik på Find kilde for at finde den ønskede mappe.
  7. Klik på Udvid.
  8. Klik på OK i dialogboksen Systemkonfigurationsprogram. Hvis du bliver bedt om at genstarte computeren, skal du klikke på Genstart.
Åbn en dialogboks, som tidligere oplevede det problem, der er beskrevet i afsnittet "Symptomer" i denne artikel. Hvis problemet opstår igen, skal du gå videre til næste metode.

Metode 2: Rediger registreringsdatabasen

Advarsel! Der kan opstå alvorlige problemer, hvis registreringsdatabasen ikke redigeres korrekt ved hjælp af Registreringseditor eller en tilsvarende metode. Disse problemer kan medføre, at du skal geninstallere operativsystemet. Microsoft kan ikke garantere, at sådanne problemer kan løses. Ændring af registreringsdatabasen sker på eget ansvar.
  1. Klik på Start, og klik derefter på Kør.
  2. Skriv regedit i feltet Åbn, og klik derefter på OK.
  3. Find følgende registreringsdatabasenøgle:
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c260-6ac0-11cf-b6d1-00aa00bbbb58}\In procServer32
    Værdidataene for (Standard) skal indeholde følgende værdi:
    C:\WINDOWS\SYSTEM32\JSCRIPT.DLL
    Hvis de ikke gør det, skal du dobbeltklikke på Standard, skrive C:\WINDOWS\SYSTEM32\JSCRIPT.DLL i feltet Værdidata og derefter klikke på OK.
  4. Værdien ThreadingModel skal indeholde følgende værdi:
    Both
    Hvis den ikke gør det, skal du dobbeltklikke på ThreadingModel og derefter skrive Both i feltet Værdidata.
  5. Find følgende registreringsdatabasenøgle:
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c261-6ac0-11cf-b6d1-00aa00bbbbb58}\In procServer32
  6. Gentag trin 3 og 4 for at redigere denne nøgle, og gå derefter til trin 7.
  7. Find følgende registreringsdatabasenøgle:
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c262-6ac0-11cf-b6d1-00aa00bbbbb58}\In procServer32
  8. Gentag trin 3 og 4 for at redigere denne nøgle, og gå derefter til trin 9.
  9. Afslut Registreringseditor.

Egenskaber

Artikel-id: 831430 - Seneste redigering: 22. december 2006 - Redigering: 4.0
Oplysningerne i denne artikel gælder:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Nøgleord: 
kbprb KB831430

Send feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com