文書番号: 831430 - 対象製品
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
322756 Windows XP および Windows Server 2003 でレジストリをバックアップ、編集および復元する方法
すべて展開する | すべて折りたたむ

目次

現象

次のいずれかの現象が発生することがあります。
  • 次のダイアログ ボックスのいずれかを表示しようとすると、ダイアログ ボックスに何も表示されない場合や、内容が部分的にしか表示されない場合があります。
    • 検索コンパニオン
    • ユーザー アカウント
    • Windows Update
    • ヘルプとサポート
    • システムの復元
  • Microsoft Windows Media Player を起動しようとすると、エラー メッセージ "内部アプリケーション エラーが発生しました" (または、これに類似したエラー メッセージ) が表示される場合があります。
  • Internet Explorer で印刷ができない場合があります。[ファイル] メニューをクリックし、[印刷] をクリックしても、[印刷] ダイアログ ボックスが表示されません。印刷プレビューも空白になります。

原因

この問題は、設定の正しくない Jscript レジストリ キーがある場合に発生することがあります。Jscript.dll ファイルが存在しないか破損している場合にも、この問題が発生することがあります。

解決方法

この問題を解決するには、以下の手順を記載されている順に実行します。

方法 1 : Jscript.dll を再登録する

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに regsvr32 jscript.dll と入力し、[OK] をクリックします。
  3. [OK] をクリックします。
ファイルが正常に登録できない場合、またはエラー メッセージが表示される場合は、システム ファイルが存在しないか破損している可能性があります。Windows XP で不足しているファイルを展開するには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに msconfig と入力し、[OK] をクリックします。
  3. [ファイルの展開] をクリックします。
  4. [復元するファイル] ボックスに、復元するファイル名を入力します。
  5. [復元の参照元] ボックスに、復元するファイルが含まれる Windows XP の .cab ファイルのパスを入力するか、[参照元の参照] をクリックして Windows XP の .cab ファイルを指定します。

    : Windows XP の .cab ファイルは、Windows XP の CD の i386 フォルダにあります。
  6. [ファイルの保存先] ボックスに、新しいファイルの展開先のパスを入力するか、[保存先の参照] をクリックして展開先のフォルダを指定します。
  7. [展開] をクリックします。
  8. [システム構成ユーティリティ] ダイアログ ボックスで [OK] をクリックします。コンピュータの再起動を要求するメッセージが表示されたら、[再起動] をクリックします。
この資料の「現象」に記載されている問題が発生したダイアログ ボックスを開きます。問題が解決しない場合は、次の方法に進みます。

方法 2 : レジストリを編集する

レジストリを編集するには、次の手順を実行します。

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。
  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
  2. [名前] ボックスに regedit と入力し、[OK] をクリックします。
  3. 次のレジストリ キーを見つけます。
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c260-6ac0-11cf-b6d1-00aa00bbbb58}\InprocServer32
    (既定) の値のデータが次の値に設定されている必要があります。
    C:\WINDOWS\SYSTEM32\JSCRIPT.DLL
    データが上記以外の場合は、[既定] をダブルクリックし、[値のデータ] ボックスに C:\WINDOWS\SYSTEM32\JSCRIPT.DLL と入力し、[OK] をクリックします。
  4. ThreadingModel の値のデータが次の値に設定されている必要があります。
    Both
    データが上記以外の場合は、[ThreadingModel] をダブルクリックして、[値のデータ] ボックスに Both と入力します。
  5. 次のレジストリ キーを見つけます。
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c261-6ac0-11cf-b6d1-00aa00bbbb58}\InprocServer32
  6. 手順 3. 〜 4. と同様の操作を行い、手順 7. に進みます。
  7. 次のレジストリ キーを見つけます。
    HKEY_LOCAL_MACHINE\SOFTWARE\CLASSES\CLSID\{f414c262-6ac0-11cf-b6d1-00aa00bbbb58}\InprocServer32
  8. 手順 3. 〜 4. と同様の操作を行い、手順 9. に進みます。
  9. レジストリ エディタを終了します。

プロパティ

文書番号: 831430 - 最終更新日: 2008年3月19日 - リビジョン: 5.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbprb KB831430
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com