Aparece un mensaje de error cuando intenta imprimir en una impresora de red compartida en una sesión de Terminal Server

Seleccione idioma Seleccione idioma
Id. de artículo: 831754 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando está conectado a una sesión de terminal server en un equipo basado en Microsoft Windows 2000 o en un equipo basado en Microsoft Windows Server 2003 e intenta imprimir desde cualquier programa en una impresora de red compartida, puede recibir un mensaje de error que es similar a uno de los siguientes:
No hay impresoras se instalan. Para instalar a una impresora, elija Configuración en el menú Inicio de Windows, haga clic en impresora y, a continuación, haga doble clic en Agregar impresora. Siga las instrucciones del asistente.
Impresora actual no está disponible. Seleccione otra impresora.
Antes de imprimir, deberá seleccionar una impresora. Si necesita instalar a una impresora, haga doble clic en el icono Agregar impresora o elija el botón Buscar impresora ubicado en la ficha general de este cuadro de diálogo.
Mensajes de error variar desde un programa a otro.

Después de recibir uno de estos mensajes de error y, a continuación, haga clic en Aceptar , es posible que abrirá el cuadro de diálogo impresoras . Si selecciona la misma impresora que provocó el mensaje de error, los botones Imprimir y no están disponibles y no puede imprimir. Si selecciona una impresora diferente, quizás pueda imprimir.

Causa

Este problema puede producirse si otro usuario inicia sesión en el servidor de terminal server y el usuario tiene una versión posterior del mismo controlador de impresora instalado en su equipo. Cuando la cola de impresión se detecta el controlador de nuevo en el servidor Terminal Server, en la cola de impresión se crea un nuevo archivo de datos binarios para la versión posterior del controlador de impresora. Cuando intenta imprimir desde un programa en la sesión de terminal server, no puede tener acceso al nuevo archivo de datos binarios porque la versión anterior del controlador de impresora está instalada en su equipo.

Archivos de datos binarios son archivos temporales que el controlador de impresora universal (Unidrv) crea después analiza la información que se encuentra en archivos de texto del minicontrolador. El controlador de impresora universal (Unidrv) es el controlador de impresora estándar que utiliza Microsoft para las impresoras no PostScript. Archivos de datos binarios Unidrv tienen la .bud extensión nombre.

Solución

Información de revisiones

Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información del archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.

Windows Server 2003, versiones basadas en Itanium

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaTipo de servicio
Localspl.dll5.2.3790.220860,16030-Sep-200408: 32IA-64RTMQFE
Spoolss.dll5.2.3790.212233,98430-Sep-200408: 32IA-64RTMQFE

Windows Server 2003, versiones basadas en 86 en x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaTipo de servicio
Localspl.dll5.2.3790.220312,32030-Sep-200423: 28x 86RTMQFE
Spoolss.dll5.2.3790.21281,40830-Sep-200423: 28x 86RTMQFE

Windows 2000

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado Windows 2000 Service Pack 3 (SP3).

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información del archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.

Windows 2000

Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaTipo de servicio
Basesrv.dll5.0.2195.682442.25620-Nov-200322: 59x 86No aplicable
Cmd.exe5.0.2195.6824236.30421-Sep-200300: 45x 86No aplicable
Faxui.dll0.2.0.1138.00020-Nov-200322: 59x 86No aplicable
Gdi32.dll5.0.2195.6824222,99220-Nov-200322: 59x 86No aplicable
Kernel32.dll5.0.2195.6867711,44020-Nov-200322: 59x 86No aplicable
Localspl.dll5.0.2195.6876252,68820-Nov-200322: 59x 86No aplicable
Mpr.dll5.0.2195.682454.03220-Nov-200322: 59x 86No aplicable
Msgina.dll5.0.2195.6876334,09620-Nov-200322: 59x 86No aplicable
Rdpwd.sys5.0.2195.682490,23220-Nov-200322: 59x 86No aplicable
Sp3res.dll5.0.2195.68705,847,55206-Nov-200322: 29x 86No aplicable
Spoolss.dll5.0.2195.687680,14420-Nov-200322: 59x 86No aplicable
User32.dll5.0.2195.6869380,17620-Nov-200322: 59x 86No aplicable
Userenv.dll5.0.2195.6871389,39220-Nov-200322: 59x 86No aplicable
Win32k.sys5.0.2195.68691,628,81631-Oct-200303: 02x 86No aplicable
Win32spl.dll5.0.2195.682487,31220-Nov-200322: 59x 86No aplicable
Winlogon.exe5.0.2195.6873182,03211-Nov-200300: 29x 86No aplicable
Winsrv.dll5.0.2195.6873243,98420-Nov-200322: 59x 86No aplicable
Kernel32.dll5.0.2195.6867711,44020-Nov-200322: 59x 86UNIPROC
Win32k.sys5.0.2195.68691,628,81631-Oct-200303: 02x 86UNIPROC
Winsrv.dll5.0.2195.6873243,98420-Nov-200322: 59x 86UNIPROC

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 831754 - Última revisión: domingo, 04 de noviembre de 2007 - Versión: 3.9
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp5fix KB831754 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 831754

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com