Você recebe uma mensagem de erro quando tenta imprimir em uma impressora de rede compartilhada em uma sessão do terminal server

Traduções deste artigo Traduções deste artigo
ID do artigo: 831754 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você estiver conectado a uma sessão do terminal server em um computador baseado no Microsoft Windows 2000 ou um computador baseado no Microsoft Windows Server 2003 e você tentar imprimir em qualquer programa para uma impressora de rede compartilhada, você receberá uma mensagem de erro é semelhante a um destes procedimentos:
Nenhuma impressora instalada. Para instalar uma impressora, aponte para configurações no Menu Iniciar do Windows, clique em impressora e, em seguida, clique duas vezes em Adicionar impressora. Siga as instruções no assistente.
A impressora atual não está disponível. Selecione outra impressora.
Antes de imprimir, você precisa selecionar uma impressora. Se você precisar instalar uma impressora, clique duas vezes no ícone Adicionar impressora ou clique no botão Localizar impressora localizado na guia geral desta caixa de diálogo.
Mensagens de erro variam de programa para programa.

Após receber uma das seguintes mensagens de erro e, em seguida, clique em OK , a caixa de diálogo impressora poderá ser aberta. Se você selecionar a mesma impressora que causou a mensagem de erro, os botões Imprimir e Aplicar não estão disponíveis, e não é possível imprimir. Se você selecionar uma impressora diferente, talvez você consiga imprimir.

Causa

Esse problema pode ocorrer se outro usuário fizer logon ao servidor de terminal e o usuário tem uma versão posterior do mesmo driver de impressora instalado no computador. Quando o spooler de impressão detecta o novo driver no servidor de terminal, o spooler cria um novo arquivo de dados binários para a versão mais recente do driver de impressora. Quando você tentar imprimir a partir de um programa em sua sessão de servidor de terminal, você não poderá acessar o novo arquivo de dados binários porque a versão anterior do driver da impressora está instalada no seu computador.

Arquivos de dados binários são arquivos temporários que o driver de impressora universal (Unidrv) cria depois ele analisa informações contidas em arquivos de texto minidriver. O driver de impressora universal (Unidrv) é o driver de impressora padrão que a Microsoft usa para impressoras PostScript não. Arquivos de dados binários Unidrv têm uma extensão nome .bud.

Resolução

Informações sobre o hotfix

Windows Server 2003

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.

Windows Server 2003, versões com base em Itanium

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRamificação do serviço
Localspl.dll5.2.3790.220860,16030 De setembro de 200408: 32IA-64RTMQFE
Spoolss.dll5.2.3790.212233,98430 De setembro de 200408: 32IA-64RTMQFE

Windows Server 2003, versões com base em 86 x

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRamificação do serviço
Localspl.dll5.2.3790.220312,32030 De setembro de 200423: 28x 86RTMQFE
Spoolss.dll5.2.3790.21281,40830 De setembro de 200423: 28x 86RTMQFE

Windows 2000

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, você deve ter o Windows 2000 Service Pack 3 (SP3) instalado.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.

Windows 2000

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataformaRamificação do serviço
Basesrv.dll5.0.2195.682442,25620-Nov-200322: 59x 86Não aplicável
Cmd.exe5.0.2195.6824236.30421-Set-200300: 45x 86Não aplicável
Faxui.dll0.2.0.1138,00020-Nov-200322: 59x 86Não aplicável
Gdi32.dll5.0.2195.6824222,99220-Nov-200322: 59x 86Não aplicável
Kernel32.dll5.0.2195.6867711,44020-Nov-200322: 59x 86Não aplicável
Localspl.dll5.0.2195.6876252,68820-Nov-200322: 59x 86Não aplicável
MPR.dll5.0.2195.682454,03220-Nov-200322: 59x 86Não aplicável
Msgina.dll5.0.2195.6876334,09620-Nov-200322: 59x 86Não aplicável
Rdpwd.sys5.0.2195.682490,23220-Nov-200322: 59x 86Não aplicável
Sp3res.dll5.0.2195.68705,847,55206-Nov-200322: 29x 86Não aplicável
Spoolss.dll5.0.2195.687680,14420-Nov-200322: 59x 86Não aplicável
User32.dll5.0.2195.6869380,17620-Nov-200322: 59x 86Não aplicável
Userenv.dll5.0.2195.6871389,39220-Nov-200322: 59x 86Não aplicável
Win32k.sys5.0.2195.68691,628,81631-Out-200303: 02x 86Não aplicável
Win32spl.dll5.0.2195.682487,31220-Nov-200322: 59x 86Não aplicável
Winlogon.exe5.0.2195.6873182,03211-Nov-200300: 29x 86Não aplicável
Winsrv.dll5.0.2195.6873243,98420-Nov-200322: 59x 86Não aplicável
Kernel32.dll5.0.2195.6867711,44020-Nov-200322: 59x 86UNIPROC
Win32k.sys5.0.2195.68691,628,81631-Out-200303: 02x 86UNIPROC
Winsrv.dll5.0.2195.6873243,98420-Nov-200322: 59x 86UNIPROC

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter informações adicionais sobre como os pacotes de hotfix são nomeados, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
816915Novo esquema de nomeação de arquivo para pacotes de atualização de software do Microsoft Windows
Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 831754 - Última revisão: domingo, 4 de novembro de 2007 - Revisão: 3.9
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbbug kbfix kbqfe kbwin2000presp5fix KB831754 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 831754

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com