Erro: O snap-in da Host Integration Server Management Console não é iniciado

Traduções de Artigos Traduções de Artigos
Artigo: 831893 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando abrir o snap-in da consola de gestão da Microsoft SNA Manager, o snap-in deixa de responder (não reage) durante cerca de 60 segundos, e, em seguida, recebe a seguinte mensagem de erro:

Foi perdida a comunicação com os servidores. Tem de ser reiniciado SNA Manager.
Além disso, 5149 um evento semelhante à seguinte é registado no registo de eventos de aplicações:

Origem do evento ID do evento: 5149: Descrição do serviço de gerir SNA: Gerir base erro - Erro ao aceder à tabela de domínio. O nome de domínio local não é válido

Causa

Um identificador de um semáforo que indica que o processo de MngClient está em execução não é encerrado em todas as situações. Por conseguinte, a consola de gestão assume que este processo está em execução quando não está em execução.

Resolução

Informações sobre Service Packs

Para resolver este problema, obtenha o service pack mais recente do Microsoft Host Integration Server 2000. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
328152Como obter o service pack mais recente do Host Integration Server 2000

Informações sobre a correcção

A versão inglesa desta correcção tem os atributos de ficheiro (ou posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas no formato de universal hora (UTC) coordenada Coordinated. Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version    Size     File name
   ----------------------------------------------------
   10-Nov-2003  21:56  5.0.0.952  114,960  Mngbase.dll
   10-Nov-2003  21:56  5.0.0.952  102,672  Mngagent.exe
   10-Nov-2003  21:56  5.0.0.952  102,672  Mngcli.exe

				

Nota Devido a dependências de ficheiros, a correcção mais recente que contenha estes ficheiros também poderão conter ficheiros adicionais.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".Este problema foi corrigido no Microsoft Host Integration Server 2000 Service Pack 2.

Mais Informação

Quando o snap-in Host Integration Server MMC é iniciado, o MngClient inicializa e cria o semáforo MNG_PROXY_TERM_SEM_NAME. O semáforo MNG_PROXY_TERM_SEM_NAME permanece aberto até fechar MngClient.

Quando a consola MMC ou o fornecedor Windows Management Instrumentation (WMI) é iniciado, primeiro tenta abrir este semáforo. Se existir o semáforo com este nome no sistema, SNA Manager assume que o MngClient está em execução. Caso contrário, o SNA Manager irá tentar iniciar uma nova instância do MngClient. Por conseguinte, o semáforo MNG_PROXY_TERM_SEM_NAME indica a existência do MngClient.

Em algumas circunstâncias, o MngClient não chama a função de CloseHandle contra este semáforo. Este comportamento é correcto na maior parte das vezes porque o sistema limpa todos os identificadores de um processo após o processo descarregado. No entanto, se o identificador não é fechado, uma janela de temporização aumenta uma vez que o sistema operativo demora algum tempo para descarregar o processo e para efectuar a limpeza. Esta janela de tempo maiores faz com que o problema descrito na secção "Sintomas".

Propriedades

Artigo: 831893 - Última revisão: 11 de fevereiro de 2014 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Host Integration Server 2000 Standard Edition
  • Microsoft Host Integration Server 2000 Service Pack 1
Palavras-chave: 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbhotfixserver kbqfe kbqfe kbfix kbbug KB831893 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 831893

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com