You receive a "stop 0x000000DA" error message on a blue screen after you enable PTE tracking on a Windows Server 2003-based node

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Article ID: 831899 - View products that this article applies to.
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SYMPTOMS

When you edit the registry of a Microsoft Windows Server 2003-based node in a server cluster to turn on page table entry (PTE) tracking, the server may stop responding. You may also receive a stop error message on a blue screen that is similar to the following:
Stop 0x000000DA (parameter1, parameter2, parameter3, parameter4) SYSTEM_PTE_MISUSE

CAUSE

This problem may occur if both the following conditions are true:
  • You turn on PTE tracking on the server by setting the
    TrackPTEs
    value in the following registry subkey to 1:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
  • The Classpnp.sys driver incorrectly references a memory location, and PTEs are incorrectly processed.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

Date         Time   Version        Size    File name
-------------------------------------------------------
16-Dec-2003  18:30  5.2.3790.113   61,952  Classpnp.sys

Windows Server 2003 64-bit edition

Date         Time   Version       Size     File name
-------------------------------------------------------
16-Dec-2003  18:08  5.2.3790.113  145,408  Classpnp.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 831899 - Last Review: July 24, 2007 - Revision: 3.11
APPLIES TO
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB831899

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