이벤트 ID 577이 Windows XP 기반 컴퓨터의 보안 이벤트 로그에 반복적으로 나타난다

기술 자료 번역 기술 자료 번역
기술 자료: 831905 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

Microsoft Windows XP 기반 컴퓨터에서 보안 이벤트 로그에 다음과 같은 실패 이벤트가 반복적으로 나타납니다.

원본: Security
종류: 오류
범주: 사용 권한 사용
이벤트 ID: 577
설명:
권한이 있는 서비스 호출:

서버: Security
서비스: -
기본 사용자 이름: PrimaryUserName
기본 도메인: PrimaryDomain
기본 로그온 ID: PrimaryLogonID
클라이언트 사용자 이름: ClientUserName
클라이언트 도메인: ClientDomain
클라이언트 로그온 ID: ClientLogonID
권한: SeIncreaseBasePriorityPrivilege

577 이벤트가 발생하면 사용자 컴퓨터에서 응답 시간이 길어지고 CPU 사용이 증가할 수 있습니다. 로컬 관리자 자격 증명이 있는 계정을 사용하여 Windows XP 기반 컴퓨터에 로그온하면 이러한 현상이 나타나지 않습니다.

원인

이 문제는 다음 조건에 모두 해당할 경우 발생할 수 있습니다.
  • Windows XP 기반 컴퓨터에 설치되어 있는 프로그램이 SetProcessWorkingSetSize 함수를 호출하여 작업 집합을 해제합니다.
  • 권한 사용 감사 범주의 감사가 설정되어 있습니다.
  • 해당 사용자 계정에 "예약 우선 순위 증가"라고도 하는 SeIncreaseBasePriorityPrivilege 사용자 권한이 없습니다.
이러한 조건에 해당하는 경우 SetProcessWorkingSetSize 함수를 호출하여 작업 집합을 해제하는 프로그램이 감사 이벤트 577을 트리거합니다. 프로그램 호출은 또한 SeIncreaseBasePriorityPrivilege 사용자 권한을 필요로 하는 함수에 대한 두 번째 호출도 트리거합니다. 이러한 두 번째 호출은 불필요합니다. SetProcessWorkingSetSize 함수가 두 번째 호출을 트리거하면 거짓 감사 이벤트 577이 보안 이벤트 로그에 기록됩니다.

해결 방법

서비스 팩 정보

이 문제를 해결하려면 Microsoft Windows XP용 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
322389 최신 Windows XP 서비스 팩을 구하는 방법

핫픽스 정보

Windows XP

현재 지원되는 핫픽스를 Microsoft에서 구할 수 있지만 이 문서에서 설명하는 문제를 해결하기 위한 것일 뿐이므로 이러한 특정 문제가 발생하는 시스템에만 이 핫픽스를 적용하십시오. 이 핫픽스는 나중에 추가 테스트를 받아야 할 수도 있습니다. 따라서 이 문제의 영향이 심각하지 않으면 이 핫픽스가 포함된 다음 서비스 팩이 나올 때까지 기다리는 것이 좋습니다.

이 문제를 해결하려면 Microsoft 온라인 고객 서비스에 요청을 제출하여 핫픽스를 구하십시오. 핫픽스를 구하기 위한 온라인 요청을 제출하려면 다음 Microsoft 웹 사이트를 방문하십시오.
http://go.microsoft.com/?linkid=6294451
참고 문제가 추가로 발생하거나 문제 해결이 필요한 경우 별도의 서비스 요청을 해야 할 수도 있습니다. 이 특정 핫픽스로 해결할 수 없는 추가 질문과 문제에 대해서는 지원 비용이 청구됩니다. 별도의 서비스 요청을 하려면 다음 Microsoft 웹 사이트를 방문하십시오.
기술지원 서비스 안내
이 핫픽스의 영어 버전은 아래와 같거나 그 이상의 특성을 갖고 있습니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 보려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.
표 축소표 확대
날짜시간버전크기파일 이름플랫폼
2003-12-1018:225.1.2600.13261,897,472Ntkrnlmp.exex86
2003-12-1018:235.1.2600.13261,953,536Ntkrnlpa.exex86
2003-12-1018:225.1.2600.13261,925,632Ntkrpamp.exex86
2003-12-1018:225.1.2600.13261,930,496Ntoskrnl.exe x86
2003-12-1018:225.1.2600.13265,831,040Ntkrnlmp.exeIA-64
2003-12-1018:225.1.2600.13265,774,464Ntoskrnl.exeIA-64
참고 이 핫픽스를 사용하려면 Windows XP 서비스 팩 1이 있어야 합니다.

Microsoft Windows 2000

현재 지원되는 핫픽스를 Microsoft에서 구할 수 있지만 이 문서에서 설명하는 문제를 해결하기 위한 것일 뿐이므로 이러한 특정 문제가 발생하는 시스템에만 이 핫픽스를 적용해야 합니다.

이 문제를 해결하려면 Microsoft 고객기술지원부에 문의하여 핫픽스를 구하십시오. Microsoft 고객기술지원부의 전체 전화번호 목록과 지원 비용에 대한 정보는 다음 Microsoft 웹 사이트를 참조하십시오.
기술지원 서비스 안내
참고?특정 업데이트로 문제를 해결할 수 있다고 Microsoft 기술지원 전문가가 판단할 경우 지원 요청에 따른 일반적 비용이 취소될 수도 있습니다. 해당 업데이트로 해결할 수 없는 추가 질문과 문제에 대해서는 지원 비용이 청구됩니다. 이 핫픽스의 영어 버전은 아래와 같거나 그 이상의 특성을 갖고 있습니다. 이 파일의 날짜와 시간은 UTC(Coordinated Universal Time)로 나열되며 파일 정보를 볼 때 로컬 시간으로 변환됩니다. UTC와 로컬 시간의 차이를 보려면 제어판날짜 및 시간 도구에서 표준 시간대 탭을 사용하십시오.

전제 조건


Windows 2000 서비스 팩 4가 설치되어 있어야 합니다.

다시 시작 요구 사항


이 핫픽스를 적용한 후에는 컴퓨터를 다시 시작해야 합니다.

핫픽스 대체 정보


이 핫픽스는 다른 핫픽스를 대체하지 않습니다.

파일 정보


표 축소표 확대
날짜시간버전크기파일 이름
2005-03-0819:545.0.2195.703590,544Mup.sys
2005-07-0504:585.0.2195.70581,714,560Ntkrnlmp.exe
2005-07-0504:595.0.2195.70581,713,600Ntkrnlpa.exe
2005-07-0504:595.0.2195.70581,735,936Ntkrpamp.exe
2005-07-0606:505.0.2195.70591,690,944Ntoskrnl.exe

현재 상태

Microsoft는 이 문서의 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열한 제품에서 이 문제를 확인했습니다. 이 문제는 Microsoft Windows XP 서비스 팩 2에서 처음 해결되었습니다.

추가 정보

SeIncreaseBasePriorityPrivilege 사용자 권한이 있으면 프로세스의 예약 우선 순위를 높일 수 있고 프로세스의 작업 집합을 늘릴 수 있습니다. 이렇게 하면 실행 속도가 향상됩니다.

작업 집합을 해제하려면 프로그램이 최소 크기 및 최대 크기를 모두 0xffffffff로 설정하여 SetProcessWorkingSetSize 함수를 호출하면 됩니다. 또한 프로그램은 오랫동안 유휴 상태로 있거나 작업 집합이 큰 고비용 작업을 완료한 후에도 SetProcessWorkingSetSize 함수를 호출할 수 있습니다.

자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
824684 Microsoft 소프트웨어 업데이트를 설명하는 데 사용되는 표준 용어에 대한 설명




Microsoft 제품 관련 기술 전문가들과 온라인으로 정보를 교환하시려면 Microsoft 뉴스 그룹에 참여하시기 바랍니다.

속성

기술 자료: 831905 - 마지막 검토: 2007년 9월 7일 금요일 - 수정: 4.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
키워드:?
kbbug kbfix kbqfe kbwinxpsp2fix kbwinxppresp2fix kbhotfixserver KB831905

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com