Artikel-ID: 831962 - Geändert am: Dienstag, 24. Juli 2007 - Version: 8.8

Beim Abmelden von eines erweiterten Client-Computers möglicherweise eine lange Verzögerung eine Remotedesktopsitzung auftreten

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Problembeschreibung

Nachdem Sie die Microsoft Systems Management Server (SMS) 2003 Advanced Client-Software auf einem Terminal Server-Computer installiert haben, dauert es mehrere Minuten zum Abmelden von einer Terminaldienstesitzung auf dem erweiterten Client-Computer. Darüber hinaus möglicherweise Änderungen an Ihrem Profil nicht gespeichert.

Ursache

Dieses Problem kann auftreten, wenn ein anderer Benutzer versucht, eine Terminalserversitzung anmelden, während Sie einen Terminalserver-Sitzung abmelden möchten. In diesem Szenario werden die Abmeldung Benachrichtigungen synchron ausgeführt. Wenn Benutzer A versucht, eine Sitzung abmelden, wenn Benutzer B versucht, eine neue Sitzung anmelden, wird z. B. die Abmeldung blockiert, bis die Anmeldung abgeschlossen ist. Die Anmeldung kann zum Verarbeiten von Anmeldeskripts verzögert werden.

Darüber hinaus kann das Problem auftreten, wenn folgende Bedingungen erfüllt sind:
  • Keine Benutzer sind an der erweiterte Client Computer lokalen Konsole angemeldet.
  • Ein Benutzer versucht, eine Terminaldienstesitzung auf dem erweiterten Client Computer abmelden.

    Hinweis: Diese Bedingung nicht erforderlich, dass der Benutzer handeln eines bestimmten Benutzers. Alle Benutzer, die Anmeldung über Terminaldienste-Sitzungen treten dieses Problem, solange niemand in der lokalen Konsole angemeldet ist.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Der Hotfix ist jedoch nur die Behebung des Problems die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt. Dieser Hotfix kann einem späteren Zeitpunkt zusätzliche Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft daher, auf die nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download verfügbar ist, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar" am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an technischen Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten die für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen die folgende Microsoft-Website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist es, da ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen

Es gelten keine Voraussetzungen.

Neustartanforderung

Wenn Sie diesen Hotfix installieren, die SMS-Website-Dienste beenden und neu starten und der Hotfix startet eine SMS-Website zurücksetzen.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Hotfixes weist die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind in Coordinated Universal Time (UTC) angegeben. Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln verwenden Sie die Registerkarte Zeitzone des Tools ? Datum und Uhrzeit in der Systemsteuerung.
   Date         Time   Version             Size  File name
   ------------------------------------------------------------------------------
   26-Nov-2003  16:04                 6,448,128  Mp.msi  
   27-Nov-2003  00:32  2.50.2726.102  5,422,128  Sms2003-rtm-kb831962-x86-enu.exe  
   25-Dec-2003  07:10                    11,304  Filemap.ini
   25-Dec-2003  07:10  2.0.6.3          354,152  Smsupdate.exe    
   25-Dec-2003  07:10  2.50.2726.102    541,696  Ccmexec.exe      
   25-Dec-2003  07:10  2000.80.194.0    274,489  Ntwdblib.dll     
   25-Dec-2003  07:10  2.0.1493.5011    855,312  Preinst.exe      
   25-Dec-2003  07:10                   369,152  Sms2003ac-kb831962-x86.msp

Informationen zur Installation

Dieser Hotfix aktualisiert Client Configuration Manager (CCM) Framework-Komponente auf Version 2.50.2726.0102. Dieser Hotfix enthält ein erweiterter Client-Update und eine Verwaltung Punkt Framework aktualisieren. Sie müssen alle Verwaltungspunkte mit dem neuen Framework aktualisieren. Als Teil der Installation des führt dieser Hotfix einer Website zurückgesetzt, um alle Management-Punkte in der SMS-Hierarchie automatisch aktualisiert. Wenn das Zurücksetzen der SMS-Standort verzögert wird, müssen Sie manuell durchführen einer Site zurücksetzen oder entfernen und fügen Sie dann die Verwaltungspunkte. Sie müssen jede Site zurücksetzen, wo Sie diesen Hotfix anwenden. Verwenden Sie für im Hintergrund Hotfix den/s -Schalter in der Befehlszeile.

Sie müssen diesen Hotfix am primären und sekundären Standorten anwenden. Erstellen Sie ein neues Paket und ein neues Programm um diesen Hotfix auf den erweiterten Client Computern anzukündigen, aufgrund der neuen Architektur in SMS 2003. Als Teil des Installationsprogramms kann dieses Update das Paket und die Ankündigung automatisch erstellen. Microsoft empfiehlt, das Setupprogramm das Paket und die Ankündigung für Sie erstellen zu lassen.

Gehen Sie folgendermaßen vor um diesen Hotfix zu installieren:
  1. Downloaden Sie die Hotfixdatei, und führen Sie die selbstextrahierende ausführbare Datei zum Erstellen der Sms2003-rtm-kb831962-X 86-enu.exe-Datei.
  2. Kopieren Sie Sms2003-rtm-kb831962-X 86-DEU.exe in einen Ordner auf dem SMS primären oder sekundären Standort Server.
  3. Klicken Sie auf Start , zeigen Sie auf Programme , zeigen Sie auf Systems Management Server und klicken Sie dann auf SMS-Administratorkonsole .
  4. Erweitern Sie Standortdatenbank .
  5. Klicken Sie mit der rechten Maustaste auf Sammlungen , zeigen Sie auf neu und klicken Sie anschließend auf Sammlung .
  6. Geben Sie im Feld Name :
    Erweiterte Clients für 831962
  7. Klicken Sie auf die Eigenschaften für Abfrageregel Schaltfläche.
  8. Geben Sie im Feld Name :
    Erweiterte Clients für 831962
  9. Klicken Sie auf Abfrageanweisung bearbeiten .
  10. Klicken Sie auf der Registerkarte Allgemein auf die Anzeigen Abfragesprache Schaltfläche.
  11. Fügen oder geben Sie die folgende Abfrage im Abfrage-Anweisung :
    select * from SMS_R_System 
    	inner join SMS_G_System_SMS_ADVANCED_CLIENT_STATE 
    	on SMS_G_System_SMS_ADVANCED_CLIENT_STATE.ResourceID = SMS_R_System.ResourceId 
    	where SMS_R_System.ClientType = 1 
    	and SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Name = "CcmFramework" 
    	and (SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version < "2.50.2726.0102" 
    	or SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version in ( "2.50.2726.4","2.50.2726.5",
            "2.50.2726.18", "2.50.2726.1", "2.50.2726.16" ))
    zum dieser Abfrage zu verwenden, benötigen Sie mindestens einen erweiterten Client Computer in Ihrem Lager zum Erstellen der Datenbankklassen.
  12. Klicken Sie dreimal auf OK .

    Diese Abfrage gibt erweiterten Client Computern, die nicht diesen Hotfix installiert verfügen. Und diese Abfrage gibt Verwaltungspunkte, die auch der erweiterte Client installiert haben.
  13. Führen Sie Sms2003-rtm-kb831962-X 86-enu.exe auf dem SMS Site Server-Computer.
  14. Nachdem die Dateien kopiert werden, Klicken Sie auf Ja, erstellen Sie ein Paket und Programm jetzt und klicken Sie dann auf Weiter .
  15. Klicken Sie auf Weiter , um das Standardpaket und Programm Standardnamen übernehmen.
  16. Klicken Sie auf Ja , um ein Zurücksetzen der Website ausführen.
  17. Erweitern Sie Pakete , in der SMS-Administratorkonsole.
  18. Klicken Sie mit der rechten Maustaste auf das KB831962 - Advanced Client Hotfix -Paket, zeigen Sie auf Alle Tasks , klicken Sie auf Software verteilen und klicken Sie dann auf Weiter .
  19. Klicken Sie auf das Kontrollkästchen für die Verteilungspunkte, und klicken Sie dann auf Weiter .
  20. Klicken Sie auf Weiter , um das Programm ankündigen.
  21. Klicken Sie auf Weiter , um das Programm für die Werbung auszuwählen.
  22. Klicken Sie auf das Programm einer vorhandenen Sammlung ankündigen , und klicken Sie dann auf Durchsuchen .
  23. Klicken Sie auf die Erweiterten Clients für die 831962 -Auflistung, und klicken Sie dann auf OK .
  24. Klicken Sie zweimal auf Weiter .
  25. Klicken Sie auf das Programm nur Mitgliedern der angegebenen Sammlung ankündigen , und klicken Sie dann auf Weiter .
  26. Führen Sie den Software-Verteilungs-Assistenten.
Gehen Sie folgendermaßen vor, um eine automatische Installation dieses Hotfixes:
  1. Klicken Sie auf Start , und klicken Sie dann auf Ausführen .
  2. Geben Sie cmd ein , und klicken Sie dann auf OK .
  3. Suchen Sie den Ordner, der die Sms2003-rtm-kb831962-X 86-enu.exe-Datei enthält.
  4. Geben Sie den folgenden Befehl ein, und drücken Sie die [EINGABETASTE]:
    SMS 2003-RTM-KB831962-X 86-DEU.exe/s
Wenn Sie den erweiterten Client Teil dieser Hotfix nicht installieren können, überprüfen Sie die erweiterten Client-Protokolldateien auf dem Clientcomputer. Der erweiterte Client Protokolldateien in der $Systemroot%\System32\Ccmsetup und %Systemroot%\System32\Ccm\Logs-Ordner befinden.

wichtig Ankündigungsstatus für diesen Hotfix kann falsch gemeldet werden, wenn Sie verteilte zusätzliche Advanced Client Hotfixes verfügen. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
840864  (http://support.microsoft.com/kb/840864/ ) Nachdem Sie das SMS 2003 Advanced Client Hotfixes bereitgestellt haben, wird eine falschen Status angezeigt

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen finden die Versionsnummer der Installation von SMS 2003 finden Sie im folgenden Artikel der Microsoft Knowledge Base:
832103  (http://support.microsoft.com/kb/832103/ ) Zum Ermitteln der Versionsnummer der Systems Management Server 2003
Weitere Informationen zu SMS International Clients Packs finden Sie im folgenden Artikel der Microsoft Knowledge Base:
202941  (http://support.microsoft.com/kb/202941/ ) Systems Management Server International Client Packs
Weitere Informationen zu Standardterminologie zum Beschreiben von Softwareupdates verwendet finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Systems Management Server 2003 Enterprise Edition
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kbmt kbautohotfix kbqfe kbhotfixserver kbnetwork kbsmstopazfix kblogin kbuser kbperformance kbremoting kbfix kbbug KB831962 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 831962  (http://support.microsoft.com/kb/831962/en-us/ )
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