Artigo: 831962 - Última revisão: terça-feira, 24 de Julho de 2007 - Revisão: 8.8

Uma sessão de ambiente de trabalho poderão um longo atraso quando tenta terminar um computador cliente avançado

Está disponível transferência de hotfixDisponível transferência de hotfix
Ver e solicitar transferências de hotfix
Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Depois de instalar o software de cliente avançado do Microsoft Systems Management Server (SMS) 2003 num computador com o Terminal Server, poderá demorar alguns minutos terminar uma sessão dos serviços de terminal no computador cliente avançado. Além disso, as alterações ao seu perfil não podem ser guardadas.

Causa

Este problema poderá ocorrer se outro utilizador tentar iniciar sessão a uma sessão de servidor de terminais enquanto está a tentar terminar uma sessão do servidor de terminais. Neste cenário, as notificações de fim de sessão são concluídas síncrona. Por exemplo, se o utilizador A tentar terminar uma sessão quando o utilizador B tenta iniciar uma sessão nova, a fim de sessão é bloqueado até que o início de sessão esteja concluído. O início de sessão pode ser atrasado para processar scripts de início de sessão.

Além disso, o problema poderá ocorrer se as seguintes condições são verdadeiras:
  • Os utilizadores não tem sessão iniciados na consola local do computador cliente avançado.
  • Um utilizador tenta iniciar uma sessão dos serviços de terminal no computador cliente avançado.

    Nota Esta condição não é necessário que os utilizadores ser um utilizador específico. Qualquer utilizador que iniciar sessão através de sessões de serviços de terminal irá detectar este problema desde que ninguém tem sessão iniciada consola local.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Quando instalar esta correcção, os serviços de site SMS parar e reiniciar e a correcção inicia uma reposição de site SMS.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário na ferramenta Data e hora no painel de controlo.
   Date         Time   Version             Size  File name
   ------------------------------------------------------------------------------
   26-Nov-2003  16:04                 6,448,128  Mp.msi  
   27-Nov-2003  00:32  2.50.2726.102  5,422,128  Sms2003-rtm-kb831962-x86-enu.exe  
   25-Dec-2003  07:10                    11,304  Filemap.ini
   25-Dec-2003  07:10  2.0.6.3          354,152  Smsupdate.exe    
   25-Dec-2003  07:10  2.50.2726.102    541,696  Ccmexec.exe      
   25-Dec-2003  07:10  2000.80.194.0    274,489  Ntwdblib.dll     
   25-Dec-2003  07:10  2.0.1493.5011    855,312  Preinst.exe      
   25-Dec-2003  07:10                   369,152  Sms2003ac-kb831962-x86.msp

Informações de instalação

Esta correcção actualiza o Gestor de configuração cliente (CCM) componente Framework versão 2.50.2726.0102. Esta correcção contém uma actualização de cliente avançado e uma actualização de estrutura de ponto de gestão. Tem de actualizar todos os pontos de gestão com a nova estrutura de trabalho. Como parte da instalação, esta correcção efectua um site repor para actualizar automaticamente todos os pontos de gestão na hierarquia do SMS. Se adiar o reinício de site SMS, tem de efectuar manualmente uma reposição do site ou remover e, em seguida, adicione os pontos gestão. Tem de reiniciar cada site onde aplicar esta correcção. Para aplicar a correcção silenciosamente, utilize o parâmetro /s na linha de comandos.

Tem de aplicar esta correcção em sites primários e secundários. Devido a nova arquitectura no SMS 2003, tem de criar um novo pacote e um novo programa para anunciar esta correcção nos computadores cliente avançado. Como parte do programa de configuração, esta correcção pode criar o pacote e anúncio automaticamente. A Microsoft recomenda que deixe o programa de configuração criar o pacote e o anúncio para a.

Para instalar esta correcção, siga estes passos:
  1. Transfira o ficheiro de correcção e, em seguida, execute o ficheiro executável extracção automática para criar o Sms2003 rtm-kb831962 ficheiro-x 86-ptg.exe.
  2. Copie Sms2003-rtm-kb831962-x 86-ptg.exe para uma pasta no computador de servidor do site principal ou secundário SMS.
  3. Clique em Iniciar , aponte para Todos os programas , aponte para o Systems Management Server e clique em Consola de administrador SMS .
  4. Expanda base de dados locais .
  5. Clique com o botão direito do rato em colecções , aponte para Novo e, em seguida, clique em colecção .
  6. Na caixa nome , escreva:
    clientes para 831962 avançadas
  7. Clique em Propriedades de regras consulta botão.
  8. Na caixa nome , escreva:
    clientes para 831962 avançadas
  9. Clique em Editar consulta declaração .
  10. No separador Geral , faça clique sobre o Mostrar linguagem de consulta botão.
  11. Cole ou escreva a seguinte consulta na caixa consultar a declaração : seleccione
    select * from SMS_R_System 
    	inner join SMS_G_System_SMS_ADVANCED_CLIENT_STATE 
    	on SMS_G_System_SMS_ADVANCED_CLIENT_STATE.ResourceID = SMS_R_System.ResourceId 
    	where SMS_R_System.ClientType = 1 
    	and SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Name = "CcmFramework" 
    	and (SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version < "2.50.2726.0102" 
    	or SMS_G_System_SMS_ADVANCED_CLIENT_STATE.Version in ( "2.50.2726.4","2.50.2726.5",
            "2.50.2726.18", "2.50.2726.1", "2.50.2726.16" ))
    para utilizar esta consulta, tem de ter, pelo menos, um cliente avançado computador no inventário para criar as classes de base de dados.
  12. Clique três vezes em OK .

    Esta consulta identifica computadores dos cliente avançado esta correcção instalada. E esta consulta identifica os pontos de gestão que também tenham o cliente avançado instalado.
  13. Execute Sms2003-rtm-kb831962-x 86-ptg.exe no computador de servidor de site SMS.
  14. Depois de copiados os ficheiros, clique em Sim, pretendo criar um pacote e programa agora e, em seguida, clique em seguinte .
  15. Clique em seguinte para aceitar o pacote predefinido e o nome do programa predefinido.
  16. Clique em Sim para efectuar uma reposição do site.
  17. Na consola de administrador SMS, expanda pacotes .
  18. Clique com o botão direito do rato no pacote KB831962 - correcção de cliente avançado , aponte para Todas as tarefas , clique em Distribuir Software e, em seguida, clique em seguinte .
  19. Clique para seleccionar a caixa de verificação para os pontos de distribuição e, em seguida, clique em seguinte .
  20. Clique em seguinte para anunciar o programa.
  21. Clique em seguinte para seleccionar o programa para o anúncio.
  22. Faça clique sobre o anúncio este programa para uma colecção existente e, em seguida, clique em Procurar .
  23. Clique em Avançadas clientes para 831962 colecção e, em seguida, clique em OK .
  24. Clique em seguinte duas vezes.
  25. Faça clique sobre o programa apenas os membros da colecção especificada do anúncio e, em seguida, clique em seguinte .
  26. Conclua o Assistente de distribuição de software.
Para efectuar uma instalação silenciosa desta correcção, siga estes passos:
  1. Clique em Iniciar e, em seguida, clique em Executar .
  2. Escreva cmd e, em seguida, clique em OK .
  3. Localize a pasta que contém o Sms2003 rtm-kb831962 ficheiro-x 86-ptg.exe.
  4. Escreva o seguinte comando e, em seguida, prima ENTER:
    sms2003-RTM-KB831962-X 86-ptg.exe /s
Se não conseguir instalar a parte de cliente avançado esta correcção, visualizar os ficheiros de registo de cliente avançado no computador cliente. O cliente avançado ficheiros de registo estão a ser o $Systemroot%\System32\Ccmsetup e as pastas %Systemroot%\System32\Ccm\Logs.

importante Anúncio de estado para esta correcção poderão ser comunicado incorrectamente se tiver o cliente avançadas adicionais distribuídas correcções. Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
840864  (http://support.microsoft.com/kb/840864/ ) Recebe uma mensagem estado incorrecto depois de implementar as correcções de cliente do SMS 2003 avançadas

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre como localizar o número da instalação do SMS 2003 versão, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
832103  (http://support.microsoft.com/kb/832103/ ) Como determinar o número da versão do Systems Management Server 2003
Para obter mais informações sobre pacotes de clientes do SMS internacional, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
202941  (http://support.microsoft.com/kb/202941/ ) Sistemas de gestão Server internacional Client Packs
Para obter mais informações sobre a terminologia padrão utilizada para descrever actualizações de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Microsoft Systems Management Server 2003 Enterprise Edition
Palavras-chave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbnetwork kbsmstopazfix kblogin kbuser kbperformance kbremoting kbfix kbbug KB831962 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 831962  (http://support.microsoft.com/kb/831962/en-us/ )