Description de la table de Windows Installer PublishComponent pour Visio 2007 et Visio 2003

Traductions disponibles Traductions disponibles
Numéro d'article: 832029 - Voir les produits auxquels s'applique cet article

Annexe

Liste des valeurs Enable-conditions communes de la charge de manière statique les modules complémentaires

Voici une liste de certaines valeurs enable-conditions courantes des modules statiquement activé :
Needs document			1
Needs window			3
Needs drawing window		7
Needs page window		135
Needs master window		263
Needs stencil window		11
Needs ShapeSheet window		19
Needs icon window		35
Needs target			65
Needs page target		193
Needs master target		321
Needs selection target		577
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article décrit la table de Microsoft Windows Installer PublishComponent et contient des informations sur la façon dont les développeurs tiers peuvent utiliser cette table PublishComponent dans un fichier Microsoft Installer (.msi) pour publier contenu (modèles, gabarits, modules complémentaires et fichiers d'aide) dans Microsoft Office Visio 2007 et Microsoft Office Visio 2003.

Il existe deux méthodes que vous pouvez utiliser pour publier du contenu à Visio. Dans les versions de Microsoft Visio antérieures à Visio, Visio découvre contenu installé en recherchant un ensemble spécifique de chemins d'accès du dossier. Dans Visio, Visio fournit une nouvelle méthode qui peut être intégrée dans les programmes configuration installer Visio contenu. Configurer les programmes qui sont créés par des développeurs tiers qui utilisent Windows Installer technologie pouvez publier des descriptions de leur contenu Visio à un emplacement spécial sur ordinateur d'un utilisateur en utilisant le PublishComponent installer Windows table dans les fichiers .msi. Cette nouvelle méthode est un peu plus complexe. Toutefois, il est plus puissante. Tout contenu qui est natif dans Visio est publié par utiliser la méthode composant publié.

La méthode de découverte chemin d'accès qui est utilisée par les versions de Visio antérieures à Visio, est prise en charge dans Visio. Toutefois, car aucun contenu du programme Visio réel n'est publié à l'aide de cette méthode, par défaut, les chemins des modèles, gabarits, modules complémentaires, modules complémentaires de démarrage et fichiers d'aide sont vides. Vous pouvez définir ces chemins d'accès de votre contenu lorsque vous spécifiez une liste délimitée par des points-virgules, présentant la liste du contenu qui vous souhaitez que Visio à découvrir. Assurez-vous que vous ne modifiez pas les chemins d'accès fichier point au contenu est natif dans Visio. .

Pour afficher et modifier la table PublishComponent dans un fichier .msi, utilisez un outil de modification de la table comme l'éditeur de base de données Orca. Orca est inclus dans le logiciel d'installer Windows Kit de développement (SDK). Pour obtenir de l'éditeur de base de données Orca, vous devez installer le Kit de développement logiciel (SDK) l'et le Kit de développement logiciel (SDK) Windows Installer. Pour plus d'informations pour ce faire, reportez-vous au site de Web Microsoft suivant :
http://www.microsoft.com/msdownload/platformsdk/sdkupdate/default.htm?p=/msdownload/platformsdk/sdkupdate/SDKInfo.htm
Les avantages d'utilisation du contenu publié en utilisant la table PublishedComponent par rapport au contenu est découvert chemin d'accès sont les suivants :
  • Uniquement les modules sont installés par le PublishComponent table sont considérés comme comme étant installée la case autorisation installés sous l'onglet Sources fiables de la boîte de dialogue sécurité (dans le menu Outils , pointez sur macros , puis cliquez sur sécurité ).
  • Un degré plus élevé d'intégration est disponible pour des solutions tierces. Vous pouvez utiliser modules complémentaires, les modèles gabarits que contenu ? dans la zone ? et avoir plus de contrôle de nom des éléments de menu qui accèdent de vos gabarits, modèles et compléments.
  • Augmenter les performances pour la découverte des modules complémentaires. L'énumération des composant publié sont beaucoup plus rapide que découverte du contenu en recherchant des dossiers sur le disque dur, en particulier via un réseau.
  • Fonctionnalité de changement de langue plus robuste.
  • Prise en automne-back charge linguistique pour solutions localisées.
  • Prise en charge des configurations exécuter-depuis-la-source et la installés localement dans contenu dans le même produit.
  • Une solution de nettoyage pour le Web télécharge à Plug-in de l'interface Visio.

Notification ayant publié le contenu modifié

Un fichier .msi qui publie contenu Visio devez indiquer à Visio que le contenu modifié après que le programme tiers est installé ou supprimé. En procédant ainsi, le programme d'installation assure que le nouveau contenu apparaît dans l'interface lorsque le programme est installé et est supprimé à partir de l'interface lorsque le programme est supprimé. Pour des raisons de performances, Visio met en cache les données PublishComponent. Visio ne pas régénérer le cache, sauf si elle est a été demandé pour ce faire, ou que le cache n'est pas présent.

Pour demander à Visio pour régénérer son cache, les programmes d'installation doivent modifier la valeur actuelle de Visio contenu elle
REG_DWORD
valeur de Registre
ConfigChangeID
, à une valeur aléatoire, non zéro :
  • HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Visio
note Chaque fois que le programme d'installation fait installée contenu Visio en soit l'installation ou en supprimant les modèles, gabarits, modules complémentaires ou fichiers d'aide, la valeur de Registre doit être modifiée pour utiliser une autre valeur non nulle.

Localisation des composants de publication

Pour publier des versions localisées des composants, l'ID de paramètres régionaux dans le champ Description doit correspondre à la langue cible. En outre, les données affichées dans l'interface Visio peuvent également exiger de localisation.

Dans Visio 2003, vous ne devez pas localiser des noms de fichier, car tous les fichiers sont affichés dans l'interface avec un nom qui est extraites à partir du champ AppData .

Référence de table Visio PublishComponent

Windows Installer PublishComponent table

Réduire ce tableauAgrandir ce tableau
ColonneTypeCléNullablesInformations pour la publication de contenu de Visio
ComponentIDGUIDOuiNonUn des ID prédéfinis qui correspondent à la type de contenu Visio (modèle, gabarit, module complémentaire ou fichier d'aide) qui est publié.
QualificateurTexteOuiNonNom de paramètres régionaux et de fichier du composant.
ComposantIdentificateurOuiNonClé externe à la table composant.
AppDataTexte--OuiLes données qui décrit la manière dont un composant est publié.
FonctionIdentificateur--NonClé externe à la fonction table.


note Des données spécifiques à Visio dans la description et les colonnes AppData , le caractère de canal (« | ») utilisé pour délimiter les sub-fields. Le caractère barre oblique inverse (« \) peut être utilisé comme un caractère d'échappement littéral. Pour insérer un caractère de canal dans les données comme un caractère non délimitant, insérer un caractère barre oblique inverse avant ce caractère canal--par exemple, utiliser ? \| ?. Pour insérer un caractère barre oblique inverse, utilisez les barres obliques inverses consécutifs--par exemple, utilisez ? \\ ?).

Publier des modèles Visio et gabarits

Modèles publiés (fichiers .vst et .vtx) apparaissent dans les emplacements suivants dans Visio :
  • Dans le menu sous-menu qui apparaît lorsque vous pointez sur Nouveau dans le menu Fichier .
  • Dans le volet Choisir un type de dessin
  • Dans l'automatisation. Utilisez des références aux modèles publiés à installer à la demande ou une réparation modèles si nécessaire. Documents.Add (? Shapes.vst base ?) est un exemple d'une référence à un modèle publié.
Gabarits publiés (fichiers .vss et .vsx) s'affichent dans les emplacements suivants dans Visio :
  • Dans le sous-menu qui apparaît lorsque vous pointez sur formes dans le menu Fichier .
  • Dans l'automatisation. Utilisez des références à gabarits publiés à installer à la demande ou une réparation gabarits que nécessaire. Documents.Add(?Backgrounds.vss?) est un exemple d'une référence à un gabarit publié.

Valeurs de colonne dans la table PublishComponent

Réduire ce tableauAgrandir ce tableau
ColonneValeurExemple
ID de composantContent-TypePour les modèles: {026E1DF38100 CF1F488D-8D6F 499 C - A78D -}
Les gabarits: {026E1DF38101 CF1F488D-8D6F 499 C - A78D -}
QualificateurLocale-ID \ FileName1033\flowchart.vst

note Vous ne pouvez pas utiliser multiples du même nom de fichier dans un environnement de Visio. ID\ aux paramètres régionaux FileName doit être unique afin que Visio peut reconnaître qu'il. Par conséquent, utiliser un nom de fichier unique dans un environnement de Visio.
AppDataMenu-Path | Alt-NamesFlowchart\Work flux Shapes.vss;workflow.vss de diagramme de flux de tâches Shapes|Work

Description des valeurs dans la table PublishComponent

Réduire ce tableauAgrandir ce tableau
ValeurDescriptionExemple
ComponentIDValeur prédéfinie du type de contenu.
Pour les modèles: {026E1DF38100 CF1F488D-8D6F 499 C - A78D -}
Les gabarits: {026E1DF38101 CF1F488D-8D6F 499 C - A78D -}
Pour les modèles: {026E1DF38100 CF1F488D-8D6F 499 C - A78D -}
Les gabarits: {026E1DF38101 CF1F488D-8D6F 499 C - A78D -}
ID de paramètres régionauxID de paramètres régionaux décimal du composant. Les valeurs courantes incluent les suivantes :
Chinese (Traditional)	1028
German		        1031
English (U.S.) 	        1033
French			1036
Japanese		1041
Korean			1042	
Chinese (Simplified)	2052
1033
FileNameLe nom du fichier (sans le chemin d'accès) du modèle ou gabarit.Flowchart.vst
Chemin d'accès de menuPour les modèles, le menu-chemin d'accès spécifie où le modèle s'affiche dans l'arborescence de menu modèles et dans le volet Choisir un type de dessin . Les gabarits, le menu-chemin d'accès spécifie où le gabarit est affiché dans l'arborescence de menu gabarits.
Si cette valeur est une chaîne vide, le modèle ou le gabarit ne s'affiche dans les menus pas.
Si un caractère de soulignement (_) provient avant n'importe quel nom dans le chemin d'accès de menu, le modèle ne s'affiche pas dans les menus.

La dernière partie du menu chemin d'accès est également utilisée dans le nom de fichier dans l'interface utilisateur de Visio. Pour les modèles, le nom de fichier s'affiche dans la liste des modèles plus récemment utilisés. Les gabarits, le nom de fichier est affiché dans la barre de titre du gabarit.
Formes de diagramme de flux Flowchart\Work.
Remplacement des nomsUne liste délimitée par des points-virgules, présentant la liste de noms autres pour le fichier. Si cette valeur est spécifiée, la valeur remplace tout autre nom qui est stockés dans le fichier par la propriété AlternateNames de l'objet document.Diagramme de flux de travaux Shapes.vss;workflow.vss

Publier les modules complémentaires

Modules complémentaires publiés qui sont implémentés dans les fichiers .vsl et .exe apparaissent dans les emplacements suivants dans Visio :
  • Dans le sous-menu ce menu que s'affiche lorsque vous pointez sur modules complémentaires dans le menu Outils , puis cliquez sur Exécuter les modules complémentaires , ou lorsque vous cliquez sur le module complémentaire à partir du sous-menu les modules complémentaires .
  • Sous l'onglet Action du double-clic de la boîte de dialogue pour une forme comportement (sélectionnez une forme, puis cliquez dans le menu Format , sur comportement ).
  • Dans feuille ShapeSheet une forme.
  • Dans l'automatisation.

Valeurs de colonne dans la table PublishComponent

Réduire ce tableauAgrandir ce tableau
ColonneValeurExemple
ID de composantContent-Type{026E1DF38103 CF1F488D-8D6F 499 C - A78D -}
QualificateurLocale-ID \ Number \ FileName1033\0\add-on.vsl
AppDataMenu-Path | Localized-Name | Universal-Name | Ordinal | Attrs | Enable-Rule | Invoke-OnVisio Extras\ & Assistant bases de données... |Database Wizard|DBWiz|1|1|65535|0

Description des valeurs dans la table PublishComponent



Réduire ce tableauAgrandir ce tableau
ValeurDescriptionExemple
ComponentIDValeur prédéfinie du type de contenu. Pour les modules complémentaires :
{026E1DF38103 CF1F488D-8D6F 499 c - A78D -}
{026E1DF38103 CF1F488D-8D6F 499 C - A78D -}
ID de paramètres régionauxID de paramètres régionaux décimal du composant. Les valeurs courantes incluent les suivantes :
Chinese (Traditional)	1028
German		        1031
English (U.S.) 	        1033
French			1036
Japanese		1041
Korean			1042	
Chinese (Simplified)	2052
1033
NombreVous devez utiliser nombres consécutifs, à partir de 0 (zéro), à nombre de modules complémentaires qui est implémenté dans un seul fichier de bibliothèque Visio (.vsl). Toutefois, vous ne devez pas faire dans un ordre particulier. Pour chaque fichier .vsl, il doit y avoir au moins un module complémentaire publié avec son nombre défini sur 0 (zéro). Pour les modules complémentaires ont une extension .exe, la valeur nombre doit être définie à ? 0?, car il peut être uniquement un module complémentaire dans un fichier .exe unique.0
FileNameLe nom du fichier (sans le chemin d'accès) du module complémentaire. ajouter-on.vsl
Chemin d'accès de menuLe menu-chemin d'accès décrit où le module complémentaire est affiché dans l'arborescence de menu des modules complémentaires.

Si cette valeur est une chaîne vide, le module complémentaire ne s'affiche pas dans les menus.
Si un trait de soulignement (_) provient avant n'importe quel nom dans le chemin d'accès de menu, le module complémentaire ne s'affiche pas dans les menus.
Visio Extras\ & Assistant bases de données...
-Nom localiséLe nom localisé du module complémentaire. Ce nom apparaît dans les emplacements de l'interface de Visio qui répertorie les modules complémentaires.Assistant de base de données
Nom d'universelNom non localisée du module complémentaire. Ce nom ne figure pas dans l'interface Visio mais peut apparaissent dans la feuille ShapeSheet utilisé avec les fonctions RUNADDON() et RUNADDONWARGS, la feuille ShapeSheet. Ce nom est utilisé pour appeler un module complémentaire à partir de code. Modules complémentaires exécutables doivent être publiés pour utiliser ce champ car ils ne peuvent pas être interrogés au moment de l'exécution.DBWiz
OrdinalBasée sur 1 position ordinale d'un module complémentaire dans un fichier .vsl ou .exe.


Les modules complémentaires dans un fichier de bibliothèque Visio (.vsl), cette valeur doit correspondre à la valeur qui est renvoyée par le module complémentaire de réponse au message suivant :
V2LMSG_ENUMADDONS


Pour les modules complémentaires exécutables, cette valeur est toujours définie à 1.
1
Attrs Cette valeur définit les attributs du module complémentaire. Il est une représentation décimale d'un masque binaire qui décrit les attributs du module complémentaire. Cette valeur est une valeur ou au niveau du bit d'une ou plusieurs des constantes suivantes sont définies dans le VAO.h Kit de développement Platform SDK de Visio :
Performs actions			1
Has an About dialog box			2
Provides help				4
Display the wait cursor when running	8
Do not display add-on in the interface	16
Modules complémentaires exécutables doivent être publiés pour prendre en charge attributs car ils ne peuvent pas être interrogés au moment de l'exécution.

Les modules complémentaires qui sont implémentées dans un fichier .vsl, cette valeur remplace la valeur spécifiée dans le module complémentaire.
1
Enable-règlesCette valeur indique la règle Activation du module complémentaire. La valeur de la règle permettent de doit être une valeur décimale. En règle générale, il peut être plus facile à tout d'abord déterminer la valeur hexadécimale équivalente de la règle d'activer et ensuite convertir la valeur hexadécimale en valeur décimale avant d'ajouter il à la table PublishComponent.

Un module complémentaire peut être toujours activé. Si un module complémentaire est toujours activé, la règle activer est 65 535. Ceci est la règle d'activer par défaut pour un module complémentaire exécutable. La valeur hexadécimale équivalente de 65 535 est 0xffff.

Un module complémentaire qui est implémenté dans un fichier de bibliothèque Visio (.vsl) peut être activé dynamiquement. Si un module complémentaire est activé dynamiquement, Visio interroge le module complémentaire pour déterminer son état activer. Car cette requête est exécutée chaque fois que le module complémentaire est appelé, activé dynamiquement les modules complémentaires peuvent entraîner baisse de performances. Microsoft ne recommande pas utilisant dynamiquement activé modules complémentaires, sauf si vous avez besoin. La règle d'activer des activé dynamiquement les modules complémentaires est 0. Modules complémentaires exécutables ne peut être activé dynamiquement.

Modules complémentaires peuvent être également activés conditionnelle. Modules activé de façon conditionnelle dispose de certaines conditions activer qui doivent être remplies et qui sont tout d'abord vérifié par Visio avant que le module complémentaire est activé. Par exemple, un module complémentaire peut nécessiter que la fenêtre active est une fenêtre de dessin. Modules complémentaires qui sont activées en fonction complètement des conditions d'activer sont souvent appelés « statiquement-activé » modules complémentaires. Dans les versions de Visio antérieures à Visio, uniquement modules complémentaires qui sont implémentées dans un fichier .vsl peuvent être statiquement activé. Dans Visio, modules complémentaires exécutables qui sont publiés l'aide de la table PublishedComponent peuvent être activée de manière statique. Pour statiquement activée de modules complémentaires, la règle activer doit être une combinaison ou au niveau du bit des indicateurs de bas niveau enable-condition suivants :
                                                      Decimal Hexadecimal
--------------------------------------------------------------------------
Document is active (required for all enable-rules) 	1 	0x0001
Window is active (required for all window types) 	2 	0x0002
Active window is a drawing window 			4  	0x0004
Active window is a stencil window 			8  	0x0008
Active window is a ShapeSheet window 			16 	0x0010
Active window is an icon window 			32 	0x0020
Command target active (required for all target types) 	64 	0x0040 
Command target is a page 				128  	0x0080
Command target is a master 				256  	0x0100
Selection                                               512     0x0200
note Pour obtenir une liste de certains commun activer valeurs conditions de modules complémentaires statiquement activées, consultez la section « Annexe » plus loin dans cet article.

Visio prend également en charge les modules complémentaires qui sont partiellement dynamique activés. Ces modules complémentaires sont appelés « statiquement-puis-dynamiquement-activé » modules complémentaires. Visio interroge le module complémentaire pour son état d'activation lorsque ses conditions activer statiques sont remplies. Cette combinaison de l'activation statiques et dynamiques n'affecte pas performances autant qu'activé dynamiquement les modules complémentaires. Toutefois, cette combinaison peut entraîner des diminutions de performances. Uniquement les modules sont implémentés dans des fichiers .vsl peuvent être activées de manière statique puis-dynamiquement. La règle d'activer des modules de manière statique puis-dynamiquement-activé doit être une combinaison ou au niveau du bit des indicateurs qui sont répertoriées plus haut dans cet article et la valeur étendue dynamiques de 32768. La valeur hexadécimale équivalente de 32768 est 0 x 8000).
Pour spécifier que le module complémentaire est activé que si une fenêtre de dessin est active, définie la règle Activer sur une valeur de 7 (0 + 1 + 2 + 4).

Pour spécifier que Visio interroge le module complémentaire de l'état activer uniquement lorsque la cible de commandes actif est une page, définie la règle permettent à la valeur 33089 (32768 + 1 + 64 + 256.
Appeler surCette valeur indique si le module complémentaire commence lorsque vous démarrez Visio. La valeur peut être définie sur 0 (zéro) ou 1 comme suit :
Do not start the add-on when Visio starts  0 
Start the add-on when  Visio starts        1
pour les modules complémentaires qui sont implémentées dans un fichier .vsl et qui sont publiés l'aide de la table PublishedComponent, cette valeur remplace l'attribut Invoke-sur qui est définie dans le module complémentaire.
1

Publier les fichiers d'aide Visio

Publié de l'aide de fichiers (.chm) apparaissent dans les emplacements suivants dans Visio :
  • Dans l'automatisation. Utiliser des références à publié fichiers d'aide à installation-par demande ou réparez les fichiers d'aide si nécessaire. Application.InvokeHelp (? myhelp.chm ?, 15, 0) est un exemple d'une référence à un fichier d'aide publié.
  • Dans l'aide de la forme. Le fichier d'aide spécifié lorsque vous cliquez sur spécial dans le menu Format , puis cliquez sur Aide est installé par la demande et réparé si nécessaire.

Valeurs de colonne dans la table PublishComponent

Réduire ce tableauAgrandir ce tableau
ColonneValeurExemple
ID de composantContent-TypePour les fichiers d'aide :
{026E1DF38102 CF1F488D-8D6F 499 C - A78D -}
QualificateurLocale-ID \ FileName1033\flowchart.vst

Description des valeurs dans la table PublishComponent

Réduire ce tableauAgrandir ce tableau
ValeurDescriptionExemple
ComponentIDValeur prédéfinie du type de contenu.
Fichiers d'aide: {026E1DF38102 CF1F488D-8D6F 499 C - A78D -}
Pour obtenir de l'aide de fichiers: {026E1DF38102 CF1F488D-8D6F 499 c - A78D -}
ID de paramètres régionauxID de paramètres régionaux décimal du composant. Les valeurs courantes incluent les suivantes :
Chinese (Traditional)	1028
German		        1031
English (U.S.) 	        1033
French			1036
Japanese		1041
Korean			1042	
Chinese (Simplified)	2052
1033
FileNameLe nom du fichier (sans le chemin d'accès) de l'aide ou réponse Assistant fichier. myhelp.chm

Références

Pour plus d'informations sur la table PublishComponent, reportez-vous au site de Web Microsoft suivant :
http://msdn2.microsoft.com/en-us/library/aa370921.aspx
Pour plus d'informations sur Visio, reportez-vous au site de Web Microsoft suivant :
http://www.microsoft.com/office/visio

Propriétés

Numéro d'article: 832029 - Dernière mise à jour: mardi 17 avril 2007 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Office Visio Standard 2003
Mots-clés : 
kbmt kbtemplate kbinfo KB832029 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 832029
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com