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Terminal Services .ini files do not synchronize as you expect in Windows Server 2003

Article ID:832048
Last Review:July 24, 2007
Revision:3.9
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SYMPTOMS

In Microsoft Windows Server 2003, .ini files for Terminal Services may not synchronize as you expect. This problem causes the GetWindowsDirectory function to return the system directory instead of the user's system directory.

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CAUSE

This problem occurs because Windows Server 2003 does not correctly propagate the global .ini file for the program that you want to use with Terminal Services to the .ini file that is located in the user's profile. For example, when you add an .ini file entry for the program that you want to use with Terminal Services to the following registry subkey, and you set the value of the entry to 0x00000004, the global .ini file is not propagated to the user's .ini file:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Terminal Server\Compatibility\IniFiles

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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Online Customer Services to obtain the hotfix. To submit an online request to obtain the hotfix, visit the following Microsoft Web site:
http://go.microsoft.com/?linkid=6294451 (http://go.microsoft.com/?linkid=6294451)
Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. To create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" section and the online request forms display the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version       Size       File name      Platform
--------------------------------------------------------------------
17-Dec-2003  01:28  5.2.3790.112    988,672  Kernel32.dll        x86
17-Dec-2003  01:28  5.2.3790.112  1,850,368  Kernel32.dll      IA-64
17-Dec-2003  01:28  5.2.3790.112    732,672  Ntdll.dll           x86
17-Dec-2003  01:28  5.2.3790.112  1,524,224  Ntdll.dll         IA-64
17-Dec-2003  01:28  5.2.3790.112    934,400  Wkernel32.dll       x86
17-Dec-2003  01:28  5.2.3790.112    711,168  Wntdll.dll          x86

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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MORE INFORMATION

For additional information about terminal server registry settings for applications, click the following article number to view the article in the Microsoft Knowledge Base:
186499 (http://support.microsoft.com/kb/186499/) Terminal Server Registry Settings for Applications
For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the Standard Terminology That Is Used to Describe Microsoft Product Updates, Tools, and Add-ons

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APPLIES TO
Microsoft Windows Server 2003, Web Edition
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise x64 Edition

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Keywords: 
kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwinserv2003presp1fix KB832048

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