Karty Smart card, přestane pracovat nebo nelze získat přístup v místním registru při upgradu ze systému Windows 2000 Server na systém Windows XP s aktualizací SP 1 nebo starší

Překlady článku Překlady článku
ID článku: 832082 - Produkty, které se vztahují k tomuto článku.
OfficeNet
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Předpokládejme situaci, kdy upgradujete počítač se systémem Microsoft Windows 2000 Service Pack 4 (SP4) nebo novější verzi systému Windows 2000 na jeden z následujících:
  • Microsoft Windows XP Professional Edition Service Pack 1 (SP1)
  • Systém Microsoft Windows XP Home Edition s aktualizací SP1
  • starší verze systému Windows XP
V tomto scénáři může objevit některý z následujících problémů:
  • Karty smart card mohou přestat fungovat.
  • Nebudete moci získat přístup k místním registru ze vzdáleného počítače.


Navíc může být v protokolu událostí aplikace zaznamenána některý z následujících událostí:

Typ události: Chyba
Zdroj události: SCardSvr
Kategorie události: žádný
ID události: 201
Datum: 9/25/2003
Čas: 1:04:08 PM
Uživatel: není k dispozici
Počítač: Název počítače
Popis: Nepodařilo se inicializovat aplikaci serveru: přístup byl odepřen.



Typ události: Chyba
Zdroj události: SCardSvr
Kategorie události: žádný
ID události: 110
Datum: 9/25/2003
Čas: 1:04:08 PM
Uživatel: není k dispozici
Počítač: Název počítače
Popis: Comm Responder se nepodařilo vytvořit komunikační objekt.



Typ události: Chyba
Zdroj události: SCardSvr
Kategorie události: žádný
ID události: 104
Datum: 9/25/2003
Čas: 1:04:08 PM
Uživatel: není k dispozici
Počítač: Název počítače
Popis: Službě Comm Responder nelze získat přístup ke klíči Calais: přístup byl odepřen.



Poznámka: K tomuto problému nedochází při upgradu počítače se systémem Windows 2000 Service Pack 3 nebo novější. Tento problém také nedochází při upgradu na systém Windows XP Service Pack 2 nebo novější verzi systému Windows XP.

Příčina

Tomuto problému dochází, protože při upgradu počítače se systémem Windows 2000 SP4 nebo novější verzi systému Windows 2000 není uplatněn šablony zabezpečení ze souboru Dwup.inf.

Karta smart card pravděpodobně nebude pracovat správně, protože místní služba nebylo uděleno oprávnění ke čtení pro následující podklíč registru:
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/kryptografie a Calais a aktuální
Přístup ke vzdálenému registru nemusí správně fungovat, protože místní služba nebylo uděleno oprávnění ke čtení pro následující podklíč registru:
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/řízení/SecurePipeServers/winreg

Řešení

Informace o aktualizaci Service pack

Tento problém vyřešíte pomocí nejnovější aktualizace service pack pro systém Microsoft Windows XP. Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
322389 Jak získat nejnovější aktualizaci service pack pro systém Windows XP

Informace o opravě hotfix

Existuje několik scénářů řešení tohoto problému.

Pokud víte o tomto problému, před upgradem na aktualizaci Windows XP SP2, Windows 2000 SP4 nebo novější verzi systému Windows 2000, můžete zadat Spdwnw2k.exe /test příkaz příkazového řádku v systému Windows 2000 SP4 nebo novější verzi systému Windows 2000. Spdwnw2k.exe je umístěn na disku CD-ROM systému Windows 2000 SP4 ve složce i386\update.

Pokud víte o tomto problému po upgradu ze systému Windows 2000 SP4 nebo novější verzi systému Windows 2000 na systém Windows XP SP1, je nutné nainstalovat tuto opravu hotfix k vyřešení tohoto problému.

Podporovaná oprava hotfix je k dispozici od společnosti Microsoft. Tato oprava hotfix je však určena pouze problém popsaný v tomto článku. Použití této opravy hotfix pouze u systémů, ve kterých dochází k tomuto konkrétnímu problému. Tato oprava hotfix může být dále testována. Proto pokud není přísně tento problém, doporučujeme počkat na další aktualizaci softwaru, která bude tuto opravu hotfix obsahovat.

Pokud je oprava hotfix je k dispozici ke stažení, je sekce "Hotfix stažení k dispozici" v horní části tohoto článku. Pokud tento oddíl není uveden, obraťte se na podporu a služby zákazníkům společnosti, jak získat opravu hotfix.

Poznámka: Pokud nastanou další problémy nebo řešení potíží je vyžadován, pravděpodobně vytvořit samostatnou žádost. Výdaje na technickou podporu se bude u dalších otázek a problémů, které nelze vyřešit určitou konkrétní opravy hotfix. Úplný seznam telefonních čísel služeb zákazníkům společnosti Microsoft a podpoře nebo vytvořit zvláštní požadavek na službu navštivte následující Web společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support
Poznámka: "Hotfix stažení k dispozici" formulář zobrazí jazyky, pro které je oprava hotfix je k dispozici. Pokud váš jazyk není uveden, je to, protože oprava hotfix není k dispozici pro daný jazyk.

Anglická verze této opravy hotfix má atributy souborů (nebo novější), jsou uvedeny v následující tabulce. Data a časy jednotlivých souborů jsou uvedeny v koordinovaný světový čas (UTC). Při zobrazení informací o souboru, je převeden na místní čas. Pomocí vyhledat rozdíl mezi místním časem a časem UTC naleznete Časové pásmo Karta v nástroji datum a čas v okně Ovládací panely.
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   31-Mar-2004  00:06  5.1.2600.1361     667,648  Lsasrv.dll       x86
   31-Mar-2004  00:06  5.1.2600.1360     171,008  Scecli.dll       x86
   31-Mar-2004  00:06  5.1.2600.1360     297,472  Scesrv.dll       x86
   10-Jan-2004  04:11  5.2.3790.32        17,408  Spupdsvc.exe     x86
   09-Mar-2004  00:23                    306,953  Xpupgfix.inf     x86
   31-Mar-2004  00:01  5.1.2600.1361   2,069,504  Lsasrv.dll       IA-64
   31-Mar-2004  00:01  5.1.2600.1360     494,080  Scecli.dll       IA-64
   31-Mar-2004  00:01  5.1.2600.1360     857,600  Scesrv.dll       IA-64
   09-Jan-2004  21:47  5.2.3790.32        30,208  Spupdsvc.exe     IA-64
   09-Mar-2004  00:24                    306,953  Xpupgfix.inf     IA-64
Pokud upgradujete na systém Windows XP SP2 po upgradu na systém Windows XP SP1 nebo po upgradu starší verze systému Windows XP a tento problém přetrvává, soubor Xpupgfix.inf, který je součástí této opravy hotfix můžete aplikovat ručně. Chcete-li extrahovat soubor Xpupgfix.inf z tohoto balíčku oprav hotfix, je nutné spustit balíček s /x přepínače příkazového řádku. Balíček, který je extrahován bude obsahovat soubor, který se nazývá WindowsXP-KB832082-x 86csy.exe nebo WindowsXP-KB832082-IA64-ENU.EXE. Extrahujte soubor s /x přepnete znovu. Na příkazovém řádku aktualizovat počítač se systémem Windows XP SP2 nebo novější verzi systému Windows XP pomocí souboru Xpupgfix.inf, zadejte následující příkaz:

% systemroot %\system32\secedit.exe / configure/cfg xpupgfix.inf způsob % systemroot %\security\Database\update.sdb

Pokud upgradujete počítač se systémem Windows 2000 SP4 nebo novější verzi systému Windows 2000 verze systému Windows XP s aktualizací SP2, žádné další kroky jsou nezbytné, protože tato oprava hotfix je naplánováno zahrnutá v aktualizaci Windows XP SP2.

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části "Platí pro". Tento problém byl poprvé opraven v aktualizaci Microsoft Windows XP Service Pack 2.

Další informace

Další informace získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
824684 Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft

Vlastnosti

ID článku: 832082 - Poslední aktualizace: 22. května 2011 - Revize: 6.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Klíčová slova: 
kbautohotfix kbHotfixServer kbqfe kbwinxpsp2fix kbupgrade kbsmartcard kbnetwork kbwinxppresp2fix kbfix kbbug kbmt KB832082 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:832082

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com