Cartão inteligente pára de funcionar ou você não pode acessar o registro local quando você atualiza do Windows 2000 Server para Windows XP SP 1 ou anterior

Traduções deste artigo Traduções deste artigo
ID do artigo: 832082 - Exibir os produtos aos quais esse artigo se aplica.
OfficeNet
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Suponha que um cenário onde você atualiza um computador que esteja executando Microsoft Windows 2000 Service Pack 4 (SP4) ou uma versão posterior do Windows 2000 para um destes procedimentos:
  • Microsoft Windows XP Professional Edition Service Pack 1 (SP1)
  • Microsoft Windows XP Home Edition SP1
  • uma versão anterior do Windows XP
Nesse cenário, um dos seguintes problemas pode ocorrer:
  • Seu cartão inteligente pode parar de funcionar.
  • Você não poderá acessar o registro local de um computador remoto.


Além disso, qualquer um dos seguintes eventos pode ser registrado no log de eventos do aplicativo:

Tipo de evento: erro
Origem do evento: SCardSvr
Categoria do evento: nenhum
IDENTIFICAÇÃO de evento: 201
Data: 25/9/2003
Tempo: 1: 04: 08 PM
Usuário: N/d
Computador: Computer Name
Descrição: Falha ao inicializar o aplicativo do servidor: acesso negado.



Tipo de evento: erro
Origem do evento: SCardSvr
Categoria do evento: nenhum
IDENTIFICAÇÃO de evento: 110
Data: 25/9/2003
Tempo: 1: 04: 08 PM
Usuário: N/d
Computador: Computer Name
Descrição: Respondedor de comunicações não pôde criar objeto de comunicação.



Tipo de evento: erro
Origem do evento: SCardSvr
Categoria do evento: nenhum
IDENTIFICAÇÃO de evento: 104
Data: 25/9/2003
Tempo: 1: 04: 08 PM
Usuário: N/d
Computador: Computer Name
Descrição: O Respondente de comunicações não pôde acessar a chave Calais: acesso negado.



Observação Esse problema não ocorre quando você atualiza um computador que está executando o Windows 2000 Service Pack 3 ou anterior. Esse problema também não ocorre quando você atualiza para Windows XP Service Pack 2 ou uma versão posterior do Windows XP.

Causa

Esse problema ocorre porque um modelo de segurança do arquivo Dwup.inf não é aplicado quando você atualiza um computador que esteja executando o Windows 2000 SP4 ou uma versão posterior do Windows 2000.

O cartão inteligente pode não funcionar corretamente porque o serviço local não é concedido a permissão Read para a seguinte subchave do Registro:
HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Cryptography/Calais/Current
Acesso remoto ao registro pode não funcionar corretamente porque o serviço local não é concedido a permissão Read para a seguinte subchave do Registro:
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/SecurePipeServers/winreg

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Microsoft Windows XP. Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
322389Como obter o service pack mais recente do Windows XP

Informações sobre o hotfix

Há vários cenários de resolução para esse problema.

Se você souber sobre esse problema antes de atualizar para o Windows XP SP2 do Windows 2000 SP4 ou uma versão posterior do Windows 2000, você pode digitar o comando Spdwnw2k.exe /test em um prompt de comando no Windows 2000 SP4 ou em uma versão posterior do Windows 2000. O arquivo Spdwnw2k.exe está localizado no CD-ROM do Windows 2000 SP4 na pasta i386\update.

Se você souber sobre esse problema após a atualização para Windows XP SP1 do Windows 2000 SP4 ou uma versão posterior do Windows 2000, você deve instalar esse hotfix para resolver esse problema.

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

A versão em inglês deste hotfix apresenta os atributos de arquivo (ou posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version            Size    File name        Platform
   ------------------------------------------------------------------------
   31-Mar-2004  00:06  5.1.2600.1361     667,648  Lsasrv.dll       x86
   31-Mar-2004  00:06  5.1.2600.1360     171,008  Scecli.dll       x86
   31-Mar-2004  00:06  5.1.2600.1360     297,472  Scesrv.dll       x86
   10-Jan-2004  04:11  5.2.3790.32        17,408  Spupdsvc.exe     x86
   09-Mar-2004  00:23                    306,953  Xpupgfix.inf     x86
   31-Mar-2004  00:01  5.1.2600.1361   2,069,504  Lsasrv.dll       IA-64
   31-Mar-2004  00:01  5.1.2600.1360     494,080  Scecli.dll       IA-64
   31-Mar-2004  00:01  5.1.2600.1360     857,600  Scesrv.dll       IA-64
   09-Jan-2004  21:47  5.2.3790.32        30,208  Spupdsvc.exe     IA-64
   09-Mar-2004  00:24                    306,953  Xpupgfix.inf     IA-64
Se você atualizar para o Windows XP SP2 após a atualização para Windows XP SP1 ou após atualizar para uma versão anterior do Windows XP e o problema ainda ocorrer, você pode aplicar manualmente o arquivo Xpupgfix.inf que está incluído nesse hotfix. Para extrair o arquivo Xpupgfix.inf neste pacote de hotfix, você deve executar o pacote com a opção/x no prompt de comando. O pacote é extraído irá conter um arquivo chamado WindowsXP-KB832082-x 86-enu.exe ou WindowsXP-KB832082-IA64-enu.exe. Extraia novamente esse arquivo com a opção/x . Em seguida, digite o seguinte comando no prompt de comando para atualizar o computador que está executando o Windows XP SP2 ou uma versão posterior do Windows XP com o arquivo Xpupgfix.inf:

%systemroot% \system32\secedit.exe /configure /cfg xpupgfix.inf /db %systemroot% \security\Database\update.sdb

Se você atualizar um computador que está executando o Windows 2000 SP4 ou uma versão posterior do Windows 2000 para uma versão corrigida do Windows XP SP2, não há etapas adicionais são necessárias, porque esse hotfix está programado para ser incluído no Windows XP SP2.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Microsoft Windows XP Service Pack 2.

Mais Informações

Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 832082 - Última revisão: quinta-feira, 17 de maio de 2007 - Revisão: 4.6
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palavras-chave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbupgrade kbsmartcard kbnetwork kbwinxppresp2fix kbfix kbbug KB832082 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 832082

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com