Help and Support
 

powered byLive Search
Hotfix Download Available

FIX: IIS 6.0 serves stale content if your Web site has both an IP address and host headers set

Article ID:832139
Last Review:December 3, 2007
Revision:2.7
On This Page

SYMPTOMS

In Microsoft Internet Information Services 6.0, if your Web site is configured for both an IP address and host headers, any change that you make to the static content does not appear immediately.

Back to the top

CAUSE

This problem occurs because of the way that the content is stored in the Http.sys cache.

Back to the top

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 (http://support.microsoft.com/kb/889100/) How to obtain the latest service pack for Windows Server 2003

Back to the top

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Restart requirement

You must restart your computer after you apply this hotfix

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size     File name
   ------------------------------------------------------
   10-Dec-2003  00:37  5.2.3790.110  334,336  Http.sys
   10-Dec-2003  01:18  5.2.3790.110   27,648  Httpapi.dll
   10-Dec-2003  01:18  6.0.3790.110  338,432  W3core.dll
Note If you are also experiencing the symptoms that Microsoft Knowledge Base article 832911 describes, apply this hotfix before you apply hotfix 832911.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
832911 (http://support.microsoft.com/kb/832911/) 401.3 during NTLM 3 way handshake with webgardens enabled

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 1.

Back to the top

MORE INFORMATION

When you store a cache entry in the Http.sys cache, the Http.sys cache uses a "host header + IP address" token. However, the Http.sys cache does not return a "host header + IP address" token in the parsed (also known as cooked) URL of a request. Therefore, when you try to flush a cache entry by using the parsed URL of a request, the flush does not succeed.

Back to the top


APPLIES TO
Microsoft Internet Information Services 6.0

Back to the top

Keywords: 
kbautohotfix kbhotfixserver kbqfe kbhotfixserver kbqfe kbfix kbbug kbqfe kbwinserv2003presp1fix KB832139

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.