Impossibile stampare dopo avere installato un service pack, un aggiornamento cumulativo o un hotfix della stampante in un server che esegue Windows 2000 o Windows Server 2003

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Importante In questo articolo sono contenute informazioni su come modificare il Registro di sistema. Assicurarsi di eseguire il backup del Registro di sistema prima di modificarlo e di sapere come ripristinare il Registro di sistema qualora si verifichino dei problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Descrizione del Registro di sistema di Microsoft Windows
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Sintomi

Dopo avere installato Microsoft Windows 2000 Service Pack 2 (SP2), un service pack di Windows Server 2003, un aggiornamento cumulativo o un hotfix per l'aggiornamento del file Unidrvui.dll, è possibile che si verifichino entrambi i sintomi seguenti:
  • Quando viene effettuato un tentativo di stampa da un client o da un server, il servizio Spooler di stampa non risponde o sembra bloccato e viene visualizzato un messaggio di errore analogo al seguente:
    Impossibile creare il processo di stampa.
  • Quando si tenta di stampare una pagina di prova dalla console del server, viene visualizzato il messaggio di errore seguente:
    La stampa della pagina di prova non è riuscita.

Cause

Il problema può verificarsi se il service pack o il pacchetto hotfix viene installato in un server con numerosi driver della stampante PCL basati su Unidrv.

Quando si installa un service pack o un file di hotfix che aggiorna Unidrvui.dll in un server con numerosi driver della stampante PCL basati su Unidrv, è possibile che il server impieghi molto tempo (fino a 2 ore) per rigenerare i file binari di descrizione delle stampanti analizzati (file bud) utilizzati per migliorare l'efficienza dello spooler per questi driver. Durante questo intervallo lo spooler di stampa non è in grado di ricevere i processi di stampa in arrivo e potrebbe restituire ai client messaggi nei quali è indicato che la coda di stampa è piena. Questa operazione di analisi si verifica una sola volta e non viene ripetuta dopo la rigenerazione dei file bud binari analizzati.

I file bud binari generati dai file GPD (Generic Printer Description) devono essere rigenerati perché la versione del file parser GPD è stata modificata. Dopo aver analizzato tutti i driver PCL basati su Unidrv, lo spooler potrà ricevere nuovamente i processi di stampa. Per questo motivo Microsoft consiglia di pianificare le installazioni di service pack e hotfix nei server con molti driver della stampante PCL basati su Unidrv tenendo conto delle due ore che potrebbero essere necessarie per la compilazione del file bud.

Risoluzione

Per risolvere questo problema, pianificare un tempo sufficiente per il completamento dell'analisi di tutti i driver della stampante basati su Unidrv per ogni file di driver aggiornato, quindi pianificare un tempo sufficiente per ogni stampante che utilizza questi file.

Workaround

Avviso L'errato utilizzo dell'editor del Registro di sistema può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. L'utilizzo dell'editor del Registro di sistema è a rischio e pericolo dell'utente.

Se non è possibile attendere il completamento dell'analisi di tutti i driver della stampante basati su Unidrv, rimuovere manualmente tutti file binari di descrizione delle stampanti (file bud) memorizzati nella cache, quindi attendere che vengano ricreati automaticamente. È possibile che questa ricreazione automatica risulti più rapida, a seconda della velocità del server. In genere questa operazione viene completata in 30 minuti.

Nota All'avvio dello Spooler di stampa viene installata una versione più recente del file Unidrv.dll. I file bud non saranno pertanto aggiornati. I file bud costituiscono la versione compilata dei file ppd e possono essere rigenerati completamente a partire da tali file ppd, quindi i file bud possono essere rimossi. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Interrompere il servizio Spooler di stampa. Per effettuare questa operazione, al prompt dei comandi digitare quanto segue:
    net stop spooler
  2. Cercare tutti i file bud, quindi assicurarsi che siano contrassegnati dalla data e dall'ora correnti, ovvero la data odierna.
  3. Rimuovere tutti i file bud con attributi di data e ora precedenti rispetto alla data odierna. Questi file si trovano nella seguente cartella:
    %SYSTEMROOT%\System32\Spool\Drivers\w32x86\3
  4. Rimuovere la seguente chiave del Registro di sistema se esistente:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\PostSPUpgrade
    Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella Apri, quindi scegliere OK.
    2. Individuare e selezionare la seguente sottochiave del Registro di sistema:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
    3. Scegliere Esporta file del Registro di sistema dal menu Registro di sistema.
    4. Nella casella Nome file digitare printkey, quindi fare clic su Salva.

      Nota Per ripristinare la chiave del Registro di sistema
      Print
      in un secondo momento, è possibile fare doppio clic sul file Printkey.reg salvato.
    5. Individuare e selezionare la seguente sottochiave del Registro di sistema, se esistente:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\PostSPUpgrade
    6. Scegliere Elimina dal menu Modifica, quindi scegliere per confermare l'eliminazione della chiave del Registro di sistema
      PostSPUpgrade
      .

      Nota È possibile che la chiave del Registro di sistema
      PostSPUpgrade
      sia nuovamente presente al riavvio del computer. Il problema si verifica se esistono altri file bud non ancora analizzati. Dopo avere analizzato questi file, la chiave del Registro di sistema verrà rimossa automaticamente.
  5. Riavviare il server.
La funzionalità di stampa sarà disponibile circa 30 minuti dopo il riavvio del server.

Proprietà

Identificativo articolo: 832219 - Ultima modifica: martedì 11 dicembre 2007 - Revisione: 5.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
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