Windows 2000 또는 Windows Server 2003에서 서비스 팩, 업데이트 롤업 또는 프린터 핫픽스를 서버에 설치한 후에 인쇄할 수 없다

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256986 Microsoft Windows 레지스트리 설명
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현상

Microsoft Windows 2000 서비스 팩 2(SP2), Windows Server 2003 서비스 팩, 업데이트 롤업 또는 Unidrvui.dll 파일을 업데이트하는 핫픽스를 설치한 후에 다음과 같은 현상이 모두 나타날 수 있습니다.
  • 클라이언트나 서버가 인쇄를 시도하면 인쇄 스풀러 서비스가 응답하지 않고 다음과 같은 오류 메시지가 나타납니다.
    인쇄 작업을 만들 수 없습니다.
  • 서버 콘솔에서 테스트 페이지를 인쇄하려고 하면 다음과 같은 오류 메시지가 나타날 수 있습니다.
    테스트 페이지를 인쇄하지 못했습니다.

원인

이 문제는 여러 Unidrv 기반 PCL(Printer Control Language) 프린터 드라이버가 있는 서버에 서비스 팩이나 핫픽스 패키지를 설치하는 경우 발생할 수 있습니다.

여러 Unidrv 기반 PCL 프린터 드라이버가 있는 서버에 Unidrvui.dll을 업데이트하는 서비스 팩이나 핫픽스 파일을 설치하면 서버가 이러한 드라이버에 대한 스풀러 효율을 증가시키는 데 사용되는 구문 분석된 이진 프린터 설명 파일(.bud 파일)을 다시 생성하는 데 오랜 시간(최대 2시간)이 걸릴 수 있습니다. 이 시간 동안 인쇄 스풀러는 들어오는 인쇄 작업을 받을 수 없으며 인쇄 대기열이 가득 찼다는 메시지를 클라이언트에 반환할 수 있습니다. 이는 일회성 구문 분석 작업이며 구문 분석된 이진 .bud 파일을 성공적으로 다시 생성한 후에는 발생하지 않습니다.

GPD 파서 파일 버전이 변경되기 때문에 GPD(일반 프린터 설명) 파일에서 생성된 이진 .bud 파일을 다시 생성해야 합니다. 모든 Unidrv 기반 PCL 드라이버를 구문 분석한 후에 스풀러는 다시 인쇄 작업을 받을 수 있습니다. 이와 같은 이유로 최대 2시간이 걸리는 .bud 파일 컴파일을 수행할 수 있도록 여러 Unidrv 기반 PCL 프린터 드라이버가 있는 서버에 서비스 팩과 핫픽스 설치 일정을 잡는 것이 좋습니다.

해결 방법

이 문제를 해결하려면 각각의 업그레이드된 드라이버 파일에 대해 모든 Unidrv 기반 프린터 드라이버의 구문 분석을 완료하기 위한 충분한 시간을 서버에 배정하십시오.

해결 과정

경고 레지스트리 편집기를 잘못 사용하면 심각한 문제가 발생할 수 있으며 문제를 해결하기 위해 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft는 레지스트리 편집기를 잘못 사용함으로써 발생하는 문제에 대해 해결을 보증하지 않습니다. 레지스트리 편집기 사용에 따른 모든 책임은 사용자에게 있습니다.

서버에서 모든 Unidrv 기반 프린터 드라이버의 구문 분석이 완료되기를 기다릴 수 없는 경우 캐시된 모든 이진 프린터 설명 파일(.bud 파일)을 수동으로 제거한 다음 자동으로 다시 만들어지도록 합니다. 서버 속도에 따라 이진 프린터 설명 파일이 짧은 시간에 자동으로 다시 만들어질 수 있습니다. 일반적으로 이 작업은 30분 내에 완료됩니다.

참고 인쇄 스풀러가 시작되면 Unidrv.dll의 최신 버전이 설치됩니다. 따라서 .bud 파일은 날짜가 지난 것입니다. .bud 파일은 .ppd 파일의 컴파일된 버전이며 이러한 .ppd 파일에서 완벽하게 다시 생성될 수 있습니다. 따라서 .bud 파일을 제거할 수 있습니다. 이렇게 하려면 다음과 같이 하십시오.
  1. 인쇄 스풀러 서비스를 중지합니다. 서비스를 중지하려면 명령 프롬프트에서 다음 명령을 실행합니다.
    net stop spooler
  2. 모든 .bud 파일을 검색한 다음 현재 시간과 날짜로 표시되어 있는지 확인합니다. 파일은 오늘 날짜로 나타납니다.
  3. 날짜와 시간 스탬프가 오늘 이전인 모든 .bud 파일은 제거합니다. 이러한 파일은 다음 폴더에 있습니다.
    %SYSTEMROOT%\System32\Spool\Drivers\w32x86\3
  4. 아래와 같은 레지스트리 키가 있으면 제거합니다.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\PostSPUpgrade
    이렇게 하려면 다음과 같이 하십시오.
    1. 시작, 실행을 차례로 누르고 열기 상자에 regedit를 입력한 다음 확인을 누릅니다.
    2. 다음 레지스트리 하위 키를 찾아 두 번 누릅니다.
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
    3. 레지스트리 메뉴에서 레지스트리 파일 내보내기를 누릅니다.
    4. 파일 이름 상자에 printkey를 입력한 다음 저장을 누릅니다.

      참고 나중에
      Print
      레지스트리 키를 복원하려면 저장한 Printkey.reg 파일을 두 번 누르면 됩니다.
    5. 다음 레지스트리 하위 키가 있는 경우 찾아서 누릅니다.
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\PostSPUpgrade
    6. 편집 메뉴에서 삭제를 누른 다음
      PostSPUpgrade
      레지스트리 키를 삭제할 것인지 묻는 메시지가 나타나면 를 누릅니다.

      참고 컴퓨터를 다시 시작한 후에
      PostSPUpgrade
      레지스트리 키가 나타날 수 있습니다. 이 문제는 아직 구문 분석하지 않은 다른 .bud 파일이 있는 경우 발생합니다. 이러한 파일을 구문 분석하면 이 레지스트리 키가 자동으로 제거됩니다.
  5. 서버를 다시 시작합니다.
서버를 다시 시작하고 30분 후에 인쇄 기능을 사용할 수 있습니다.



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속성

기술 자료: 832219 - 마지막 검토: 2007년 12월 10일 월요일 - 수정: 5.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 서비스 팩 3
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Professional SP4
  • Microsoft Windows 2000 서비스 팩 3
  • Microsoft Windows 2000 Professional SP2
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
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