Cómo solucionar problemas de la instalación de Application Center 2000

Seleccione idioma Seleccione idioma
Id. de artículo: 832325 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta instalar el Service Pack 2 (SP2) de Microsoft Application Center 2000, la instalación falla y recibirá el siguiente mensaje de error:
Error 1722. Error al realizar la tarea. Hay un problema con este paquete de Windows Installer. Un programa ejecutado como parte de la instalación no finalizó como se esperaba. Póngase en contacto con el soporte técnico personal o paquete el proveedor. Acción register_CLBSetup.exe, ubicación: c:\Archivos programa\Microsoft aplicación Center\CLBSetup.exe, comando: /i acción finalizada 11:34:39: InstallFinalize. Valor devuelto 3.

Causa

Error 1722 es un error genérico de Microsoft Windows Installer que indica un error de instalación. Sin embargo, el mensaje de error no indica el motivo del error.

Si instaló previamente Microsoft Application Center 2000 en el servidor y ha quitado el programa, el problema puede producirse si no finalizó la eliminación de Application Center 2000. Algunos archivos, algunas carpetas y algunas claves del registro pueden no se quitaron de la instalación anterior de Application Center.

Solución

Esta sección describen métodos para solucionar problemas que puede utilizar para resolver problemas con la instalación de Application Center 2000 SP2.

El método que utiliza depende de si anteriormente se instaló Application Center:
  • Si instaló previamente Application Center 2000, empiece por "Método 1" y siga cada método hasta que se resuelven los problemas.
  • Si previamente no se ha instalado ninguna versión de Application Center 2000, comience por "Método 3" y siga cada método hasta que se resuelven los problemas.

Método 1: Utilizar la herramienta Acremover.exe para quitar los archivos sobrantes

Para resolver este problema, utilice la herramienta Acremover.exe para quitar los archivos, las carpetas y claves del registro que están sobrantes de la instalación anterior. Microsoft recomienda que ejecute esta herramienta tras cada error de instalación de Application Center 2000.

Para utilizar esta herramienta, el .NET Framework debe estar instalado.

Para obtener más información acerca de la herramienta Acremover.exe y cómo utilizarlo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
825436Cómo utilizar la herramienta Acremover.exe

Método 2: Quitar manualmente los archivos sobrantes

Si no está instalada .NET Framework, debe quitar manualmente los archivos, las carpetas y las claves del registro.

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para asegurarse de que se quita completamente la instalación anterior de Application Center 2000, siga estos pasos:
  1. Si los servicios siguientes que están asociados con Application Center 2000 están presentes en el equipo, detenga los servicios:
    • Servicio de administración de Application Center
    • Servicio de clúster de Application Center
    • Ayuda de Application Center registro consulta
    • Servicio de resolución de nombres de Application Center
    • Servicio de sincronización de Application Center
    • Servicio de equilibrio de carga de COM + componentes
    • MSAC y de SQLAgent $
  2. Quite las claves SQL Server Desktop Engine (MSDE) de Application Center 2000 y Microsoft Application Center siguientes del registro:
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Application Center Server
    • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSAC
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSSQL$MSAC
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SQLAGENT$MSAC
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Acadmin
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Accluster
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Aclqhelper
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Acnameres
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Acsrepl
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ComLBSvc
  3. Quitar la carpeta siguiente:
    C:\Archivos de programa\Microsoft Application Center
    Si no puede quitar la carpeta, ejecute el comando siguiente en el símbolo del sistema y, a continuación, intente quitar la carpeta nuevo:
    Msizap.exe T {20F95200 47 D 6-4CAC-92FF-5F6B29C78F88}
  4. Quitar la carpeta siguiente:
    C:\Archivos de programa\Microsoft MSAC Y de SQL Server\MSSQL $
  5. Utilice el elemento Agregar o quitar programas en el panel de control para quitar a Health Monitor.

Método 3: Instalar desde Setup.hta

Si el problema persiste después de que ha seguido los pasos anteriores para quitar los archivos sobrantes, siga estos pasos:
  1. Iniciar la instalación desde el archivo de instalador Setup.hta. El archivo Setup.hta genera un archivo de registro que se denomina Ac_setup.log y que indica error donde en la instalación. Utilizando la información de Ac_setup.log, puede seguir solucionar problemas. (El archivo Ac_setup.log normalmente se guarda en la carpeta C:\Winnt o en la carpeta C:\Windows.)

    Si inicia la instalación desde el archivo de instalador de Setup.exe, el archivo de registro no se genera y no puede proporcionarle a información acerca de la solución de problemas.
  2. Abra Ac_setup.log en un editor de texto como Bloc de notas y busque "Valor devuelto 3" .
  3. Ver el texto que aparece inmediatamente antes de "Valor devuelto 3" para indicaciones sobre códigos de error o mensajes de error.

Método 4: Revisar los errores en el archivo Ac_setup.log

Si el problema persiste después de haber seguido los pasos anteriores, puede ver el archivo Ac_setup.log para obtener más información acerca de dónde falló la instalación.

Los siguientes son dos de los errores que surgen con frecuencia:
Error 1722
Error 1722. Error al realizar la tarea. Hay un problema con este paquete de Windows Installer. Un programa ejecutado como parte de la instalación no finalizó como se esperaba. Póngase en contacto con el soporte técnico personal o paquete el proveedor. Acción register_CLBSetup.exe, ubicación: c:\Archivos programa\Microsoft aplicación Center\CLBSetup.exe, comando: /i acción finalizó 11:34:39: InstallFinalize. Valor devuelto 3.
2744 error
Error interno 2744. /i register_CLBSetup.exe, Center\CLBSetup.exe de aplicación de programa\Microsoft c:\Archivos, el programa ha experimentado un error interno. Si esta condición persiste, reinicie la aplicación o en contacto con su 14:58:44 de .Action finalizada de soporte técnico personal: InstallFinalize. Valor devuelto 3

Utilizar la herramienta ACComplusVerify para corregir los errores

Si el archivo Ac_setup.log incluye o error 1722 2744 error, ejecute la herramienta ACComplusVerify. Si se detectan componentes incorrectos, quítelas.Para obtener más información acerca de cómo ejecutar esta herramienta y acerca de cómo quitar componentes incorrectos, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
299309Cómo utilizar la herramienta ACComPlusVerify

Reparar el catálogo COM +

Si el problema persiste incluso después de ejecutar la herramienta ACComplusVerify, esto indica que un catálogo puede estar dañado. Para obtener más información acerca de cómo reparar un catálogo de COM + dañado, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
301919PRB: No se puede expandir "Mi PC" en el complemento MMC de servicios de componentes
315296Cómo limpiar un catálogo de COM + dañado
Para obtener más información acerca de otro error que puede aparecer en el archivo Ac_setup.log y cómo resolver el problema, consulte el "método 6: error adicional en Ac_setup.log" sección que aparece más adelante en este artículo.

Método 5: Determinar si un programa de terceros está defectuoso

Algunas aplicaciones de terceros parecen ocasionar problemas durante la instalación de Application Center 2000. Por ejemplo, cualquiera de los siguientes programas pueden causar el problema:
  • aSPUpload : este programa tiene la siguiente clave de registro
    ClSID\HKEY_CLASSES_ROOT\CLSID\{12BCCB9B-A6B6-4a47-A643-1C141828415C}
    El REG_DWORD sin nombre valor 2 para InprocServer32 causa el problema.
  • ASPGrid : este programa tiene la siguiente clave de registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{7100FA7E-2852-4fa5-B4B5-F422034CB1B5}
Si el problema persiste incluso después de utilizar los métodos anteriores, siga estos pasos:
  1. Cambiar el nombre la clave InprocServer32 con cualquier otro nombre y, a continuación, reinicie el servidor. Por ejemplo, utilice el nombre DummyKey .
  2. Instalar Application Center 2000.
  3. Reemplace el nombre ficticio de la clave con el nombre original, InprocServer32 y a continuación, reinicie el servidor.

Método 6: Error adicional en Ac_setup.log

El siguiente mensaje de error pueden aparecer en el archivo Ac_setup.log
Iniciar acción personalizada InstallPerfMon
Registrar los contadores de rendimiento desde sqlctr.ini
PerfmonLoad rutina devolvió el código de error 6
La acción terminó 19:55:22: InstallFinalize. Valor devuelto 3.
Para obtener más información acerca de este error y cómo resolver el problema, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
315083Error de una instalación de SQL Server Desktop Engine 2000 cuando intenta registrar los contadores del Monitor de rendimiento
296152Instalación de Application Center 2000 falla durante la instalación de MSDE
320946Servicio MSDTC debe iniciarse para instalar Application Center 2000
El mensaje de error siga se muestra en el archivo Ac_setup.log:
Acción 18: 19: 00: register_acadmin.exe. Error interno 2835. ErrorIcon, El programa SetupError experimentó un error interno. Si esta condición persiste, reinicie la aplicación o póngase en contacto con su personal de soporte técnico. Interno Error 2744. register_acadmin.exe, aplicaciones de programa\Microsoft c:\Archivos Center\AcAdmin.exe - servicio, el programa produjo un error interno. Si esta condición persiste, reinicie la aplicación o póngase en contacto con su personal de soporte técnico. La acción terminó 18: 20: 06: InstallFinalize. Valor devuelto 3. Acción 18: 20: 06: deshacer. Deshaciendo acción:
Una traza dbmon muestra lo siguiente:
00000250 182.87378513 [2208] 2260, AsaiRoot, acmetaobj.cpp, (699), [18:19:03] [0xC0140079] CAcMetaObj::WriteValues
00000251 182.87390553 [2208] 2260, AsaiRoot, appsrvobjimpl.cpp, (1063),[18:19:03] [0xC0140079] CAppSrvObjImpl::_Save 
00000252 182.87402971 [2208] 2260, AsaiRoot, acapplications.cpp, (600), [18:19:03] [0xC0140079] CAcApplications::CreateSiteApps - saving app
00000253 182.88563896 [2208] 2260, AsaiRoot, appsrvadm.cpp, (93), [18:19:03] [0xC0140079] init apps
00000254 182.88625524 [2208] 2260, AsaiRoot, appsrvadm.cpp, (165),[18:19:03] [0xC0140079] _tWinMain - Service
el problema es que un sitio Web en el servidor utiliza caracteres que no son válidos en Application Center 2000. No se permiten los caracteres siguientes:
  • <
  • >
  • \
  • "
  • '
  • +
  • &
  • %
  • [
  • ]
Cambiar el nombre de los sitios Web que incluyen caracteres que no son válidos y, a continuación, reinicie el servicio Web.

El mensaje de error siguiente se muestra en el archivo Ac_setup.log:
Acción 09:49:02: register_rdrvcapi.dll. Error de depuración: 2835: el control ErrorIcon no se encontró en diálogo Error interno de SetupError 2835. ErrorIcon, el programa SetupError experimentó un error interno. Si esta condición persiste, reinicie la aplicación o póngase en contacto con su personal de soporte técnico. Error 1722. Error al realizar la task.There es un problema con este paquete de Windows Installer. Un programa ejecutado como parte de la instalación no finalizó como se esperaba. Póngase en contacto con el soporte técnico personal o paquete el proveedor. Acción register_rdrvcapi.dll, ubicación: E:\SUPORTEDBDC\Microsoft aplicación Center\, comando: C:\WINNT\system32\regsvr32.exe /s "E:\SUPORTEDBDC\Microsoft aplicación Center\rdrvcapi.dll" acción finalizó 09:54:25: InstallFinalize. Valor devuelto 3.
Iniciar en modo a prueba de errores y, a continuación, registrar los siguientes archivos DLL desde la carpeta de sistema del CD de Application Center:
  • Msxml3.dll
  • Msxml3a.dll
  • Msxml3r.dll
El mensaje de error siga se muestra en el archivo Ac_setup.log:
Error 1722. Error al realizar la task.There es un problema con este paquete de Windows Installer. Un programa ejecutado como parte de la instalación no finalizó como se esperaba. Póngase en contacto con el soporte técnico personal o paquete el proveedor. Acción register_lcsetup.exe, ubicación: d:\Archivos programa\Microsoft aplicación Center\lcsetup.exe, comando:-instalar logcons.dll MSI (s) (CC:94) [13:03:26:351]: producto: Microsoft Application Center 2000 SP2--error 1722. Error al realizar la task.There es un problema con este paquete de Windows Installer. Un programa ejecutado como parte de la instalación no finalizó como se esperaba. Póngase en contacto con el soporte técnico personal o paquete el proveedor. Acción register_lcsetup.exe, ubicación: d:\Archivos programa\Microsoft aplicación Center\lcsetup.exe, comando:-instalar logcons.dll acción finalizó 13: 03: 26: InstallFinalize. Valor devuelto 3.
Intente ejecutar la herramienta Acremover.exe y, a continuación, ejecutar la instalación.Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
825436Cómo utilizar la herramienta Acremover.exe

Método 7: Soluciones anteriores no funcionan y sospecha que MSDE

Si ninguno de los anteriores pasos que aparecen en este artículo resuelve el problema y sospecha que el problema es debido a de la instalación de Microsoft SQL Server 2000 Desktop Engine (MSDE), considere lo siguiente:
  • Si aparece un intento de instalar MSDE antes de "Valor devuelto 3" , puede estar produciéndose el problema durante la instalación de MSDE.
  • Intente instalar Application Center 2000 sin activada la característica de sucesos y registro de rendimiento . Esta característica de registro intenta instalar MSDE. Durante la instalación de Application Center 2000, haga clic en la opción instalación personalizada y, a continuación, active la casilla de verificación eventos y registro de rendimiento .
  • Si la instalación se realiza correctamente sin activada la característica de sucesos y registro de rendimiento , el problema se produce durante la instalación de MSDE. El problema puede deberse a algunos de los bits de MSDE que son sobrantes de la eliminación anterior de Application Center 2000. Quitar los archivos sobrantes según a los pasos que se enumeran al principio de la sección "Solución".

Método 8: La cadena "SetCLBIdentity" aparece justo antes de "Valor devuelto 3"

Esta situación no se produce con frecuencia. Para obtener más información acerca de qué hacer en esta situación, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
318495No se puede instalar Application Center 2000 debido a SetCLBIdentity

Propiedades

Id. de artículo: 832325 - Última revisión: viernes, 02 de mayo de 2008 - Versión: 4.2
La información de este artículo se refiere a:
  • Microsoft Application Center 2000 Service Pack 2
  • Microsoft Application Center 2000 Standard Edition
Palabras clave: 
kbmt kbinfo KB832325 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 832325

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com