Se utiliza el modo de digitalización final en vez del modo de digitalización de vista previa cuando utiliza un escáner con Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 832344 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se utiliza un escáner para digitalizar una imagen en modo de vista previa en Microsoft Windows XP, la detección puede completarse en modo final. Como resultado, cuando intenta ver un análisis, tarda un tiempo para la imagen digitalizada mostrar porque en lugar de digitalizar la imagen en modo de vista previa (normalmente rápida), el escáner recorre la imagen en el modo de digitalización final (normalmente más lento).

Causa

Este problema se produce porque el sistema operativo Windows XP no establece correctamente el indicador que indica el escáner en el modo que se va a utilizar. Las imágenes de Windows (WIA) micro controlador del escáner no se llama para realizar una vista previa explorar debido a no puede diferenciar el modo de vista previa del modo de digitalización final.

Solución

Información de Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Microsoft Windows XP. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version        Size     File name     Platform 
   ------------------------------------------------------------------
   24-Nov-2003  19:41  5.1.2600.1321  415,232  Wiaacmgr.exe  x86   
   24-Nov-2003  21:21  5.1.2600.1321  449,536  Wiadefui.dll  x86
   24-Nov-2003  19:42  5.1.2600.1321  963,072  Wiaacmgr.exe  IA-64
   24-Nov-2003  22:03  5.1.2600.1321  911,360  Wiadefui.dll  IA-64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:". Este problema se corrigió por primera vez en el Service Pack 2 de Microsoft Windows XP.

Más información

Al digitalizar una imagen, se supone que la función de MicroEntry(..) en un controlador de micro WIA a ser llamados por el controlador de escáner plano con el argumento lCommand = CMD_SETSCANMODE para notificar el micro controlador que desea una vista previa o una digitalización final. Pero, independientemente de si intenta realizar una vista previa o un análisis final, la función MicroEntry(..) siempre se llama a con los argumentos lCommand = CMD_SETSCANMODE y pValue-> lVal = SCANMODE_FINALSCAN (modo de digitalización final). Este problema se produce porque el Asistente de análisis de WIA, establece la propiedad WIA_DPS_PREVIEW en el elemento controlador en lugar del elemento raíz. Como resultado, la función de BOOL CWIADevice::IsPreviewScan siempre devuelve el valor FALSE , y la detección se completó en el modo de digitalización final.

Para obtener información adicional acerca de WIA, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
270157Adquisición de imágenes en Windows
Para obtener información adicional acerca de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 832344 - Última revisión: jueves, 26 de octubre de 2006 - Versión: 2.5
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB832344 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 832344

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com