ModalitÓ di digitalizzazione finale viene utilizzato anzichÚ dalla modalitÓ di scansione anteprima quando si utilizza uno scanner con Windows XP

Traduzione articoli Traduzione articoli
Identificativo articolo: 832344 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando si utilizza uno scanner per digitalizzare un'immagine in modalitÓ di anteprima in Microsoft Windows XP, l'analisi pu˛ essere completata in modalitÓ finale. Di conseguenza, quando si tenta di visualizzare in anteprima una scansione, viene eseguito molto tempo per l'immagine digitalizzata visualizzare perchÚ anzichÚ la digitalizzazione dell'immagine in modalitÓ anteprima (in genere veloce), lo scanner esegue la scansione l'immagine nella modalitÓ di scansione finale (in genere pi¨ lenta).

Cause

Questo problema si verifica perchÚ il sistema operativo Windows XP non correttamente impostato il flag che indica lo scanner la modalitÓ da utilizzare. Driver per scanner di micro non viene chiamato per eseguire un'anteprima Windows Image Acquisition (WIA) analizzare, perchÚ impossibile distinguere modalitÓ anteprima dalla modalitÓ di scansione finale.

Risoluzione

Informazioni sul Service pack

Per risolvere il problema, ottenere il service pack pi¨ recente per Microsoft Windows XP. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
322389Come ottenere il service pack pi¨ recente per Windows XP

Informazioni sull'hotfix

╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico. Questo aggiornamento rapido (hotfix) potrebbe essere eseguiti ulteriori test. Se non si Ŕ notevolmente interessati da questo problema, si consiglia pertanto di attendere il successivo aggiornamento di software che contiene questo aggiornamento rapido (hotfix).

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, Ŕ necessario contattare servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.

La versione inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
   Date         Time   Version        Size     File name     Platform 
   ------------------------------------------------------------------
   24-Nov-2003  19:41  5.1.2600.1321  415,232  Wiaacmgr.exe  x86   
   24-Nov-2003  21:21  5.1.2600.1321  449,536  Wiadefui.dll  x86
   24-Nov-2003  19:42  5.1.2600.1321  963,072  Wiaacmgr.exe  IA-64
   24-Nov-2003  22:03  5.1.2600.1321  911,360  Wiadefui.dll  IA-64

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a". Questo problema Ŕ stato innanzitutto corretto in Microsoft Windows XP Service Pack 2.

Informazioni

Quando si digitalizza un'immagine, la funzione di MicroEntry(..) in un driver di micro WIA dovrebbe essere chiamato dal driver da tavolo con l'argomento lCommand = CMD_SETSCANMODE per notificare il micro driver che desidera un'anteprima o un'analisi finale. Ma, indipendentemente se si tenta di eseguire un'anteprima o un'analisi finale, viene sempre chiamata la funzione MicroEntry(..) con gli argomenti lCommand = CMD_SETSCANMODE e pValue -> lVal = SCANMODE_FINALSCAN (modalitÓ di scansione finale). Questo problema si verifica perchÚ la procedura guidata analisi di WIA imposta la proprietÓ WIA_DPS_PREVIEW l'elemento driver anzichÚ l'elemento principale. Di conseguenza, la funzione di BOOL CWIADevice::IsPreviewScan restituisce sempre il valore FALSE , e l'analisi Ŕ stata completata in modalitÓ di scansione finale.

Per ulteriori informazioni sul WIA, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
270157Acquisizione di immagini di Windows (WIA)
Per ulteriori informazioni sulla terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti Software Microsoft

ProprietÓ

Identificativo articolo: 832344 - Ultima modifica: giovedý 26 ottobre 2006 - Revisione: 2.5
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Chiavi:á
kbmt kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug KB832344 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 832344
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com