Режим сканирования используется вместо режима просмотра при использовании сканера с Windows XP

Переводы статьи Переводы статьи
Код статьи: 832344 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

При сканировании изображения в режиме предварительного просмотра в Microsoft Windows XP с помощью сканера в окончательный режим завершения сканирования. Таким образом при попытке просмотра сканирования, это занимает немного отсканированного изображения для отображения, так как вместо сканирования изображения в режиме предварительного просмотра (обычно быстрый), сканер сканирует изображение в режим сканирования (медленнее).

Причина

Эта проблема возникает, если операционная система Windows XP правильно не установлен флаг, указывающий режим, используемый сканер. Загрузки изображений (WIA) micro драйвера сканера не вызывается, чтобы выполнить предварительный просмотр сканирования, так как он не может отличить режим предварительного просмотра из режима сканирования.

Решение

Сведения о пакете обновления

Чтобы устранить эту проблему, получите последний пакет обновления для Microsoft Windows XP. Для получения дополнительных сведений щелкните следующий номер статьи базы знаний Майкрософт:
322389 Как получить последний пакет обновления для Windows XP

Сведения об исправлении

Корпорация Майкрософт выпустила исправление. Однако данное исправление предназначено для устранения проблемы, описанной в этой статье. Данное исправление только в тех системах, в которых обнаружена эта специфическая неполадка. Это исправление может проходить дополнительное тестирование. Таким образом Если вы не представляет особой эта проблема, рекомендуется отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, имеется раздел «Исправление доступно для загрузки» в верхней части статьи базы знаний. Если этот раздел не отображается, обратитесь в службу и службу поддержки для получения исправления.

Примечание Если возникают другие проблемы или необходимо устранить неполадки, возможно создать отдельный запрос на обслуживание. Затраты на обычные службы поддержки будут применяться дополнительные вопросы и проблемы, не связанные с данным исправлением, оплачиваются. Для получения полного списка телефонов службы поддержки и обслуживания клиентов корпорации Майкрософт или создать отдельный запрос посетите следующий веб-узел корпорации Майкрософт:
http://support.Microsoft.com/contactus/?ws=Support
Примечание В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если язык не отображается, значит исправления недоступна для данного языка.

Английская версия данного исправления содержит версии файлов (или более поздней версии), приведенные в следующей таблице. Дата и время для файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использовать Часовой пояс вкладку Дата и время на панели управления.
   Date         Time   Version        Size     File name     Platform 
   ------------------------------------------------------------------
   24-Nov-2003  19:41  5.1.2600.1321  415,232  Wiaacmgr.exe  x86   
   24-Nov-2003  21:21  5.1.2600.1321  449,536  Wiadefui.dll  x86
   24-Nov-2003  19:42  5.1.2600.1321  963,072  Wiaacmgr.exe  IA-64
   24-Nov-2003  22:03  5.1.2600.1321  911,360  Wiadefui.dll  IA-64

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Microsoft, перечисленных в разделе «Относится к». Сначала исправление этой проблемы появилось в пакете обновления 2 (SP2) для Windows XP.

Дополнительная информация

При сканировании изображения, MicroEntry(..) предполагается, что в micro драйвер WIA функция вызывается с аргументом драйвером устройства подачи lCommand = CMD_SETSCANMODE уведомление micro драйвера, что ему предварительного или окончательного сканирования. Но, вне зависимости от того, при попытке выполнить предварительный просмотр или окончательного сканирования MicroEntry(..) функция всегда вызывается с аргументами lCommand = CMD_SETSCANMODE, и pValue-> lVal = SCANMODE_FINALSCAN (режим сканирования). Данная проблема возникает, потому что мастер сканирования WIA WIA_DPS_PREVIEW свойство элемента драйвер вместо корневого элемента. В результате BOOL CWIADevice::IsPreviewScan функция всегда возвращает значение ЗНАЧЕНИЕ FALSE, и завершения поиска в режиме сканирования.

Для получения дополнительных сведений о WIA щелкните следующий номер статьи базы знаний Майкрософт:
270157Загрузки изображений Windows
Для получения дополнительных сведений о стандартной терминологии, используемой при описании обновлений программных продуктов Майкрософт щелкните следующий номер статьи базы знаний Майкрософт:
824684Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Свойства

Код статьи: 832344 - Последний отзыв: 16 июня 2011 г. - Revision: 4.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Ключевые слова: 
kbautohotfix kbhotfixserver kbqfe kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbmt KB832344 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:832344

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com