FIX: You receive an "HTTP 404" error message when you create an alert for a document library in the Japanese version of SharePoint Portal Server 2003

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Article ID: 832455 - View products that this article applies to.
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SYMPTOMS

In the Japanese version of Microsoft Office SharePoint Portal Server 2003, you may receive an error message after you do the following:
  1. You click a document library in a subarea of your portal site.
  2. You click Alert me in the Actions area.
  3. You configure an alert to notify you when content in the document library changes.
The error message that you receive is the following:
HTTP 404
Although you receive this error message after you click OK on the Add List Alert page, alerts are delivered as expected when content in the document library in that subarea changes.

CAUSE

This problem may occur if both the following conditions are true:
  • You use the Japanese version of Microsoft Internet Explorer.
  • The name of the subarea contains certain double-byte character set (DBCS) characters.
In this situation, the parameter for the Alert me link may be encoded and decoded incorrectly. As a result, you experience the symptoms that are described in the "Symptoms" section of this article.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest SharePoint Portal Server 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Microsoft SharePoint Portal Server 2003 Service Pack 1.

To resolve this problem, obtain the latest service pack for Microsoft SharePoint Portal Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
889380 How to obtain the latest service pack for SharePoint Portal Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
The Japanese version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Size     File name
---------------------------------------------------------------
13-Nov-2003  19:18  169,006  Schema.xml (SPSToc\Lists\Doclib)
13-Nov-2003  19:19  169,006  Schema.xml (SPSTopic\Lists\Doclib)
Note This hotfix requires Microsoft Office SharePoint Portal Server 2003.

WORKAROUND

To work around this problem, do not use the Japanese version of Internet Explorer to connect to the portal site. Instead, use the English version of Internet Explorer to connect to the portal site.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.
This problem was first corrected in SharePoint Portal Server 2003 Service Pack 1.

MORE INFORMATION

For more information about how to manage alerts on the portal site, see the "Managing Alerts" topic in the "Administration" section of the Microsoft Office SharePoint Portal Server 2003 Administration Guide. The Microsoft Office SharePoint Portal Server 2003 Administration Guide (Administrator's Help.chm) is located in the Docs folder in the root directory of the SharePoint Portal Server 2003 CD.

For more information about SharePoint Portal Server, visit the following Microsoft Web site:
http://www.microsoft.com/PRODUCTS/info/product.aspx?view=22&pcid=2f7ba03d-1762-4ae9-b059-23aa198c08fb

Properties

Article ID: 832455 - Last Review: November 15, 2007 - Revision: 3.10
APPLIES TO
  • Microsoft Office SharePoint Portal Server 2003
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbshareptportalsvr2003sp1fix kbnewfile kberrmsg kbqfe kbfix kbbug KB832455

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