Gewusst wie: Setzen Sie ein Bild auf eine Schaltfläche in InfoPath 2003 oder in InfoPath 2007

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 832511 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Zusammenfassung

Sie können ein Bild aus einer GIF-Datei auf der Vorderseite des eines Button -Steuerelements in Microsoft Office InfoPath 2007 oder in Microsoft Office InfoPath 2003 einfügen. Hierzu können Sie die Attribute der Schaltfläche in der Datei View.xsl des Formulars angeben. Sie müssen den Stil des INPUT -Elements der Datei View.xsl für das Formular ändern.

Weitere Informationen

In den folgenden Schritten beschrieben eine Stichprobe erstellen, die GIF-Datei auf einer Schaltfläche platziert. Die folgenden Schritte erfordern die Verwendung eine GIF-Datei. Eine typische Installation von Microsoft Office verfügt über einen Ordner von GIF-Dateien, denen Sie von auswählen können, damit Sie das Beispiel zu entwickeln. Standardmäßig ist der Ordner der GIF-Dateien unter c:\Programme\Microsoft Office\ClipArt\PUB60Cor am.
  1. Starten Sie InfoPath. Erstellen Sie ein leeres Formular.
  2. Klicken Sie im Aufgabenbereich Formularentwurf auf die Controls -Verknüpfung. Klicken Sie auf das Button -Steuerelement.

    Ein Button -Steuerelement wird auf dem leeren Formular angezeigt.
  3. Klicken Sie mit der rechten Maustaste auf die Schaltfläche im Formular, und klicken Sie dann auf Schaltflächeneigenschaften . Klicken Sie im Dialogfeld Schaltflächeneigenschaften auf die Registerkarte Größe , und ändern die Höhe auf 100 Pixel. Ändern Sie die Breite auf 100 Pixel. Klicken Sie auf OK .
  4. Klicken Sie in InfoPath 2007 im Menü Extras auf Ressourcendateien . Klicken Sie im Dialogfeld Ressourcendateien auf Hinzufügen . Verschieben in den Ordner, der GIF-Dateien enthält, und doppelklicken Sie dann auf die GIF-Datei, die Sie möchten. Klicken Sie auf OK , um das Dialogfeld Ressourcendateien zu schließen.

    Klicken Sie in InfoPath 2003 im Menü Extras auf Ressourcenmanager . Klicken Sie im Dialogfeld Ressourcen-Manager auf Hinzufügen . Verschieben in den Ordner, der GIF-Dateien enthält, und doppelklicken Sie dann auf die GIF-Datei, die Sie möchten. Klicken Sie auf OK , um das Dialogfeld Ressourcen-Manager zu schließen.

    Hinweis: Die Datei, die in diesem Beispiel verwendet wird AG00174_.gif.
  5. Klicken Sie im Menü Datei auf Speichern .
  6. Geben Sie im Feld Dateiname Button1 , um den Namen des Formulars zu ändern ein. Speichern Sie das Formular in einem Ordner Ihrer Wahl. Klicken Sie auf Speichern , um das Dialogfeld zu schließen.

    Hinweis: Schließen Sie nicht das Formular, das Sie entwerfen.
  7. Klicken Sie in InfoPath 2007 im Menü Datei auf Als Quelldateien speichern .

    Klicken Sie in InfoPath 2003 im Menü Datei auf Formulardateien extrahieren .
  8. Verschieben Sie im Dialogfeld Ordner suchen in den Ordner in dem Sie das Button1-Formular gespeichert. Klicken Sie auf den Ordner, und klicken Sie dann auf OK , um das Dialogfeld Ordner suchen zu schließen. Klicken Sie im Menü Datei auf Schließen , um das Formular zu schließen.
  9. Wechseln Sie in Windows Explorer zu dem Ordner, der das Formular enthält, und Dateien, die aus der Button1.xsn-Datei extrahiert wurden.

    Hinweis: Der Ordner enthält die ursprüngliche Datei Button1.xsn und die folgenden extrahierten Dateien:
    • Manifest.xsf
    • Sampledata.Xml
    • Template.Xml
    • Myschema.xsd
    • View1.xsl
  10. Öffnen Sie die View1.XSL-Datei in Editor. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie mit der rechten Maustaste auf die View1.xsl -Datei.
    2. Klicken Sie auf Öffnen mit .
    3. Klicken Sie aus den verfügbaren Optionen auf Editor .
  11. Suchen Sie in der View1.XSL-Datei, die nun im Editor geöffnet ist, die folgende Zeile des Codes:
    <input class="langFont" title="" style="WIDTH: 86px; HEIGHT: 85px" type="button" value="Button" xd:xctname="Button" 
         xd:CtrlId="CTRL1_5" tabIndex="0"/>
    From the following style attribute, copy the part that is in quotation marks:
    style="BORDER: none; BACKGROUND-IMAGE: url(yourImageHere.gif); BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat;"
    Note What you copy will look similar to the following code:
    BORDER: none; BACKGROUND-IMAGE: urlYourImageHere.gif; BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat;
    Insert what you just copied into the existing style attribute so that the completed line will now look similar to the following code:
    <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(yourImageHere.gif); 
         BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat; WIDTH: 86px; HEIGHT: 85px" type="button" 
         value="Button" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
  12. Ändern Sie den Stil URL-Wert von url(yourimageHere.gif) auf url(AG00174_.gif).

    Hinweis: Sie können auch den Dateinamen für die GIF-Datei verwenden, die Sie zuvor ausgewählt haben.

    The code that appears will look similar to the following code:
    <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(AG00174_.gif); 
         BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat; WIDTH: 86px; HEIGHT: 85px" type="button" 
         value="Button" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
  13. Speichern Sie die geänderte View1.XSL-Datei. Schließen Sie "Notepad".
  14. Verschieben Sie in den Ordner mit die Dateien, die von Button1.xsn extrahiert.

    Hinweis: Dies ist der Ordner mit der geänderten View1.XSL-Datei.
  15. Doppelklicken Sie auf Manifest.xsf , um das Formular in InfoPath öffnen.

    Hinweis: Die ursprüngliche Schaltfläche zeigt das GIF-Bild oben links auf das Wort Schaltfläche in der Mitte des Button.
  16. Schließen Sie InfoPath.
  17. Öffnen Sie in Editor die View1.XSL Datei erneut. So ändern Sie die "< input... / >" gehen Sie folgendermaßen vor, Abschnitt:
    1. Ändern Sie die Schaltflächengröße auf 100 x 100 Pixel.

      Dazu können Sie das WIDTH -Attribut des Button ändern und das HEIGHT -Attribut des Button ändern.
    2. Löscht das Wort Schaltfläche , um das Wort Schaltfläche aus die Oberfläche der Schaltfläche zu entfernen.

      Hierzu können Sie die VALUE -Attribut des Button ändern.
    3. Das GIF-Bild auf die Schaltfläche zentriert.

      Hierzu können Sie das BACKGROUND-POSITION -Attribut des Button ändern.

      Geänderte <input.../> element will look similar to the following code:
      <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(AG00174_.gif); 
           BACKGROUND-POSITION: center; BACKGROUND-REPEAT: no-repeat; WIDTH: 100px; HEIGHT: 100px" type="button" 
           value="" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
    4. Speichern Sie die geänderte View1.XSL-Datei. Schließen Sie "Notepad".
  18. Ersetzen Sie die frühere Version der Datei Manifest.xsf, mit der neueren Version der Datei Manifest.xsf.

    Hinweis: Wenn Sie die Datei Manifest.xsf doppelklicken, öffnen Sie das Formular in InfoPath. Die Änderungen sind nicht in das Formular. Dieses Verhalten tritt auf, weil die frühere Version der Datei Manifest.xsf im Cache ist. Sie müssen die frühere Version der Datei Manifest.xsf mit der aktuellen Version der Datei Manifest.xsf ersetzen. Wenden Sie hierzu eine der folgenden Methoden an:
    • Methode 1: Auf der Windows-Befehlszeile geben Sie den folgenden Befehl, und drücken Sie anschließend die [EINGABETASTE]:
      InfoPath.exe /cache clearall
    • Methode 2:
      1. Öffnen Sie die Datei Manifest.xsf im Editor.
      2. Klicken Sie im Menü Datei auf Speichern unter .

        Im Dialogfeld Speichern unter werden aufgefordert, ob Sie die vorhandene Datei mit dem gleichen Dateinamen ersetzen möchten.
      3. Klicken Sie auf Ja
    Die neuere Version der Datei Manifest.xsf weist einen neueren Zeitstempel. Wenn Sie die neuere Version der Datei Manifest.xsf doppelklicken, wird die zwischengespeicherte Datei verworfen. Die zwischengespeicherte Datei wird durch die neuere Version der Datei Manifest.xsf ersetzt. Nachdem Sie Methode 1 oder Methode 2 abgeschlossen haben, doppelklicken Sie auf die neuere Version der Datei Manifest.xsf. Sie können die neue Schaltfläche anzeigen.

Eigenschaften

Artikel-ID: 832511 - Geändert am: Dienstag, 19. Juni 2007 - Version: 2.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Office InfoPath 2007
  • Microsoft Office InfoPath 2003
  • Microsoft Office InfoPath 2003, Service Pack 1 (SP1)
Keywords: 
kbmt kbhowtomaster KB832511 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 832511
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com