Comment placer une image sur un bouton dans InfoPath 2003 ou dans InfoPath 2007

Traductions disponibles Traductions disponibles
Numéro d'article: 832511 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Résumé

Vous pouvez placer une image d'un fichier .gif sur la face d'un contrôle Button dans Microsoft Office InfoPath 2007 ou Microsoft Office InfoPath 2003. Pour cela en spécifiant les attributs de bouton dans le fichier View.xsl du formulaire. Vous devez modifier le style de l'élément INPUT du fichier View.xsl pour le formulaire.

Plus d'informations

Les étapes suivantes décrivent comment créer un exemple qui place un fichier .gif sur un bouton. Les étapes suivantes nécessitent que vous utilisiez un fichier .gif. Une installation standard de Microsoft Office dispose d'un dossier des fichiers .gif qui permet de vous aider à développer votre exemple. Par défaut, le dossier des fichiers .gif est situé dans C:\Program Files\Microsoft Office\ClipArt\PUB60Cor.
  1. Démarrer InfoPath. Créez un formulaire vierge.
  2. Dans le volet Office Tâches de création , cliquez sur le lien contrôles . Cliquez sur le contrôle de bouton .

    Un contrôle bouton s'affiche sur le formulaire vierge.
  3. Cliquez avec le bouton droit le bouton sur le formulaire, puis cliquez sur Propriétés du bouton . Dans la boîte de dialogue Propriétés du bouton , cliquez sur l'onglet Taille de modifier la hauteur à 100 pixels. Modifier la largeur à 100 pixels. Cliquez sur OK .
  4. Dans InfoPath 2007, cliquez sur fichiers de ressources dans le menu Outils . Dans la boîte de dialogue fichiers de ressources , cliquez sur Ajouter . Déplacer vers le dossier qui contient les fichiers .gif et double-cliquez sur le fichier .gif souhaité. Cliquez sur OK pour fermer la boîte de dialogue fichiers de ressources .

    Dans InfoPath 2003, cliquez sur Gestionnaire des ressources dans le menu Outils . Dans la boîte de dialogue Gestionnaire de ressources , cliquez sur Ajouter . Déplacer vers le dossier qui contient les fichiers .gif et double-cliquez sur le fichier .gif souhaité. Cliquez sur OK pour fermer la boîte de dialogue Gestionnaire des ressources .

    note Le fichier qui est utilisé dans cet exemple est AG00174_.gif.
  5. Dans le menu Fichier , cliquez sur Enregistrer .
  6. Dans la zone Nom de fichier , tapez Button1 pour modifier le nom de l'écran. Enregistrez le formulaire dans un dossier de votre choix. Cliquez sur Enregistrer pour fermer la boîte de dialogue Enregistrer sous .

    note Ne fermez pas le formulaire que vous créez.
  7. Dans InfoPath 2007, cliquez sur Enregistrer en tant que fichiers source dans le menu Fichier .

    Dans InfoPath 2003, cliquez sur Extraire les fichiers de formulaires dans le menu Fichier .
  8. Dans la boîte de dialogue Rechercher un dossier , déplacer vers le dossier dans lequel vous avez enregistré le formulaire Button1. Cliquez sur le dossier, puis cliquez sur OK pour fermer la boîte de dialogue Rechercher un dossier . Dans le menu Fichier , cliquez sur Fermer pour fermer le formulaire.
  9. Dans l'Explorateur Windows, déplacer vers le dossier qui contient le formulaire et les fichiers qui ont été extraits à partir du fichier Button1.xsn.

    note Le dossier contient le fichier Button1.xsn d'origine et les fichiers extraits suivants :
    • Manifest.xsf
    • Sampledata.XML
    • Template.xml
    • Myschema.xsd
    • View1.xsl
  10. Ouvrez le fichier View1.xsl dans le bloc-notes. Pour ce faire, procédez comme suit :
    1. Cliquez avec le bouton droit sur le fichier View1.xsl .
    2. Cliquez sur Ouvrir avec .
    3. Cliquez sur le bloc-notes dans les options disponibles.
  11. Dans le fichier View1.xsl qui est désormais ouvert dans le bloc-notes, recherchez la ligne de code suivante :
    <input class="langFont" title="" style="WIDTH: 86px; HEIGHT: 85px" type="button" value="Button" xd:xctname="Button" 
         xd:CtrlId="CTRL1_5" tabIndex="0"/>
    à partir de l'attribut de style suivant, copiez la partie de guillemets :
    style="BORDER: none; BACKGROUND-IMAGE: url(yourImageHere.gif); BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat;"
    Remarque que vous copiez ressemblera au code suivant :
    BORDER: none; BACKGROUND-IMAGE: urlYourImageHere.gif; BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat;
    insérer ce que vous venez de copier dans l'attribut style existant pour que la ligne terminée maintenant apparaisse similaire au code suivant :
    <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(yourImageHere.gif); 
         BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat; WIDTH: 86px; HEIGHT: 85px" type="button" 
         value="Button" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
  12. Remplacez la valeur D'URL style url(yourimageHere.gif) url(AG00174_.gif).

    note Vous pouvez également utiliser le nom de fichier pour le fichier .gif que vous avez précédemment choisi.

    Le code qui s'affiche est similaire au code suivant :
    <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(AG00174_.gif); 
         BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat; WIDTH: 86px; HEIGHT: 85px" type="button" 
         value="Button" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
  13. Enregistrer le fichier View1.xsl modifié. Fermez le Bloc-notes.
  14. Déplacer vers le dossier contient les fichiers que vous avez extraits de Button1.xsn.

    note C'est le dossier avec le fichier View1.xsl modifié.
  15. Double-cliquez sur Manifest.xsf pour ouvrir le formulaire dans InfoPath.

    note Le bouton d'origine indique l'image .gif à l'angle supérieur gauche avec le bouton au centre du bouton mot.
  16. Fermez InfoPath.
  17. Dans le bloc-notes, rouvrez le fichier View1.xsl. Pour modifier le « < entrée... / > « section, procédez comme suit :
    1. Modifier la taille de bouton à 100 pixels à 100 pixels.

      Vous pouvez le faire en modifiant l'attribut WIDTH du bouton et en modifiant l'attribut hauteur du bouton.
    2. Supprimer le mot bouton pour supprimer le mot bouton de l'image du bouton.

      Pour cela en modifiant l'attribut VALUE d'un bouton.
    3. Centrer l'image .gif sur le bouton.

      Pour cela en modifiant l'attribut poste de l'arrière-plan du bouton.

      Le <input.../> modifiéélément ressemblera au code suivant :
      <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(AG00174_.gif); 
           BACKGROUND-POSITION: center; BACKGROUND-REPEAT: no-repeat; WIDTH: 100px; HEIGHT: 100px" type="button" 
           value="" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
    4. Enregistrer le fichier View1.xsl modifié. Fermez le Bloc-notes.
  18. Remplacer la version antérieure du fichier manifest.xsf par la version plus récente du fichier manifest.xsf.

    note Si vous double-cliquez sur le fichier manifest.xsf, vous ouvrez le formulaire dans InfoPath. Les modifications ne sont pas dans l'écran. Ce problème se produit car la version antérieure du fichier manifest.xsf est dans le cache. Vous devez remplacer la version antérieure du fichier manifest.xsf avec la version actuelle du fichier manifest.xsf. Pour cela, appliquez une des méthodes suivantes :
    • Méthode 1: sur la ligne de commande Windows, tapez la commande suivante et appuyez sur ENTRÉE :
      InfoPath.exe /cache clearall
    • Méthode 2 :
      1. Ouvrez le fichier manifest.xsf dans le bloc-notes.
      2. Dans le menu Fichier , cliquez sur Enregistrer sous .

        La boîte de dialogue Enregistrer sous invite indiquer si vous souhaitez remplacer le fichier existant portant le même nom de fichier.
      3. Cliquez sur Oui
    La version plus récente du fichier manifest.xsf a un horodatage plus récent. Par conséquent, lorsque vous double-cliquez sur la version plus récente du fichier manifest.xsf, le fichier mis en cache est ignoré. Le fichier mis en cache est remplacé par la version plus récente du fichier manifest.xsf. Après avoir effectué la méthode 1 ou 2 de méthode, double-cliquez sur la version plus récente du fichier manifest.xsf. Vous pouvez voir le nouveau bouton.

Propriétés

Numéro d'article: 832511 - Dernière mise à jour: mardi 19 juin 2007 - Version: 2.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office InfoPath 2007
  • Microsoft Office InfoPath 2003
  • Microsoft Office InfoPath 2003, Service Pack 1 (SP1)
Mots-clés : 
kbmt kbhowtomaster KB832511 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 832511
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com