Jak umieścić obraz na przycisku w programie InfoPath 2003 lub w programie InfoPath 2007

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 832511 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Streszczenie

Możesz umieścić obraz z pliku GIF z Przycisk kontroli w programie Microsoft Office InfoPath 2007 lub Microsoft Office InfoPath 2003. Można to zrobić przez określenie atrybutów przycisku w pliku View.xsl formularza. Należy zmodyfikować styl DANE WEJŚCIOWE element View.xsl pliku formularza.

Więcej informacji

Poniżej opisano sposób budowania próbkę umieszcza plik .gif na przycisku. Poniższe czynności wymagają, użyj pliku GIF. Typowej instalacji pakietu Microsoft Office ma folder plików GIF, które można wybierać, aby ułatwić opracowanie na przykład. Domyślnie folder plików GIF znajduje się w katalogu C:\Program Files\Microsoft Office\ClipArt\PUB60Cor.
  1. Uruchom program InfoPath. Utwórz pusty formularz.
  2. W Projektuj zadania kliknij polecenie okienko zadań Formanty łącze. Kliknij przycisk Przycisk formant.

    A Przycisk formant jest widoczny na pusty formularz.
  3. Kliknij prawym przyciskiem myszy Przycisk na formularzu, a następnie kliknij Właściwości przycisku. W Właściwości przycisku okno dialogowe, kliknij przycisk Rozmiar kartę i Zmień wysokość na 100 pikseli. Zmień szerokość 100 pikseli. Kliknij przycisk OK.
  4. W programie InfoPath 2007 kliknij przycisk Pliki zasobów na Narzędzia menu. W Pliki zasobów okno dialogowe, kliknij przycisk Dodawanie. Przenieś do folderu zawierającego pliki GIF i kliknij dwukrotnie żądany plik GIF. Kliknij przycisk OK Aby zamknąć Pliki zasobów okno dialogowe.

    W programie InfoPath 2003 kliknij przycisk Menedżer zasobów na Narzędzia menu. W Menedżer zasobów okno dialogowe, kliknij przycisk Dodawanie. Przenieś do folderu zawierającego pliki GIF i kliknij dwukrotnie żądany plik GIF. Kliknij przycisk OK Aby zamknąć Menedżer zasobów okno dialogowe.

    Uwaga Plik, który jest używany w tym przykładzie jest AG00174_.gif.
  5. Na Plik menu, kliknij przycisk Zapisz.
  6. W Nazwa pliku pole typu Button1 Aby zmienić nazwę formularza. Zapisz formularz w folderze wybranym. Kliknij przycisk Zapisz Aby zamknąć Zapisz jako okno dialogowe.

    Uwaga Nie zamykaj formularza, które są projektowania.
  7. W programie InfoPath 2007 kliknij przycisk Zapisz jako pliki źródłowe na Plik menu.

    W programie InfoPath 2003 kliknij przycisk Wyodrębnij pliki formularza na Plik menu.
  8. W Przeglądanie w poszukiwaniu folderu okno dialogowe Przejdź do folderu, w którym zapisany jest formularz Button1. Kliknij folder, a następnie kliknij przycisk OK Aby zamknąć Przeglądanie w poszukiwaniu folderu okno dialogowe. Na Plik menu, kliknij przycisk Zamknij Aby zamknąć formularz.
  9. W Eksploratorze Windows przenieś do folderu, który zawiera formularz i pliki, które zostały wyodrębnione z pliku Button1.xsn.

    Uwaga Folder zawiera oryginalny plik Button1.xsn i wyodrębnione następujące pliki:
    • Manifest.xsf
    • SampleData.XML
    • Template.XML
    • Myschema.xsd
    • View1.xsl
  10. Otwórz plik View1.xsl w Notatniku. Aby to zrobić, wykonaj następujące kroki:
    1. Kliknij prawym przyciskiem myszyView1.xsl plik.
    2. Kliknij przycisk Otwórz za pomocą.
    3. Kliknij przycisk Notatnik z dostępnych opcji.
  11. W pliku View1.xsl, który jest obecnie otwarty w programie Notatnik zlokalizuj następujący wiersz kodu:
    <input class="langFont" title="" style="WIDTH: 86px; HEIGHT: 85px" type="button" value="Button" xd:xctname="Button" 
         xd:CtrlId="CTRL1_5" tabIndex="0"/>
    Kopiowanie części, które jest ujęte w znaki cudzysłowu następującego atrybutu stylu:
    style="BORDER: none; BACKGROUND-IMAGE: url(yourImageHere.gif); BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat;"
    Uwaga Możesz skopiować będzie wyglądać podobnie do następującego kodu:
    BORDER: none; BACKGROUND-IMAGE: urlYourImageHere.gif; BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat;
    Wstaw skopiowanym do istniejącego atrybutu stylu tak wypełnionego linii będzie wyglądać następujący kod:
    <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(yourImageHere.gif); 
         BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat; WIDTH: 86px; HEIGHT: 85px" type="button" 
         value="Button" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
  12. Zmień wartość adresu URL styl z URL(yourimageHere.gif) do url(AG00174_.gif).

    Uwaga Można również użyć nazwy pliku dla plików GIF, które wybrano wcześniej.

    Kod, który pojawia się będzie wyglądać podobnie do następującego kodu:
    <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(AG00174_.gif); 
         BACKGROUND-POSITION: left top; BACKGROUND-REPEAT: no-repeat; WIDTH: 86px; HEIGHT: 85px" type="button" 
         value="Button" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
  13. Zapisz zmodyfikowany plik View1.xsl. Zamknij Notatnik.
  14. Przenieś do folderu zawierającego pliki, które zostały wyodrębnione z Button1.xsn.

    Uwaga Jest to folder z zmodyfikowany plik View1.xsl.
  15. Kliknij dwukrotnie ikonę Manifest.xsf Aby otworzyć formularz w programie InfoPath.

    Uwaga Przycisk oryginał zawiera obraz .gif w lewym górnym ze słowem Przycisk w Centrum przycisku.
  16. Zamknij program InfoPath.
  17. W Notatniku otwórz plik View1.xsl. Aby zmodyfikować "<input .="" .="" ./="">"sekcji, wykonaj następujące kroki:
    1. Zmień rozmiar przycisku na 100 pikseli na 100 pikseli.

      Można to zrobić, zmienianie SZEROKOŚĆ atrybut przycisku i zmieniając WYSOKOŚĆ Atrybut ten przycisk.
    2. Usuń wyraz Przycisk Aby usunąć wyraz Przycisk od nominalnej przycisku.

      Można to zrobić, zmienianie WARTOŚĆ Atrybut ten przycisk.
    3. Wyśrodkować obraz .gif na przycisku.

      Można to zrobić, zmienianie POZYCJA TŁA Atrybut ten przycisk.

      Zmiany <input...></input...> element będzie wyglądać podobnie do następującego kodu:
      <input class="langFont" title="" style="BORDER: none; BACKGROUND-IMAGE: url(AG00174_.gif); 
           BACKGROUND-POSITION: center; BACKGROUND-REPEAT: no-repeat; WIDTH: 100px; HEIGHT: 100px" type="button" 
           value="" xd:xctname="Button" xd:CtrlId="CTRL1_5" tabIndex="0"/>
    4. Zapisz zmodyfikowany plik View1.xsl. Zamknij Notatnik.
  18. Zastąpić starszą wersję pliku Manifest.xsf nowszą wersję pliku Manifest.xsf.

    Uwaga Jeśli zostanie dwukrotnie kliknięty plik Manifest.xsf, otwórz formularz w programie InfoPath. Zmiany nie są w formularzu. To zachowanie występuje, ponieważ jest starsza wersja pliku Manifest.xsf w pamięci podręcznej. Starsza wersja pliku Manifest.xsf musi zastąpić bieżącą wersję pliku Manifest.xsf. Aby to zrobić, użyj jednej z następujących metod:
    • Metoda 1: W wierszu polecenia systemu Windows, wpisz następujące polecenie, a następnie naciśnij klawisz ENTER:
      InfoPath.exe /cache clearall
    • Metoda 2:
      1. Otwórz plik Manifest.xsf w Notatniku.
      2. Na Plik menu, kliknij przycisk Zapisz jako.

        W Zapisz jako okno dialogowe monitujące czy chcesz zastąpić istniejący plik o tej samej nazwie pliku.
      3. Kliknij przycisk Tak
    Nowsza wersja pliku Manifest.xsf ma nowszą sygnaturę czasową. W związku z tym kiedy dwukrotnie nowszą wersję pliku Manifest.xsf plików w pamięci podręcznej jest odrzucany. Buforowany plik zostanie zastąpiona nowszą wersję pliku Manifest.xsf. Po ukończeniu metody 1 lub metody 2, kliknij dwukrotnie nowszą wersję pliku Manifest.xsf. Można wyświetlić przycisk Nowy.

Właściwości

Numer ID artykułu: 832511 - Ostatnia weryfikacja: 22 września 2011 - Weryfikacja: 3.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office InfoPath 2007
  • Microsoft Office InfoPath 2003
Słowa kluczowe: 
kbhowtomaster kbmt KB832511 KbMtpl
Przetłumaczone maszynowo
WAŻNE: Ten artykuł nie został przetłumaczony przez człowieka, tylko przez oprogramowanie do tłumaczenia maszynowego firmy Microsoft. Firma Microsoft oferuje zarówno artykuły tłumaczone przez ludzi, jak i artykuły tłumaczone maszynowo, dzięki czemu każdy użytkownik może uzyskać dostęp do całej zawartości bazy wiedzy Knowledge Base we własnym języku. Prosimy jednak pamiętać, że artykuły przetłumaczone maszynowo nie zawsze są doskonałe. Mogą zawierać błędy słownictwa, składni i gramatyki, przypominające błędy robione przez osoby, dla których język użytkownika nie jest językiem ojczystym. Firma Microsoft nie odpowiada za wszelkie nieścisłości, błędy lub szkody spowodowane nieprawidłowym tłumaczeniem zawartości oraz za wykorzystanie tej zawartości przez klientów. Oprogramowanie do tłumaczenia maszynowego jest często aktualizowane przez firmę Microsoft.
Anglojęzyczna wersja tego artykułu to:832511

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com