Dochází ke snížení výkonu systému nebo počítač přestane reagovat z důvodu nevracení paměti do stránkovaného fondu v systému Windows 2000 SP4 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 832762 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Po instalaci Windows 2000 Service Pack 4 (SP4) může dojít k výkonu systému pomalé nebo může počítač přestat reagovat.

Pokud máte Microsoft Message Queuing nainstalována, program front přestat odesílání a přijímání zpráv, protože program nemá dostatek prostředků. V protokolu událostí aplikace mohou být zaznamenány události, které jsou přidruženy front, které obsahují kódy chyb 0xc00e0027 a 0xc000009a.

Pokud zapnout značkování prozkoumat nevracení paměti možných označuje značkování výstup, značky fondu "Toke" používá velké množství paměti stránkovaného fondu.

Příčina

K tomuto problému dochází kvůli regresní byla zavedena v Microsoft Windows 2000 SP4. Aktualizace tento problém způsobuje zahrnuje změnu "zosobnit klienta po ověření „ uživatelské právo.

Poznámka: SeImpersonatePrivilege uživatelské právo je známá také jako uživatelské právo "Po ověření zosobnit klienta". Další informace o SeImpersonatePrivilege uživatelské právo klepněte na následující číslo článku databáze Microsoft Knowledge Base:
821546Přehled "Zosobnit klienta po ověření a" a "Vytvoření globálních objektů" nastavení zabezpečení
Po instalaci systému Windows 2000 SP4 nevracení paměti může dojít, když program provede volání funkce RpcImpersonateClient a funkce RpcRevertToSelf pomocí explicitní pověření. Dodaná downgrades straně serveru z zosobnění na identitu, pokud kontext explicitní uživatele dochází v paměti stránkovaného fondu k toto nevracení paměti.

Řešení

Informace o opravě hotfix

K dispozici je podporovaná oprava hotfix od společnosti Microsoft. Tato oprava hotfix je však určena pouze k opravě problému popsanému v tomto článku. Použijte tuto opravu hotfix pouze u systémů, kde dochází k tomuto konkrétnímu problému.

Pokud je oprava hotfix k dispozici ke stažení, v horní části tohoto článku je sekce "Hotfix stažení k dispozici". Není-li tato část uvedena, vyžádejte si tuto opravu hotfix od oddělení služeb zákazníkům a podpory společnosti Microsoft.

Poznámka: Pokud vyskytnout další problémy nebo jakékoli řešení potíží je vyžadován, pravděpodobně budete muset vytvořit zvláštní požadavek na službu. Výdaje na technickou podporu se týkají dalších otázek a problémů, které nelze vyřešit pomocí této opravy konkrétní opravy hotfix. Navštivte následující web společnosti Microsoft pro získání telefonního čísla na Zákaznické centrum, nebo pokud chcete vytvořit samostatnou žádost o podporu:
http://support.microsoft.com/contactus/?ws=support
Poznámka: Zobrazí formulář "Hotfix stažení k dispozici" jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, oprava hotfix není k dispozici pro daný jazyk.

Požadavky

Tato oprava hotfix vyžaduje Service Pack 3 (SP3) nebo novější.

Požadavek na restartování

Po instalaci této opravy hotfix je třeba restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava Hotfix nenahrazuje žádné další opravy Hotfix.

INFORMACE O SOUBORECH

Anglická verze této opravy hotfix má následující nebo vyšší atributy souborů. Data a časy jednotlivých souborů jsou uvedeny ve formátu UTC (Coordinated Universal Time). Pokud zobrazíte informace o souboru, bude převedena na místní čas. Rozdíl mezi místním ČASEM a najít, použijte kartu časové pásmo v ovládacím panelu Datum a čas.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   21-Sep-2003  00:36  5.0.2195.6824      29,712  Mountmgr.sys
   25-Nov-2003  18:27  5.0.2195.6876   1,699,136  Ntkrnlmp.exe     
   25-Nov-2003  18:27  5.0.2195.6876   1,698,432  Ntkrnlpa.exe     
   25-Nov-2003  18:27  5.0.2195.6876   1,719,232  Ntkrpamp.exe     
   25-Nov-2003  18:27  5.0.2195.6876   1,676,736  Ntoskrnl.exe   

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v produktech společnosti, které jsou uvedeny v části "Platí pro" v tomto článku.

Další informace

Problém popsaný v části "Příznaky", pokud jste nainstalovali systém Windows 2000 SP4 nebo žádné opravy hotfix vydané po aktualizaci Windows 2000 Service Pack 3 (SP3), které zahrnuty soubor Ntoskrnl.exe je počátečního setkat 25. listopadu 2002 nebo novější. Tento problém je pevné verze Ntoskrnl.exe datem 25. listopadu 2003 nebo novější. Další informace o značkování zapnout klepnutím na následující číslo článku databáze Microsoft Knowledge Base:
177415Použití nástroje Memory Pool Monitor (Poolmon.exe) k odstraňování potíží s nevracením paměti v režimu jádra
Další informace o přidělování názvů balíčkům s opravami Hotfix získáte v následujícím článku databáze Microsoft Knowledge Base:
816915Nové schéma přidělování názvů balíčkům aktualizací softwaru pro systém Microsoft Windows (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
Další informace získáte v následujícím článku znalostní báze Microsoft Knowledge Base:
824684Popis standardní terminologie používané při popisu aktualizací softwaru společnosti Microsoft


Pomoc s problémy výkonu systému Windows Vista navštivte následující webovou stránku společnosti Microsoft:
Problems with overall system speed and system performance

Vlastnosti

ID článku: 832762 - Poslední aktualizace: 26. října 2006 - Revize: 2.6
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4
  • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows 2000 Professional SP4
Klíčová slova: 
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB832762 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:832762

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com