Rendimiento lento del sistema o el equipo deja de responder debido a una pérdida de memoria en la memoria de bloque paginado en Windows 2000 SP4

Seleccione idioma Seleccione idioma
Id. de artículo: 832762 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de instalar Microsoft Windows 2000 Service Pack 4 (SP4), puede experimentar rendimiento lento del sistema o el equipo puede dejar de responder.

Si tiene instalado Microsoft Message Queue Server, el programa Message Queue Server puede dejar de enviar y recibir mensajes porque el programa no tiene suficientes recursos. Eventos que están asociados con Message Queue Server que incluyen los códigos de error 0xc00e0027 y 0xc000009a pueden anotarse en el registro de sucesos de aplicación.

Si activa el etiquetado para investigar una pérdida de memoria posible, el etiquetado de salida indica que la etiqueta de grupo "Toke" está utilizando una gran cantidad de memoria de bloque paginado.

Causa

Este problema se produce debido a una regresión que se introdujo en Microsoft Windows 2000 SP4. La actualización que causa el problema implica un cambio en el derecho de usuario "Suplantar a un cliente tras la autenticación".

Nota El derecho de usuario "Suplantar a un cliente tras la autenticación" es también conocido como el derecho de usuario SeImpersonatePrivilege. Para obtener información adicional acerca del derecho de usuario SeImpersonatePrivilege, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
821546Información general sobre la configuración de seguridad "Crear objetos globales" y "Suplantar un cliente tras la autenticación"
Después de instalar Windows 2000 SP4, se puede producir una pérdida de memoria cuando un programa hace una llamada a la función RpcImpersonateClient y a la función RpcRevertToSelf con credenciales explícitas. Esta pérdida de memoria se produce en la memoria de bloque paginado cuando se suministra el deterioro del lado servidor desde suplantación a identidad si un contexto de usuario explícito.

Solución

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, enviar una solicitud de servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si se requiere cualquier solución de problemas, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión específica. Para obtener una lista completa de servicio de atención al cliente y soporte números de teléfono o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponible" muestra los idiomas para el que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Esta revisión requiere Windows 2000 Service Pack 3 (SP3) o posterior.

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo enumerados en la siguiente tabla u otros posteriores. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para buscar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   21-Sep-2003  00:36  5.0.2195.6824      29,712  Mountmgr.sys
   25-Nov-2003  18:27  5.0.2195.6876   1,699,136  Ntkrnlmp.exe     
   25-Nov-2003  18:27  5.0.2195.6876   1,698,432  Ntkrnlpa.exe     
   25-Nov-2003  18:27  5.0.2195.6876   1,719,232  Ntkrpamp.exe     
   25-Nov-2003  18:27  5.0.2195.6876   1,676,736  Ntoskrnl.exe   

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Más información

Puede experimentar el problema que se describe en la sección "Síntomas" Si instaló Windows 2000 SP4 o cualquier hotfix de Service Pack 3 (SP3) de posteriores a Windows 2000 que incluyen el archivo Ntoskrnl.exe que es con fecha 25-Nov-2002 o posterior. Este problema es fija en la versión de Ntoskrnl.exe con fecha de 25-Nov-2003 o posterior. Para obtener información adicional acerca de cómo activar etiquetado, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
177415Pérdidas de cómo utilizar a Memory Pool Monitor (Poolmon.exe) para solucionar problemas de memoria de modo de núcleo
Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft


Para obtener ayuda con problemas de rendimiento del sistema en Windows Vista, visite la siguiente página web de Microsoft:
Problems with overall system speed and system performance

Propiedades

Id. de artículo: 832762 - Última revisión: jueves, 26 de octubre de 2006 - Versión: 2.6
La información de este artículo se refiere a:
  • Service Pack 3 de Microsoft Windows 2000
  • Microsoft Windows 2000 Server SP4
  • Microsoft Windows 2000 Advanced Server SP3
  • Microsoft Windows 2000 Advanced Server SP4
  • Service Pack 3 de Microsoft Windows 2000
  • Microsoft Windows 2000 Professional SP4
Palabras clave: 
kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000presp5fix KB832762 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 832762

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com